Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Transitioning from chapter to chapter results in video stopping

kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

For a while now, when playing certain MKV files I've ripped (in this case Rick and Morty), when the video transitions from chapter to chapter, the audio drops and then the playback stops. I have to hit fast forward to get things going again. With Rick and Morty, the video codec is VC-1 and the audio is TrueHD 5.1. When it drops, the Shield TV log show this:

01-15 15:46:27.292  w: [pms] Socket exception detected
01-15 15:46:27.295  w: [pms] Client closed the channel
01-15 15:46:27.297  i: [pms] /127.0.0.1:40086 - GET /proxy
01-15 15:46:27.298  i: [Proxy] Request received: https://10.45.19.50:32400/library/parts/19883/1474902541/file.mkv?autoAdjustQuality=0&hasMDE=1&location=lan&mediaBufferSize=25856&X-Plex-Client-Identifier=2bf26839342818ff-com-plexapp-android&X-Plex-Supported-Commands=abort&X-Plex-Token=...fTs2
01-15 15:46:27.360  i: [Proxy] Response: 206
01-15 15:46:27.397  w: [pms] Socket exception detected
01-15 15:46:27.400  w: [pms] Client closed the channel
01-15 15:46:27.714  i: [Exo1VideoPlayer] Video size is now 1920x1080
01-15 15:46:27.714  i: [video] Video size is now 1920x1080
01-15 15:46:27.718  i: [video] Scaling video view to 1920x1080
01-15 15:46:27.718  i: [VideoOverlay] Video player size changed (1920, 1080)
01-15 15:46:27.718  i: [Exo1VideoPlayer] Drawn to surface detected.
01-15 15:46:27.718  i: [video] Video start detected
01-15 15:46:27.751  i: [video] Video has started.
01-15 15:46:27.752  i: [TranscodeSession] Updating session status
01-15 15:46:27.756  i: [TranscodeSession] Direct Play
01-15 15:46:27.758  i: Fetching [method:GET] https://10.45.19.50:32400/:/timeline?bandwidth=13556&bufferedTime=0&containerKey=%2FplayQueues%2F332&duration=1376896&guid=com.plexapp.agents.thetvdb%3A%2F%2F275274%2F2%2F7%3Flang%3Den&key=%2Flibrary%2Fmetadata%2F20068&location=lan&machineIdentifier=7c32ba49023a1901017e64f284c3f38efbb386b4&playQueueItemID=1441&ratingKey=20068&state=playing&time=614467&timeToFirstFrame=0&X-Plex-Client-Identifier=2bf26839342818ff-com-plexapp-android&X-Plex-Token=...fTs2
01-15 15:46:27.818  i: [Exo1VideoPlayer] Player state changed: 4, Restarting: true
01-15 15:46:27.818  i: [ExoVideoPlayer] Found new stream via index.
01-15 15:46:27.818  i: [ExoVideoPlayer] Selecting track (1 / 0)
01-15 15:46:27.818  i: [ExoVideoPlayer] Selecting track (2 / -1)
01-15 15:46:29.011  i: [ThemeMusic] Fade out complete. Stopping media player.
01-15 15:46:34.117  i: [ExoVideoPlayer] Seeking to 610604ms
01-15 15:46:34.124  i: [Exo1VideoPlayer] Player state changed: 3, Restarting: true
01-15 15:46:34.221  i: [pms] /127.0.0.1:60686 - GET /proxy
01-15 15:46:34.222  i: [Proxy] Request received: https://10.45.19.50:32400/library/parts/19883/1474902541/file.mkv?autoAdjustQuality=0&hasMDE=1&location=lan&mediaBufferSize=25856&X-Plex-Client-Identifier=2bf26839342818ff-com-plexapp-android&X-Plex-Supported-Commands=abort&X-Plex-Token=...fTs2
01-15 15:46:34.228  i: [Exo1VideoPlayer] Bandwidth sample, Elapsed: 6854, Bytes: 43053800, Bitrate: 50252464
01-15 15:46:34.292  i: [Proxy] Response: 206
01-15 15:46:34.326  w: [pms] Client closed the channel
01-15 15:46:34.327  w: [pms] Client closed the channel
01-15 15:46:34.330  w: [pms] Socket exception detected
01-15 15:46:34.567  i: [Exo1VideoPlayer] Player state changed: 4, Restarting: true
01-15 15:46:34.648  i: [ExoVideoPlayer] Seeking to 600610ms
01-15 15:46:34.652  i: [Exo1VideoPlayer] Player state changed: 3, Restarting: true
01-15 15:46:34.751  i: [Exo1VideoPlayer] Bandwidth sample, Elapsed: 456, Bytes: 10832118, Bitrate: 190037152
01-15 15:46:34.754  i: [pms] /127.0.0.1:58626 - GET /proxy
01-15 15:46:34.756  i: [Proxy] Request received: https://10.45.19.50:32400/library/parts/19883/1474902541/file.mkv?autoAdjustQuality=0&hasMDE=1&location=lan&mediaBufferSize=25856&X-Plex-Client-Identifier=2bf26839342818ff-com-plexapp-android&X-Plex-Supported-Commands=abort&X-Plex-Token=...fTs2
01-15 15:46:34.827  i: [Proxy] Response: 206
01-15 15:46:34.856  w: [pms] Socket exception detected
01-15 15:46:34.857  e: [Exo1VideoPlayer] Player error detected
01-15 15:46:34.858  e: An exception occurred: com.google.android.exoplayer.j: com.google.android.exoplayer.a.i: AudioTrack init failed: 0, Config(48000, 252, 49152)
01-15 15:46:34.858  e: Stacktrace: com.google.android.exoplayer.j: com.google.android.exoplayer.a.i: AudioTrack init failed: 0, Config(48000, 252, 49152)
    at com.google.android.exoplayer.t.a(SourceFile:383)
    at com.google.android.exoplayer.w.b(SourceFile:954)
    at com.google.android.exoplayer.w.a(SourceFile:528)
    at com.google.android.exoplayer.am.a(SourceFile:128)
    at com.google.android.exoplayer.p.j(SourceFile:432)
    at com.google.android.exoplayer.p.handleMessage(SourceFile:211)
    at android.os.Handler.dispatchMessage(Handler.java:100)
    at android.os.Looper.loop(Looper.java:148)
    at android.os.HandlerThread.run(HandlerThread.java:61)
    at com.google.android.exoplayer.g.y.run(SourceFile:40)
Caused by: com.google.android.exoplayer.a.i: AudioTrack init failed: 0, Config(48000, 252, 49152)
    at com.google.android.exoplayer.a.e.p(SourceFile:914)
    at com.google.android.exoplayer.a.e.a(SourceFile:481)
    at com.google.android.exoplayer.t.a(SourceFile:375)
    ... 9 more

01-15 15:46:34.862  w: [pms] Client closed the channel
01-15 15:46:34.881  i: [video] Error detected during playback
01-15 15:46:34.886  i: [Exo1VideoPlayer] Player state changed: 1, Restarting: true
01-15 15:46:34.887  i: Fetching [method:GET] https://10.45.19.50:32400/:/timeline?bandwidth=185583&bufferedTime=0&containerKey=%2FplayQueues%2F332&duration=1376896&guid=com.plexapp.agents.thetvdb%3A%2F%2F275274%2F2%2F7%3Flang%3Den&key=%2Flibrary%2Fmetadata%2F20068&machineIdentifier=7c32ba49023a1901017e64f284c3f38efbb386b4&playQueueItemID=1441&ratingKey=20068&state=stopped&time=600610&X-Plex-Client-Identifier=2bf26839342818ff-com-plexapp-android&X-Plex-Token=...fTs2
01-15 15:46:34.946  i: Fetching [method:GET] https://10.45.19.50:32400/:/timeline?bandwidth=185583&bufferedTime=0&containerKey=%2FplayQueues%2F332&duration=1376896&guid=com.plexapp.agents.thetvdb%3A%2F%2F275274%2F2%2F7%3Flang%3Den&key=%2Flibrary%2Fmetadata%2F20068&machineIdentifier=7c32ba49023a1901017e64f284c3f38efbb386b4&playQueueItemID=1441&ratingKey=20068&state=stopped&time=600610&X-Plex-Client-Identifier=2bf26839342818ff-com-plexapp-android&X-Plex-Token=...fTs2
01-15 15:46:34.946  i: [TranscodeSession] Stopping...
01-15 15:46:34.947  e: [Video Player] A recoverable error occurred while attempting to play: /library/metadata/20068.
01-15 15:46:34.947  e: [Video Player] Playback has stopped because the connection to the Plex Media Server has been lost. Please ensure the server is available and retry.
01-15 15:46:34.948  i: [Video Player] Showing retry playback dialog.
01-15 15:46:34.968  i: [UpdateRecommendationsService] Updating recommendations...
01-15 15:46:34.968  i: Fetching [method:GET] https://10.45.19.50:32400/hubs?X-Plex-Token=...fTs2
01-15 15:46:35.153  e: An exception occurred: java.net.ProtocolException: unexpected end of stream
01-15 15:46:35.153  e: Stacktrace: java.net.ProtocolException: unexpected end of stream
    at com.android.okhttp.internal.http.HttpConnection$FixedLengthSource.read(HttpConnection.java:421)
    at com.android.okhttp.okio.RealBufferedSource$1.read(RealBufferedSource.java:349)
    at java.io.InputStream.read(InputStream.java:162)
    at java.nio.channels.Channels$InputStreamChannel.read(Channels.java:306)
    at org.jboss.netty.c.c.b.a(SourceFile:114)
    at org.jboss.netty.c.c.d.b(SourceFile:219)
    at org.jboss.netty.c.c.d.a(SourceFile:125)
    at org.jboss.netty.channel.z.b(SourceFile:611)
    at org.jboss.netty.channel.z.b(SourceFile:578)
    at org.jboss.netty.channel.a.a(SourceFile:251)
    at com.plexapp.plex.net.d.r.a(SourceFile:190)
    at com.plexapp.plex.net.d.r.a(SourceFile:103)
    at com.plexapp.plex.net.d.o.a(SourceFile:73)
    at org.jboss.netty.channel.aw.b(SourceFile:80)
    at org.jboss.netty.channel.ae.a(SourceFile:783)
    at org.jboss.netty.c.c.d.b(SourceFile:149)
    at org.jboss.netty.channel.ae.a(SourceFile:783)
    at org.jboss.netty.c.a.b.h.a(SourceFile:116)
    at org.jboss.netty.channel.aw.b(SourceFile:80)
    at org.jboss.netty.channel.ae.a(SourceFile:783)
    at org.jboss.netty.channel.z.a(SourceFile:302)
    at org.jboss.netty.c.a.d.b.a(SourceFile:527)
    at org.jboss.netty.c.a.d.b.a(SourceFile:506)
    at org.jboss.netty.c.a.d.b.a(SourceFile:443)
    at org.jboss.netty.channel.aw.b(SourceFile:80)
    at org.jboss.netty.channel.z.a(SourceFile:274)
    at org.jboss.netty.channel.z.a(SourceFile:261)
    at org.jboss.netty.channel.a.a.q.b(SourceFile:351)
    at org.jboss.netty.channel.a.a.q.a(SourceFile:282)
    at org.jboss.netty.channel.a.a.q.run(SourceFile:202)
    at org.jboss.netty.e.i.run(SourceFile:108)
    at org.jboss.netty.e.a.ab$1.run(SourceFile:44)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1113)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:588)
    at java.lang.Thread.run(Thread.java:818)

01-15 15:46:35.155  i: [Exo1VideoPlayer] Bandwidth sample, Elapsed: 325, Bytes: 532954, Bitrate: 190037152
01-15 15:46:35.495  i: [UserAction] Click 'cancel' on retry playback dialog.
01-15 15:46:35.499  i: [TranscodeSession] Stopping...

If I use the non-HD soundtrack I don't have issues during playback. I suspect there's still a small issue with TrueHD playback with VC-1 video. Any ideas?

«1

Answers

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    @BigWheel, since this is basically the same app as the mobile version, any chance you can take a look? I'm sure I can cut a chunk out of my MKV for you to test if you need it. I can also provide complete logs for the server and the Shield app.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    I confirmed this doesn't happen with the Embedded PMP. The audio does not drop at all when it moves from one chapter to another. Also confirmed it isn't my receiver, as I moved the Shield TV to another Onkyo receiver I own (the one the embedded PMP runs with) and the Shield TV dropped the audio and the video froze on it as well.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Does any Android dev/ninja/employee have any idea what's going on with this playback issue?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Can a mod move this to the Android (mobile) board?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Shield experience 5.0.2 did not fix this.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    @ManuelPG and @MovieFan.Plex, have you seen this problem?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Has anyone other than me encountered this problem on the Shield TV?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Bump, any dev have any input?

  • AndrroidAndrroid Members, Plex Pass Posts: 920 Plex Pass

    I use chapters fairly often but no issues. Is this only with VC-1 stuff? Are you seeing it with any other codec combinations?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass
    edited January 31

    @Andrroid, I have no issues with chapters, this is unique to television shows ripped from a BluRay, where it transitions from one scene to the next over where the commercial break was originally. I'll rip a section of the show in question and upload it so you can see if it happens on your setup.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Using mkvmerge I can split the file, but since it remuxes is a bit the video doesn't freeze - the audio just completely disappears.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    To answer the VC-1 question, this is the only TV show I have from BD, and it is indeed VC-1. It's just the Shield TV with the issue, my embedded PMP running on a NUC moves immediately from one scene to the next, no black space or dropped audio.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    In case a ninja/employee/dev wants to verify the problem, here's a snip of the video.

    https://dl.dropboxusercontent.com/u/32767348/Rick and Morty - s02e07 - Big Trouble in Little Sanchez cut.mkv

  • AndrroidAndrroid Members, Plex Pass Posts: 920 Plex Pass

    Tested the sample file, same results.

    I also encoded to h264, same results.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 14,824 Plex Employee

    Hey, just saw this thread. I'll try the sample a little later, but it sounds like it might be a problem with the way the file was originally encoded. VC-1 is a very finicky codec. The Shield can DP VC-1 so having playback issues would not surprise me. Have you tried forcing a transcode to see if that changes things?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    If I use DD 5.1 instead of TrueHD it works great. If I have TrueHD selected and I force a transcode, it works great. It's only original w/TrueHD where it has issues.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 14,824 Plex Employee

    Can you confirm that the Shield is DP when you use VC-1 and True HD? If so, then it is either the file is bad or the Shield just doesn't like that combination. We'll see what I find after I test your file later. And you see the same issue with the sample file, right?

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    Yes, it is direct play with that file. All of the files from that BluRay have the same symptoms on the Shield, but do not have those issues when played on my embedded PMP on my NUC. When the television show moves from one scene to the next over where the commercial break was, the screen drops to black and back to the show and the audio drops completely. Only with the TrueHD track selected.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 14,824 Plex Employee

    I am not able to recreate your issue with the sample you provided. I don't have an AVR so I had to force direct playing the file. Oddly, it worked. I even get sound which I don't quite understand how that is possible. But the entire 50s video clip you provided played. I'm using the 5.5.0 Beta app. Not sure if that makes a difference.

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 4,381 Plex Pass

    I'm guessing unless you have a Shield -> receiver -> TV setup you won't notice any problems. 5.5.0.77 does not make the file play correctly. I feel a bit better knowing @Andrroid was able to replicate the problem on his setup. Is it possible to find a ninja/dev that has a similar setup as mine to test it? And if the small portion of the Shield TV log I provided in the first post isn't enough I can reboot and replicate the problem and then download the entire log (along with the server log).

«1
Sign In or Register to comment.