We will be performing plex.tv database server maintenance starting 22:00 Pacific Time on Thursday, June 22 (05:00 GMT, June 23). It is expected to last ~1.5 hours. See http://status.plex.tv/incidents/w98nwqyk43pv
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Playing music on iOS stops after a few songs

jmbouffardjmbouffard Members, Plex Pass Posts: 1 Plex Pass

I am running the latest PLEX server from a Windows 10 box and I'm streaming music to the latest iOS (iPad 2) app from my local network. My problem is that the music always stops playing after a few songs. It usually stops playing half way through one of the first 5 songs. When stopped, the application displays the little circle icon as if it was searching the network but it will never start playing again unless I press next, then it'll start the next song and the cycle will repeat.

I started using PLEX quite recently so I cannot really confirm if it was working better before, however I'm pretty sure I was able to play complete albums back in Novembre 2016. These days, as explained, it is 1-5 songs max. So I'm wondering if one of the recent updates broke something?

And for your info I am capable of playing full 2 hour movies from the WebOS PLEX player with no problem at all, therefore my server and network connection seems to be reliable.

Thanks.

Best Answer

«1

Answers

  • chaosmakerchaosmaker Members, Plex Pass Posts: 335 Plex Pass

    I have no help here, but I have a similar issue where it just decides to Buffer without end. I believe someone said there might be a fix in the next version for that. So if no-one answers lets hope in the next version this gets fixed. Then we can send a bug complaint again :D

  • wj.alexander@outlook.comwj.alexander@outlook.com Members, Plex Pass Posts: 12 Plex Pass

    I have a similar issue. My music will play up to several hours and then stop in the middle of a song, displaying the message "Something went wrong when playing your media" I can exit and restart without issue.
    Before using Plex, I was able to stream my collection from a Network storage device (USB stick on my router), to my iPad and it would play continuously for weeks on end without issue. I tried Plex so that I have the ability to "Fling" media to my iPad (I get remote control in other words) but I get the stoppage problem- Same media, in the same location, playing on the same device. My media server (ver 1.3.3.3148) is running on a desktop machine that is running Win7 and is connected to my router through Ethernet cable, and is used for nothing else.
    I'm stumped- it was so easy to set up, but will not play continuously.

  • thibaud.bethibaud.be Members, Plex Pass Posts: 7 Plex Pass
    edited January 23

    I have the exact same problem.
    My music library is entirely in m4a lossless on a windows 10 plex server. setting to stream the original file
    All ios v9 and v10 devices tested (ipads pro, ipad mini, iphones) all hangs after a few songs, most of the times it doesn't even manage to play a single song entirely.

    So I though ok let's try an android device, I pulled out an older galaxy tab running android 6 and plex plays back fine (I let it play for a couple hours to make sure)... hooray
    Unfortunately it seems that music playback on plex android is plagued with another issue: You can't scrub the audio playhead. :-w

    I looked in the plex server logs but didn't notice anything special, is there a way to turn ios app plex logs ?

  • BigWheelBigWheel Members, Plex Employee, Plex Pass, Plex Ninja Posts: 9,372 Plex Employee

    hi guys. need logs from the device ( and server preferably ) covering playback of the item that stopped prematurely to see why it stopped. info on the file that it did this with would also be appreciated

  • thibaud.bethibaud.be Members, Plex Pass Posts: 7 Plex Pass

    thanks for the answer, but how do we get hold of the ios logs on a ipad ?

  • wj.alexander@outlook.comwj.alexander@outlook.com Members, Plex Pass Posts: 12 Plex Pass

    OK Here are the log files for my server, and my iPad . Yesterday I had streams enabled to an iPad, an iPhone, and two Windows laptops through the Chrome browser. Eventually they all stopped playing, at different times
    The iPad stopped in the middle of a Whitney Houston MP3, off of a Christmas album. ( I know, but I had different playlists going on each device-there does not seem to be any pattern to the type of song, it can be long or short, but seems to be mid-song) -John
    Have a look:

  • plex824@gmail.complex824@gmail.com Members, Plex Pass Posts: 10 Plex Pass

    Plex Support - I am also having this problem and I am a paying customer and would like to know when this problem is going to get fixed. It seems from multiple threads that this has been a long standing problem. It would be great if you could figure this one out as soon as possible.

    Here are the logs. The song I was listening to was, "What Breaks A Heart", time of streaming problem was 7:34 PM January 29, 2017.

  • plex824@gmail.complex824@gmail.com Members, Plex Pass Posts: 10 Plex Pass

    Plex Support - This problem not only occurs on my Windows 7 machine running the PMS, this problem also happened on my iMAC that is why I moved over to a Windows machine to see if the problem would go away. The problem still exist on these to platforms and I would say we are now looking at the IOS client. Please test this in your labs, duplicate the issue and please fix it. I do not have the time to debug this, this is something that you should step up to the plate and fix.

    Thanks!!!!

  • Wolf_666Wolf_666 Members, Plex Pass Posts: 478 Plex Pass

    I have the same issue, more frequent on iPhone than iPad. I will try to submit logs asap.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 27,040 Plex Team Member

    @plex824@gmail.com said:
    Plex Support - I am also having this problem and I am a paying customer and would like to know when this problem is going to get fixed. It seems from multiple threads that this has been a long standing problem. It would be great if you could figure this one out as soon as possible.

    Here are the logs. The song I was listening to was, "What Breaks A Heart", time of streaming problem was 7:34 PM January 29, 2017.

    I can see repeated errors logged in the server log after a disconnection.
    Would need to have a look at logs from both sides to understand more about the issue

    Seems to have started playing What Breaks A Heart.m4a then switched to Summer Song.m4a and after that back to What Breaks A Heart.m4a which was rejected by the server. Would need to see the Plex for iOS log to see why it switched tracks.

    Was this a playlist ?

    Suggest trying to reproduce and to get both both sets of logs using the new versions which came out yesterday and today - version 4.7 of the Plex for iOS app and version 1.3.4 of Plex Media Server

    The iOS logs are available in version 4.7 through the Help and Support Settings menu (Debugging menu) where you can email to yourself and then attach here together with the server log

    And as before please give an indication of the music being streamed and when the problem arose

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 27,040 Plex Team Member

    @wj.alexander@outlook.com said:
    OK Here are the log files for my server, and my iPad . Yesterday I had streams enabled to an iPad, an iPhone, and two Windows laptops through the Chrome browser. Eventually they all stopped playing, at different times
    The iPad stopped in the middle of a Whitney Houston MP3, off of a Christmas album. ( I know, but I had different playlists going on each device-there does not seem to be any pattern to the type of song, it can be long or short, but seems to be mid-song) -John
    Have a look:

    I have been looking at your logs and those from @plex824@gmail.com - it is a similar issue and relates to how the playlists are being handled by the Plex for iOS app. I have not established yet if this is fixed in the new 4.7 release which came out yesterday.

    Could you double check - thanks
    If problem persists, I would not mind new fresh logs from both sides - just so as to confirm it is still exactly as before

    Thanks

  • wj.alexander@outlook.comwj.alexander@outlook.com Members, Plex Pass Posts: 12 Plex Pass

    I updated to 4.7 on the iPad and there was no change.
    I then updated the PMS to 1.3.4 and now I cannot get a reliable connection to the server. I uninstalled, reinstalled, and created my Music library from scratch and everything is SLOW. Dashboard does not populate, playlists take a long time to save but I cannot play them since I cannot connect from my iOS device

    I will post new logs when I get this current problem sorted.
    John

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 27,040 Plex Team Member
    edited February 13

    @wj.alexander@outlook.com said:
    I updated to 4.7 on the iPad and there was no change.
    I then updated the PMS to 1.3.4 and now I cannot get a reliable connection to the server. I uninstalled, reinstalled, and created my Music library from scratch and everything is SLOW. Dashboard does not populate, playlists take a long time to save but I cannot play them since I cannot connect from my iOS device

    I will post new logs when I get this current problem sorted.
    John

    Thanks for trying 4.7

    With regards to the new issues after updating the server, are you still having a problem with accessing the server from the iOS device ? Is the dashboard still not loading in Plex Web?
    Could you raise a forum topic for your new problem in the Plex Media Server forum with logs / screenshots
    Thanks

  • SVXDAN83SVXDAN83 Members, Plex Pass Posts: 38 Plex Pass

    I am experiencing the same issues with both playlists and when switching from a track on one album to a track on a different album (i.e. adding a song to the Play Next queue). Lots of logs + details in this thread if they help at all?

    https://forums.plex.tv/discussion/254960/centos-7-3-1611-playback-problem-when-attempting-to-switch-between-tracks-on-plex-media-server/p1

    This issue has been going on for a couple months now and I am DESPERATE for a solution!

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 27,040 Plex Team Member

    @SVXDAN83 said:
    I am experiencing the same issues with both playlists and when switching from a track on one album to a track on a different album (i.e. adding a song to the Play Next queue). Lots of logs + details in this thread if they help at all?

    https://forums.plex.tv/discussion/254960/centos-7-3-1611-playback-problem-when-attempting-to-switch-between-tracks-on-plex-media-server/p1

    This issue has been going on for a couple months now and I am DESPERATE for a solution!

    The 503 errors would be the same problem, e.g. this from your log

    Jan 24, 2017 17:05:47.498 [0x700009178000] DEBUG - Completed: [208.54.90.164:22360] 503 GET /library/parts/64157/1474144414/file.m4a (13 live) TLS 5ms 319 bytes
    

    This has been raised with the Plex for iOS team
    cc @ChuckPA

  • SVXDAN83SVXDAN83 Members, Plex Pass Posts: 38 Plex Pass

    If its useful, here is my log bundle from tonight. The Plex Media Server.2.log contains where the bulk of the problems occurred when streaming music tonight.

    One example is:
    Feb 12, 2017 20:16:21.903 [0x7000014e6000] WARN - Denying access due to session lacking permission to direct play part 43003
    Feb 12, 2017 20:16:21.903 [0x700000c33000] DEBUG - Completed: [10.1.1.97:56851] 503 GET /library/parts/43003/1467599896/file.m4a (8 live) TLS 6ms 319 bytes

    They happened at Feb 12, 2017 20:16:21.903 through Feb 12, 2017 20:32:42.614 in that log.

    Thanks to all the fine Plex folk who have been helping with this!

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 27,040 Plex Team Member

    It would be the iOS log that would be more important for the iOS team - together with the server log

    I am hopeful though that we have enough evidence for now

  • SVXDAN83SVXDAN83 Members, Plex Pass Posts: 38 Plex Pass

    Ok, understood! I just switched my iOS App to Verbose Logging. I'll leave that enabled and when it happens again, I'll extract the logs in case they're useful.

    Thanks!

  • SVXDAN83SVXDAN83 Members, Plex Pass Posts: 38 Plex Pass
    edited February 13

    Not to keep piling on, but I always think more information is better than not enough... I had the issue occur twice this morning on two different iOS devices. Here are the log files from each iOS device. I added the name of the device to the end of the file name to avoid confusing which logs belong to which device. Verbose logging was enabled on both devices prior to the incident occurring.

    The incident happened on my iPhone at 2/13/2017 at 6:41AM playing the song "Cold Contagious" by Bush

    The second one happened on my iPad at 2/13/2017 at 11:06AM playing the song "The Valley" by Okkervil River

    Thanks!

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 27,040 Plex Team Member

    Thank you @SVXDAN83

«1
Sign In or Register to comment.