If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[REL] FMoviesPlus Channel

1676870727380

Comments

  • luckyleftieluckyleftie Posts: 4Members, Plex Pass Plex Pass

    @eetjtl Thanks for your quick reply. Setting the Base URL to bmovies.pro seemed to do the trick. I'm able to view content now. I am still unable to view external sources, but I do have unsupported services bundle installed. Any ideas why I am unable to view external sources?

  • pavipollopavipollo Posts: 54Members ✭✭

    Hi everyone, I have a question concerning the bookmarks. I have two servers and I would like to copy the bookmarks from the one to the other but if I put the file "bookmarks.json" (with at least 10 bookmarks) of Server1 in the directory Contents/Resources of the FMoviesPlus.bundle of Server2 no bookmarks show up. If I try, in Server2, to load the bookmarks via Options/Tools/Load Bookmarks I get the message "Channel not responding".
    The same happens if I try to put the bookmarks of Server2 in Server1.

    I use in both Servers the last version of the channel (0.62).
    Both Servers run on a Mac Mini
    Server1 runs PMS Version 1.3.4.3285 (the Mac Mini runs under Mountain Lion)
    Server2 runs PMS Version 1.10.1.4602 (the Mac Mini runs under El Capitan)

    Is it the problem that the PMS versions are different? If not, what can the problem be and how can I try to solve it?
    Thanks already for any hint!

  • pavipollopavipollo Posts: 54Members ✭✭

    Since I'm at it... I noticed another strange thing.
    With exactly the same settings in both Servers, on Server1 I can watch a show via OpenLoad while on Server2 I get the following message, when I try to watch exactly the same show:
    "Playback Error
    An error occurred trying to play "XXX(name of the show I tried to watch).mp4"."
    Has this to do with the OSX of the Servers?

  • eetjtleetjtl Posts: 710Members ✭✭✭

    @pavipollo said:
    Since I'm at it... I noticed another strange thing.
    With exactly the same settings in both Servers, on Server1 I can watch a show via OpenLoad while on Server2 I get the following message, when I try to watch exactly the same show:
    "Playback Error
    An error occurred trying to play "XXX(name of the show I tried to watch).mp4"."
    Has this to do with the OSX of the Servers?

    Not sure what version of osx(macOS) it started on but it may have to do with the openssl issue plex has. On the server it fails on do you have the Use Alternate SSL/TLS" enabled ?

  • pavipollopavipollo Posts: 54Members ✭✭

    @eetjtl said:

    @pavipollo said:
    Since I'm at it... I noticed another strange thing.
    With exactly the same settings in both Servers, on Server1 I can watch a show via OpenLoad while on Server2 I get the following message, when I try to watch exactly the same show:
    "Playback Error
    An error occurred trying to play "XXX(name of the show I tried to watch).mp4"."
    Has this to do with the OSX of the Servers?

    Not sure what version of osx(macOS) it started on but it may have to do with the openssl issue plex has. On the server it fails on do you have the Use Alternate SSL/TLS" enabled ?

    thanks for answering! I have "Use Alternate SSL/TLS" on both servers. As I said both servers have exactly the same settings...

  • JamminRJamminR Posts: 3,482Members, Plex Pass Plex Pass
    edited February 19

    @pavipollo - there have been many Plex changes from v1.3 to v1.10. (Even OpenSSL has been updated in the Python distro the different Plex versions use I think)
    My educated guess is that, yes, 1.3.4 is too old for proper viewing, even if coder-alpha's first post state 1.3.3 is required.

    I can't guarantee that though.
    Log review may help.

    Server - HW: I7-4790K(Haswell), 16GB - SW: Win10 Pro + PMS v1.13.0.5003
    Misc. HW: HDHR Extend + 2TB RAID1(Intel Z87) + 4x4TB RAID5(QNAP TS-653Pro)
    Shares - From: 2  - To: 18(5) - Potential lifetime PlexPass data generating product customer!
    ISP: ~20mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - Tautulli - UASv3 - PlexEmail - FMoviesPlus
  • pavipollopavipollo Posts: 54Members ✭✭

    @JamminR said:
    @pavipollo - there have been many Plex changes from v1.3 to v1.10. (Even OpenSSL has been updated in the Python distro the different Plex versions use I think)
    My educated guess is that, yes, 1.3.4 is too old for proper viewing, even if coder-alpha's first post state 1.3.3 is required.

    I can't guarantee that though.
    Log review may help.

    The fact is that the one working is Server1, running PMS v1.3.4, while Server2, running V1.10, does not...

  • JamminRJamminR Posts: 3,482Members, Plex Pass Plex Pass

    @pavipollo said:
    The fact is that the one working is Server1, running PMS v1.3.4, while Server2, running V1.10, does not...

    My mistake. I thought was reversed. Either way, logs likely have answers. Please zip and attach fmp channel logs after replicating error
    No guarantee i can help, but until we see zip of errors, no one else can

    Server - HW: I7-4790K(Haswell), 16GB - SW: Win10 Pro + PMS v1.13.0.5003
    Misc. HW: HDHR Extend + 2TB RAID1(Intel Z87) + 4x4TB RAID5(QNAP TS-653Pro)
    Shares - From: 2  - To: 18(5) - Potential lifetime PlexPass data generating product customer!
    ISP: ~20mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - Tautulli - UASv3 - PlexEmail - FMoviesPlus
  • pavipollopavipollo Posts: 54Members ✭✭

    @JamminR
    here some logs of Server2. Let me know whether you need more... Thanks already!

  • JamminRJamminR Posts: 3,482Members, Plex Pass Plex Pass
    edited February 21

    @pavipollo - Getting there, not quite.
    We'll need actual channel/plugin logs of the fmoviesplus variety as mentioned in first post - com.plexapp.plugins.fmoviesplus.log.
    Reference https://support.plex.tv/articles/201106148-channel-log-files/
    They give a much more specific picture of why something didn't work in fmovies. Make sure to replicate the error before posting them.

    Server - HW: I7-4790K(Haswell), 16GB - SW: Win10 Pro + PMS v1.13.0.5003
    Misc. HW: HDHR Extend + 2TB RAID1(Intel Z87) + 4x4TB RAID5(QNAP TS-653Pro)
    Shares - From: 2  - To: 18(5) - Potential lifetime PlexPass data generating product customer!
    ISP: ~20mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - Tautulli - UASv3 - PlexEmail - FMoviesPlus
  • eetjtleetjtl Posts: 710Members ✭✭✭

    and from page one of this thread
    When reporting issues please include the channel log file com.plexapp.plugins.fmoviesplus.log [including numbered ones 1 through 5] (https://support.plex.tv/hc/en-us/articles/201106148-Channel-Log-Files) or use WebTools > Logviewer/Downloader. Please make sure to 'Enable Debug' option under the Setting/Prefs and replicate your issues before providing logs.

  • pavipollopavipollo Posts: 54Members ✭✭

    thanks guys, in the meanwhile I solved the issue by deleting the channel, all connected files (prefs, cache etc.) and reinstalling ex novo. Now it works...

  • gordon999gordon999 Posts: 47Members, Plex Pass Plex Pass
    edited March 5

    OK so today even using basemovies.pro I am getting the video unavailable error on ALL videos. Log show ...

    2018-03-01 20:05:41,486 (7f88837fe700) :  DEBUG (runtime:814) - Found route matching /video/fmoviesplus/Videodetail
    2018-03-01 20:05:41,487 (7f88837fe700) :  INFO (__init__:3318) - https://bmovies.pro/film/the-flash-4.z1k7l - m55lnv
    2018-03-01 20:05:41,488 (7f88837fe700) :  INFO (fmovies:186) - Retrieving Fresh Movie Link
    2018-03-01 20:05:41,990 (7f88837fe700) :  INFO (fmovies:756) - Using cookies : MarketGidStorage=%7B%220%22%3A%7B%22svspr%22%3A%22%22%2C%22svsds%22%3A15%2C%22TejndEEDj%22%3A%22MTQ5MzIxMTc0OTQ0NDExMDAxNDc3NDE%3D%22%7D%2C%22C110014%22%3A%7B%22page%22%3A3%2C%22time%22%3A1493215038742%7D%2C%22C110025%22%3A%7B%22page%22%3A3%2C%22time%22%3A1493216772437%7D%2C%22C110023%22%3A%7B%22page%22%3A3%2C%22time%22%3A1493216771928%7D%7D; __cfduid=de2c4d5986128c0a06e1057f9ad417b751519933928; session=324f9936d2058f51fa7ece8a45c90f8613084afb; user-info=null
    2018-03-01 20:05:41,990 (7f88837fe700) :  INFO (fmovies:756) - get_sources Request-3: https://bmovies.pro/ajax/episode/info?update=0&server=36&ts=1519891200&_=1584&id=m55lnv
    2018-03-01 20:05:41,991 (7f88837fe700) :  DEBUG (interface:472) - Requesting (via Interface) : https://bmovies.pro/ajax/episode/info?update=0&server=36&ts=1519891200&_=1584&id=m55lnv
    2018-03-01 20:05:41,991 (7f88837fe700) :  INFO (interface:475) - Headers: {'Referer': 'https://bmovies.pro/film/the-flash-4.z1k7l/m55lnv', 'Cookie': u'MarketGidStorage=%7B%220%22%3A%7B%22svspr%22%3A%22%22%2C%22svsds%22%3A15%2C%22TejndEEDj%22%3A%22MTQ5MzIxMTc0OTQ0NDExMDAxNDc3NDE%3D%22%7D%2C%22C110014%22%3A%7B%22page%22%3A3%2C%22time%22%3A1493215038742%7D%2C%22C110025%22%3A%7B%22page%22%3A3%2C%22time%22%3A1493216772437%7D%2C%22C110023%22%3A%7B%22page%22%3A3%2C%22time%22%3A1493216771928%7D%7D; __cfduid=de2c4d5986128c0a06e1057f9ad417b751519933928; session=324f9936d2058f51fa7ece8a45c90f8613084afb; user-info=null', 'X-Requested-With': 'XMLHttpRequest', 'User-Agent': 'Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/44.0.2403.157 Safari/537.36'}
    2018-03-01 20:05:42,733 (7f88837fe700) :  INFO (fmovies:756) - Request-3 result: {"error":"token"}
    2018-03-01 20:05:42,733 (7f88837fe700) :  INFO (fmovies:186) - get_sources url: https://bmovies.pro/film/the-flash-4.z1k7l, key: m55lnv
    2018-03-01 20:05:42,733 (7f88837fe700) :  INFO (fmovies:186) - get_sources ret: None
    2018-03-01 20:05:42,734 (7f88837fe700) :  INFO (fmovies:186) - get_sources error: token
    2018-03-01 20:05:42,734 (7f88837fe700) :  INFO (fmovies:186) - Using Second Request due to token error
    2018-03-01 20:05:42,734 (7f88837fe700) :  INFO (fmovies:186) - CACHE cleared due to null response from API - maybe cookie issue for https://bmovies.pro/film/the-flash-4.z1k7l
    

    Anyone else have things working today?

  • Oldman3DOldman3D Posts: 136Members ✭✭
    edited March 1

    Always check the url (bmovies.pro) sys they changed it to bmovies.to.
    Also use external right now.. Might be an issue on their end. I was able to get a movie to work..
    Note:
    Confirm this with 2 movies. Openload external works.

  • gordon999gordon999 Posts: 47Members, Plex Pass Plex Pass

    @Oldman3D Yes I can get it to work with externals as well. Even using bmovies.pro. Out of intereset what url are you looking at to see what URL is currently valid?

  • Oldman3DOldman3D Posts: 136Members ✭✭

    Just went to bmovies.pro...

  • JamminRJamminR Posts: 3,482Members, Plex Pass Plex Pass

    Ok all, I'm trying to get one episode of a show I somehow missed getting last week when FMP was working fine.
    Chance, s02e08
    I've tried bmovies.pro, bmovies.to, and because going to the bmovies.to website actually redirects to fmovies.se, which says use fmovies.to for better and fast access, tried those two also.
    Going into the openload view for that particular episode always ends up in token error.
    I reset cookies every time I switch hosts.
    Anyone else having any luck, or have the pirates changed all the locks again, and @coder-alpha is going to have to regrind the keys?

    Server - HW: I7-4790K(Haswell), 16GB - SW: Win10 Pro + PMS v1.13.0.5003
    Misc. HW: HDHR Extend + 2TB RAID1(Intel Z87) + 4x4TB RAID5(QNAP TS-653Pro)
    Shares - From: 2  - To: 18(5) - Potential lifetime PlexPass data generating product customer!
    ISP: ~20mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - Tautulli - UASv3 - PlexEmail - FMoviesPlus
  • jmocs94jmocs94 Posts: 3Members, Plex Pass Plex Pass

    Hello,

    I continue to get "Video Unavailable. Error: token" error even after hours of research and trying to fix it on my own.

    Here is what I have tried (any help is appreciated):

    • Uninstalled FMoviesPlus.bundle and install directly from Github zip
    • Put PhantomJS folder on root of C:\ and placed the phantomjs.exe inside (I also tested it via pdf file from Oldman3D)
    • I installed Cryptodome
    • I have changed the base url to everything (and restarted every time)
    • I have disabled my anti-virus/firewall just to see if that caused it
    • I have put the Openload API Login and Key
    • Installed the Unsupported Services Tools
    • Ensured that my client options uses PhantomJS for parsing links
    • Reset the Cookies and the Cache
    • Changed the webhook to my own webhook url

    Here is what I can do:

    • I can see a list of movies/tv shows
    • I can use External Sources

    So my issue lies that I try to open a movie using OpenLoad and it gives me the token error. Again any help is greatly appreciated.

  • JamminRJamminR Posts: 3,482Members, Plex Pass Plex Pass

    @jmocs94 - I think all the hosts have changed anti-link-hijack code. See my previous post pretty much asking same.
    @coder-alpha - If you're able, can you poke/prod/fix?

    Server - HW: I7-4790K(Haswell), 16GB - SW: Win10 Pro + PMS v1.13.0.5003
    Misc. HW: HDHR Extend + 2TB RAID1(Intel Z87) + 4x4TB RAID5(QNAP TS-653Pro)
    Shares - From: 2  - To: 18(5) - Potential lifetime PlexPass data generating product customer!
    ISP: ~20mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - Tautulli - UASv3 - PlexEmail - FMoviesPlus
  • SteveorobboSteveorobbo Posts: 107Members ✭✭

    @JamminR said:
    Ok all, I'm trying to get one episode of a show I somehow missed getting last week when FMP was working fine.
    Chance, s02e08
    I've tried bmovies.pro, bmovies.to, and because going to the bmovies.to website actually redirects to fmovies.se, which says use fmovies.to for better and fast access, tried those two also.
    Going into the openload view for that particular episode always ends up in token error.
    I reset cookies every time I switch hosts.
    Anyone else having any luck, or have the pirates changed all the locks again, and @coder-alpha is going to have to regrind the keys?

    I have been going into external sources and then into external again (plex links) which gives you links for vidzi and other sites. Some of them work. A few give a media expired error but most work. None of the openload links for TV seem to work. Token error on the first link and then in the first external links page they all give me a server connection error. For movies some of the external openload links have been working but has been a few days since I tried. Just keep using the second external links (plex links) page for now till openload is fixed. Hope this helps.

Sign In or Register to comment.