Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

“Sorry, I’m having trouble accessing your plex skill right now”

2»

Comments

  • kingdom529kingdom529 Posts: 2Members, Plex Pass Plex Pass

    Thank you @caboose014! I enabled the cloud sync settings and now this works. I used the Google Drive cloud sync under my Plex account settings.

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    I'm having the same "“Sorry, I’m having trouble accessing your plex skill right now” issue.

    I'm using a Mac Mini as the Plex Server and have tried using the Echo Dot with the Android app, PHT, OpenPHT, Chrome app and Safari app.

    The echo unit WILL detect the plex server and happily switch to it.
    It also sees the various players and will switch to them.
    But any instruction at all will result in "“Sorry, I’m having trouble accessing your plex skill right now”.

    I've deleted and re-installed the skill multiple times, rebooted the echo unit and logged in and out of my plex account yet the issue remains. And I've never had any success at all. Not a sniff!

    • The echo unit is unbelievably good when it comes to recognising instruction so there's no fault there.
    • My plex is accessible from outside the network (port 32400 is open on the router).
    • Plex works perfectly on all players inside and outside the network.
    • No firewalls are turned on at the server end.
    • I've tried both UK and US languages in case that was the issue.

    I've noticed that the echo unit will generate a card file for every command but there's no card generated when she (LOL...she!) says "“Sorry, I’m having trouble accessing your plex skill right now”.

    That says to me that maybe it's not an issue with plex but with the echo and the actual skill itself. But that's a pure guess based on it not generating a card.

    It's a USA-based unit that I'm using in Australia but I don't think that's an issue given that all the other skills work fine and that the echo can see the server and is happy to switch between Plex players so I don't think there's any funky geo-blocking going on.

    Integration with Plex was the only reason I bought the echo dot so unless I can get this to work, I'll be taking up hockey and using it as a puck (sh*t....I think she heard that!!!).

    Any help VERY gratefully received.

    Troy.

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    Bump......

  • pancakelandpancakeland Posts: 3Members

    Same issue for me. I just got an Echo Dot for my living room, and I've been trying to use Alexa with Plex all night. Plex recognizes my server, and the various players available (Apple TV, iOS on iPhone, web player). Plex can also accomplish simple tasks like play, pause, stop, etc. But complex commands always return the "...trouble accessing your plex skill..." error. Even if I say "Alexa, open Plex", it will give me that error.

    I have port 32400 open and routed to my plex server, and I can confirm it is available outside my local network (disable wifi on my phone and connect over LTE). I have also changed the "Allow Fallback to Insecure Connections" to "Always", just to test for now. I'm not sure what else to try. Is there any logging available, either on the Alexa side or the Plex side?

  • SiscoPlexSiscoPlex Posts: 846Members, Plex Pass Plex Pass

    @pancakeland Alexa will NOT "open" Plex at this time unless you have a third party piece of hardware (Harmony Hub w/ an activity created for it)

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    Thinking that maybe Caboose014 had the solution to my issues, I started listing IP addresses in the Plex server that didn't require authorisation. However, rather than waste time plugging all of the in in the hope it would work, I simply added 0.0.0.0/0 which I believe gives every IP address authorisation (no, I didn't leave it set like that for long!).

    I rebooted the server, tested and...

    ..the problem still remains.

    Could it possibly be something at the ISP level that's stopping the complex commands that Alexa uses from coming back into the home network?

    This is getting frustrating beyond words now. I've contacted Amazon and they've pointed the issue squarely at Plex - and I think they're right.

    Do plex people monitor these forums? Surely someone there can help!

  • kegobeer-plexkegobeer-plex Posts: 5,324Members, Plex Pass, Plex Ninja Plex Ninja

    @troyeccles, try using a different port instead of 32400. In your manual port forward for your router, pick something like 45222 for the external port, 32400 for the internal port. In the Plex server settings, change your manual port from 32400 to 45222.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    Hi kegobeer.

    Thanks for that suggestion. I'll give it a go the minute I'm home and let you know!

  • malackamalacka Posts: 1Members, Plex Pass Plex Pass

    I have two servers, one of them on router's 32400 port, and one of other (16957). I can use my Echo with the first server, but if i change server to second one, alexa says “Sorry, I’m having trouble accessing your plex skill right now”
    port is open, and it seems like no traffic to port 16957 from nowhere. but sometim after a few minutes, it comes traffic from Amazon IPs

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    Sad to say that Kegobeer's suggestion didn't work. I tried two different routers too. Could there be something at the ISP level stopping alexa talking to Plex?

  • chr1sn3alchr1sn3al Posts: 2Members, Plex Pass Plex Pass

    I was running my "remote" port on 443.. (To allow access from remote locations blocking High Port Traffic) Then when I got the Alexa I had this same issue.. "I’m having trouble accessing your plex skill right now" I didn't have to change my "Remote Port" however, I did have to go into my Firewall and add a remote Port forward rule for 32400. TaDa Now Alexa works.. So now I have two rules in my Firewall One for port 443 and a second for port 32400. Maybe Plex needs to look at the app but appears when it needs access from Amazon cloud it's trying to access on the "Internal" port instead of the "remote" port configured.

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    Hi Chris. I'll try a few more ports. Why not...nothing to lose huh?

    With me being in Australia, does anyone think there's an issue with the cloud-based instructions (eg. "Alexa, ask plex what's on deck") either not getting TO amazon or not getting BACK because I'm not US-based? I can't see that being the issue....surely? Amazon wouldn't geo-block skills would they?

  • troyecclestroyeccles Posts: 23Members, Plex Pass Plex Pass

    I was sick and tired of my ISP anyway so, a few days ago, made the switch to a new carrier. It was turned on last night. I've set the router up with open ports and...STILL no good.

    So I've ruled out everything I can possibly think of now. Amazon have said it's nothing to do with them and to ask Plex. Plex seem reliant on the community and, as there only seems to be a few of us experiencing this issue, it's not getting a lot of attention.

    Anyone want to buy a half-useless hockey-puck? :/

  • adamrathsackadamrathsack Posts: 8Members, Plex Pass Plex Pass

    Has anyone found a fix for this? I'm also experiencing this issue and have no idea how to fix it.

2»
Sign In or Register to comment.