Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

ApleTV, TV Show runtimes show one hour longer... then near the end show correct runtime

tenneytenney Posts: 20Members, Plex Pass Plex Pass

When playing many different shows, Apple TV Plex app almost always now shows an incorrect duration while playing a show, but then it stops and starts and near the end of the show it's correct. It's almost always one hour longer than correct duration. AND the info showing for the info for that episode (not while playing) is correct every time.

If I've downloaded the file to my iPad, and watch part of the show (using VLC or inFuse), and know that I stopped watching at say 35 minutes in, when I go to watch that show AppleTV Plex App it shows that wrong duration (one hour longer), but I still end up at 35 minutes in to be about where I was (35 minutes in to an hour and 57 minute duration for a 57 minute show).

It's happening almost always the past several weeks.
Playing shows goes often brings up a spinning wheel in the middle because the server or LAN or NAS must be busy, but eventually (sometimes 10 minutes, sometimes one minute before the end of the show) playback shows the correct duration.

Help!

Answers

  • BigGatorBigGator Posts: 3Members, Plex Pass Plex Pass

    I'm seeing the same issue on Apple TV and web browser playback. No matter the length of the show, the timeline shows a total duration of 2:00:00 and the playback ends about 60 seconds too early.

    The same shows play correctly on iOS and Plex Media Player for MacOS.

  • IainBestIainBest Posts: 3Members, Plex Pass Plex Pass

    Seeing the same thing and experiencing either or both buffering and playback stopping around 60 seconds before the end.

  • paulwhite61paulwhite61 Posts: 15Members, Plex Pass Plex Pass

    I'm also seeing this. A 24-minute series episode will show a running time of 94 minutes at the start, then the video will stop playing for a second or two near the end and the time remaining will be fixed when it resumes playing. Very annoying!

  • BrianomcBrianomc Posts: 24Members, Plex Pass Plex Pass

    I'm getting the same issue. I'm glad (sort of) to see others have it too as I thought it was a problem with my plex server.

  • StokkesStokkes Posts: 306Members, Plex Pass Plex Pass

    Having this too.. ONLY happens with Apple TV

    Does not happen with the other clients I have: Xbox One, Roku, iOS, Samsung TV..

    Only Apple TV. It's like the client can't get the length of the video even if the video is fully analyzed.

  • jayt80jayt80 Posts: 97Members, Plex Pass Plex Pass

    @paulwhite61 said:
    then the video will stop playing for a second or two near the end and the time remaining will be fixed when it resumes playing. Very annoying!

    Same here as well. Does anyone from Plex want to chime in and at least acknowledge it and let us know it's on the cards to fix?

    Plex Server running on:  Mac Mini (2.5GHz Intel Core i5) 8GB Ram, 256GB SSD  Samsung 55inch LED TV UA55ES7100  Bose Cinemate 130 Soundbar  Plex Clients: Sony PS4, iPhone 6, iPad Air 2, TV4,  ASUS RT-AC68U  15-inch Macbook Pro Retina (Late 2013) 2.3GHz Intel Core i7, 16GB Ram, 512GB SSD. Using an HDHomerun Connect for Plex DVR/Live TV

    image

  • jarryd1111jarryd1111 Posts: 2Members, Plex Pass Plex Pass

    Same here, except it always shows the duration as 10 hours for me (irrespective of actual show length). Same behaviour of pausing and correcting itself with a few minutes to go.

    Started happening a couple months ago very rarely, now it's pretty much every single video I play.

  • dflesch28dflesch28 Posts: 1Members

    I started having an issue very similar to this as well. It started a couple months ago on my Apple TV. The duration is always set at 2 hours regardless of how long the video I'm watching is. Then with a minute left in the video playback would stop and I get a playback error. I have to go back and play the video and fast forward to the last minute to see the end of the movie or show. The second time I go in the video length is correct. It seems this issue is only present on the first video I watch when starting the app. Each video after seems to be fine. Also, I thought it may have been limited to just the Apple TV app but recently I got an LG TV and I am having the same issue with the LG TV app as well.

    I have searched a lot and have yet to find any solutions or suggestions on what could be wrong. This is the only thread I can find where anyone is having the same issue.

  • henrysingletonhenrysingleton Posts: 1Members, Plex Pass Plex Pass
    edited April 8

    I'm having the same issue, running Plex on my Synology NAS and the official client on my AppleTV 4. Episodes finish early (around a minute) and the length/duration is incorrect. Pausing and resuming the episode fixed it once but other times it has not. It's quite frustrating since the climactic moments of a show tend to happen in the last minute...

    Update:
    I updated the plex media server app on the Synology to version 1.5.3.3580 (I was running 1.4.something previously) and I played a tv episode all the way through and it didn't finish early. Sorry to revive a thread for a bug that's probably already been fixed :(

  • hrc1079hrc1079 Posts: 6Members, Plex Pass Plex Pass

    It's not a bug that's been fixed as I still have it present in 1.5.3.3580 and it's been present for the last couple of months now. I'm looking at switching to Emby or something else. No sooner is one bug fixed in Plex another one appears. It's sole purpose it to play media and they can't even manage to get that working properly. :(

  • DonHomerDonHomer Posts: 2Members, Plex Pass Plex Pass

    I have been having this issue, too only on ATV4. I've enabled network logging about 15 minutes ago and I'm playing an episode of a show now to reproduce the error. Attaching my server log if that helps.

  • david.darlington@mac.comdavid.darlington@mac.com Posts: 3Members, Plex Pass Plex Pass

    Any news on this thread? its been quiet for. while, I'm having the same issues PMS 1.5.5.3634 on Mac mini and Plex app on Apple TV v1.10 (5710)

    Episode of 59m show 1h58m then around 10 mins from the end it stops spinning circle of buffering about 1min usually then starts again with the correct time ALSO it skips back 30seconds on restart.

    Also I've noticed when it does restart its also outputting the volume louder

    Anyone have any news :-)

    David

  • discopantsdiscopants Posts: 1Members

    I've been having this issue for months now and am concerned about it not being fixed, as I would like to subscribe to Plex Pass.

    I'm running PMS 1.5.3.3580-4b377d295 on a MacBook with macOS 10.12.4 and streaming through AppleTV running tvOS 10.2.1.

    It seems to happen only on videos I play subsequently. That is, the first video I play shows the correct time, but videos I play next show a longer duration and then display the spinning gear like it's buffering for a couple seconds toward the end of the video before skipping back about 10 seconds and finishing.

  • david.darlington@mac.comdavid.darlington@mac.com Posts: 3Members, Plex Pass Plex Pass

    Glad its not just me! But not glad its happening

  • paul7paul7 Posts: 29Members ✭✭

    This has been happening for quite a while now and with each update I'm disappointed that it persists. If I start a video and notice a 2 hr runtime, backing out and restarting it fixes it but it's annoying to have to do that.

  • david.darlington@mac.comdavid.darlington@mac.com Posts: 3Members, Plex Pass Plex Pass

    I reinstalled plex and re did my entire library (due to moving to a nice new raid5 nas) but since then it's not happened (touchwood)

  • DonHomerDonHomer Posts: 2Members, Plex Pass Plex Pass

    I wish this was the case for me. I had just moved to a new server when the problem started. Maybe the process of migrating the library from one server to another?

  • pixorpixor Posts: 12Members, Plex Pass Plex Pass

    This has been happening to me for many weeks, and my family are fed up. Is there a fix on it's way?

  • jarryd1111jarryd1111 Posts: 2Members, Plex Pass Plex Pass

    @david.darlington@mac.com said:
    I reinstalled plex and re did my entire library (due to moving to a nice new raid5 nas) but since then it's not happened (touchwood)

    Just to add to what David said - I had to format my mac about 6 weeks ago and had to start all my libraries from scratch. Have not noticed it happening since. Not an actual solution as starting from scratch is annoying.

Sign In or Register to comment.