Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Error SourceNotSupported playing FLAC, AAC or ALAC

mp3 playback is fine but when I try to play either an ALAC, AAC or FLAC I get this error.

Error
SourceNotSupported: System.Exception: Excep_FromHResult 0xC00D2EE6

Client version: 3.2.9-a94df305 on Windows 10 PRO, server version 1.3.4.3285 (running on a synology)

The same tracks play fine in the Android or Web client, though in that case they are transcoded.

Answers

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja

    Hmm, 0xC00D2EE6 corresponds to NS_E_SERVER_UNAVAILABLE, so it seems to be a connectivity issue somehow. Can you send me the full client logs?

    QNAP TS-253 Pro (x86)

  • xlr23xlr23 Members, Plex Pass Posts: 68 ✭✭

    I try the uwp app from time to time to see if it's finally working; i can confirm it is broken for flac files since a few weeks at least, I have same error messages; using plex cloud, no connectivity issues with android.

    My feeling: it is getting worse and worse, app was quasi-usable for me at one point and it is getting worse and worse with time. Still impossible to simply play music, even when flac is not broken the app is so buggy it us unusable for me.

    Devs should just admit the app is a failure and start from scratch if they respect their customers

  • adameladamel Members, Plex Pass Posts: 2 Plex Pass
    edited February 2017

    I'm having the exact same problem. It worked perfectly fine for months and suddenly I can't play FLAC with the native Windows app, which often crashes with no error message back to desktop.

    I'm running Plex Media server on Debian Linux. I had Plex Media Server 1.3.3.3418. Upon logging into the web version, it informed me there was an update. I upgraded to 1.3.4.3285 and FLAC playback works again. Seems like the Windows client was updated and it broke compatibility with 1.3.3.3418 (at least for me).

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja

    @xlr23: is FLAC playback fixed for you with 1.3.4, as suggested by @adamel? I still don't have any client logs regarding this issue, so it's difficult to figure out what might be going wrong.

    QNAP TS-253 Pro (x86)

  • xlr23xlr23 Members, Plex Pass Posts: 68 ✭✭

    @pombeirp Tried flac playback from local 1.4.3 server ==> working but still not usable for me, very slow and app crash after changing track a few time;

    Tried from plex cloud 1.3.2.237 ==> flac plays but track info stays at 0:00 impossible to scrub, if touching the transport bar tracks restart from beginning.

    Speed and stability on Lumia 950 is still far, far away from a low-end android device

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja
    edited March 2017

    @xlr23: can you send me the log of the crash? Also, what is slow, is it general navigation in the app?

    FWIW, I'm testing FLAC playback on a 950XL and I don't notice issues or slowness.

    QNAP TS-253 Pro (x86)

  • xlr23xlr23 Members, Plex Pass Posts: 68 ✭✭
    edited March 2017

    Didn't have the logging on (but crash reporting was on) , it was on PC; I enabled logging now and will have some tries again.

    Just tried on mobile, enabled logging, launched an album, changed tracks a few time and got " Error SourceNotSupported: System.Exception: Excep_FromHResult 0xC00D2EE6" ==> Attached diagnostics just after the error

    And yes general navigation in mobile app, switching between menus or tracks is very slow compared to any other app; on pc it is much better.

    On both pc/mobile transport bar stays at 0:00 when playing from a plexcloud server, working as intended via webplayer/android

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja

    Interesting, I don't see the 0xC00D2EE6 (NS_E_SERVER_UNAVAILABLE) error in the log. What I do see is a 0xC00D36FB error (MF_E_BYTESTREAM_UNKNOWN_LENGTH), apparently while attempting playback from the Cloud server.

    QNAP TS-253 Pro (x86)

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja

    I was able to repro this on my 950XL. It seems to only happen when playing FLAC files from Cloud server. This may be a problem in the way Plex Cloud replies to the Windows app (it describes the FLAC file as a generic byte stream instead of a FLAC audio file). We're looking into it.

    QNAP TS-253 Pro (x86)

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja

    @xlr23: are you by any chance using OneDrive as storage for Plex Cloud?

    QNAP TS-253 Pro (x86)

  • pombeirppombeirp SwitzerlandMembers, Plex Pass, Plex Ninja Posts: 1,886 Plex Ninja

    Tested the same FLAC file with Google Drive and it played correctly, fwiw.

    QNAP TS-253 Pro (x86)

  • xlr23xlr23 Members, Plex Pass Posts: 68 ✭✭

    Yep using Onedrive forgot to mention

  • drinehartdrinehart Members, Plex Pass Posts: 1,241 Plex Pass

    @pombeirp - sorry to bring this back up, but I am currently seeing this same issue on current PMS (my own server) and Plex App playing FLAC files. I only see if from the Windows App. I am trying to play it sitting at home. I can play the tracks via PMP, Kodi, Web (though it is transcoded in web). I will try to dig up logs if needed, but I suspect if you try to play a FLAC file from a local PMS, you should be able to reproduce. Excep_FromHResult 0xC00D2EE6.

  • drinehartdrinehart Members, Plex Pass Posts: 1,241 Plex Pass

    @pombeirp - An uninstall and reinstall seems to have fixed the issue, so disregard.

  • goldenpipesgoldenpipes Members, Plex Pass Posts: 31 Plex Pass

    This is happening to me with any FLAC files i try to play. My server is running locally as well as the FLAC file. It plays on Web, PlexAmp, and OpenPHT fine but not on the UWP App. Gonna try to reinstall the app and see if that fixes anything.

  • goldenpipesgoldenpipes Members, Plex Pass Posts: 31 Plex Pass

    ok so i just converted the files using musicbee from FLAC to FLAC and now they work. seems to be some weird bug with certain conversion/ripping software.

Sign In or Register to comment.