Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Playback stops near the end of TV-episodes

injinj Members Posts: 11
Hi,


The last couple of months there's been a problem with playback of TV-show episodes. When it's near the end, playback just stops and Plex returns to the episode list. Normally it's not a problem (just annoying) because it's at the end so there's pretty much just "pan out" (or something like that) and credits left. But sometimes there's actual "content" (i.e. dialogue or something like that) left when it quits, and I have to watch it through VLC to see the ending. What seems odd is that Plex always stops playback when there's about 10-20-30 seconds left, and never at other times. The files are okay, because I can see the entire episodes through VLC.

Any idea what may cause this? I've checked some earlier threads where playback stopped more randomly, and one of the advices there was to turn off the automatic library update. I've tried that, but it didn't help.

The TV-shows are in .iso and .mkv-formats. I believe this happens regardless of format, but I'm sure that it happens to the .iso-files (haven't watched the shows I have in mkv in some time).

I hope someone can help, because right now I mostly use VLC to watch TV-shows and I'd rather use Plex :(
«1

Comments

  • injinj Members Posts: 11
    No one knows?


    inj wrote:

    Hi,


    The last couple of months there's been a problem with playback of TV-show episodes. When it's near the end, playback just stops and Plex returns to the episode list. Normally it's not a problem (just annoying) because it's at the end so there's pretty much just "pan out" (or something like that) and credits left. But sometimes there's actual "content" (i.e. dialogue or something like that) left when it quits, and I have to watch it through VLC to see the ending. What seems odd is that Plex always stops playback when there's about 10-20-30 seconds left, and never at other times. The files are okay, because I can see the entire episodes through VLC.

    Any idea what may cause this? I've checked some earlier threads where playback stopped more randomly, and one of the advices there was to turn off the automatic library update. I've tried that, but it didn't help.

    The TV-shows are in .iso and .mkv-formats. I believe this happens regardless of format, but I'm sure that it happens to the .iso-files (haven't watched the shows I have in mkv in some time).

    I hope someone can help, because right now I mostly use VLC to watch TV-shows and I'd rather use Plex :(
  • poissonishpoissonish Members, Plex Pass Posts: 90 Plex Pass
    I've had the same issue, however it doesn't seem to occur if I add that same content to my "other" section, which is set not to scrape, just to play video files that normally don't get picked up by the other scrapers. It seems strange that the same video will play all the way through as long as there is no metadata.

    I will add, I have only confirmed this to be an issue with ATV so I haven't reported it, but it may also be occurring within Plex for OSX, I just haven't used since setting up my ATV. Again I assume this is an issue with Plex for ATV, so I did not report it as a bug with PMS. I will have to try the same files on my Mac Mini and see what happens.
  • ccjensenccjensen Members Posts: 438 ✭✭
    poissonish wrote:

    I will add, I have only confirmed this to be an issue with ATV so I haven't reported it, but it may also be occurring within Plex for OSX, I just haven't used since setting up my ATV. Again I assume this is an issue with Plex for ATV, so I did not report it as a bug with PMS. I will have to try the same files on my Mac Mini and see what happens.


    I'd be very interested to hear how it works on the mac client. In the few cases I have had a chance to investigate the indications has been an "incorrect" analysis performed by the pms. More recent versions of the pms have improved media analysis capabilities. There IS a way to re-perform the analysis, but it can be a bit tricky and requires some terminal foo. The easiest way is to delete the section in the pms, and manually recreate it. Obviously this has the disadvantage of losing all watched/unwatched status, etc.
    Just another plex user
  • JayBirdJayBird Members Posts: 360 ✭✭
    Yes, plex on my mac mini does this too. Getting annoying
    Mac Mini 2.0Ghz | 17" i5 MacBook Pro | iPhone 4 | iPad 16GB Wi-Fi | Apple TV 2
  • injinj Members Posts: 11
    I have a Mac mini (not the current version, the one before that). The other day the same thing happened when watching a movie (the was a short clip at the end of the credits, and the playback stopped halfway through this clip, (so a few seconds before the end of the movie).

    If I understand the suggested solution correct: I have to delete the scanned library? Is it easier to uninstall Plex and re-install it? Then everything has to be scanned again? I don't care about losing watched/unwatched-status, but it would take alot of time to check once more that all movies and tv-shows are identified correctly.
  • apesterapester Members Posts: 3
    I'm having the same issue...the common issue seems to be a mac mini...I have confirmed that the same problem happens on the iphone/ipad clients as well as atv, but the problem goes away if I move the media manager from the mini to my imac. I haven't tried with 1 hour shows but any 30 minute sitcoms (around 24 minutes minus commercials) seem to cut off at around the 15 minute mark. Its a weird issue, I tried rebuilding the library and it made no difference..any suggestions for a fix or workaround would be welcome.
  • sanitysanity Members, Plex Pass Posts: 6 Plex Pass
    I'm having the same issue but not using a Mac mini.
    Plex Media server on my Mac Pro is saying the tv show in question is 5 minutes shorter than it really is.
    For example Mediainfo utility shows the file as being 20 minutes long but Plex (any client) while playing the file shows it as 15 minutes long in the time bar.
    Doesn't seem to have anything to do with the clients as all the clients behave exactly the same (ATV, iOS, Computer) once the show is tagged as being 5 minutes shorter.

    This is happening more frequently as of late and almost exclusively on 21'ish minute TV shows (avi/xvid).
    Currently the only way I have found to fix them is to re-encode them as M4V files (using AppleTV2 profile on Handbrake), delete original file, clean/empty PMS trash then add new file and scan again. After that it works properly and never cuts the show short again (time bar will always show proper time after doing this).

    The shows that PMS are cutting short play fine in VLC and show up with proper info on MediaInfo, Mplayer, VLC, etc.

    Crazy annoying.

    PMS = 0.9.2.7-ff76e66 on Mac OS X 10.6.7 (Mac Pro - Core i7)
    Clients = ATV2, Mac Pro, Mac Mini, Macbook, iOS (iPhone, iPad and iTouch) all running latest versions of iOS Plex app or for ATV2 the 0.8.0Beta3 client from the forums.

    Happy to provide logs or debug info if needed (not sure exactly where to look but willing to look and run stuff).
  • JayBirdJayBird Members Posts: 360 ✭✭
    I've just noticed that this is only happening on my iOS clients...both the plex official and klexi clients. Playing the same tv how via the mac mini client shows the correct time
    Mac Mini 2.0Ghz | 17" i5 MacBook Pro | iPhone 4 | iPad 16GB Wi-Fi | Apple TV 2
  • JayBirdJayBird Members Posts: 360 ✭✭
    Any word on this issue?
    Mac Mini 2.0Ghz | 17" i5 MacBook Pro | iPhone 4 | iPad 16GB Wi-Fi | Apple TV 2
  • JayBirdJayBird Members Posts: 360 ✭✭
    Just had a text message from my *unhappy* girlfriend saying the latest version of desperate houswives is showing a length of 7 seconds on both the ipad through klexi and through the main client...will investigate when i get home later
    Mac Mini 2.0Ghz | 17" i5 MacBook Pro | iPhone 4 | iPad 16GB Wi-Fi | Apple TV 2
  • atrusatrus Members, Plex Pass, Plex Ninja Posts: 11,093 Plex Ninja
    edited May 2011
    There are a couple of threads discussing this issue. The devs are aware of it, but no solid fix has been developed yet. There is however an ffmpeg update that elan posted some weeks ago that fixes this for a couple of the users at least.
    See these threads for reference:
    http://forums.plexapp.com/index.php/topic/24793-ffmpeg-quit-unexpectedly/
    http://forums.plexapp.com/index.php/topic/26381-video-stops-playing-after-8-to-12-minutes/

    The last one is for the Roku client, but has some info that relates to the iOS clients as well (including ATV).
     Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive) (PM score: 7347)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS (CPU: Intel Xeon E3-1240v2 3,4GHz, PM score: 9300) 
    New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
    Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
    Always attach log files if you are reporting an issue: Log file info & location
    Get Plex guides here: Howto name your files NAS guide Troubleshooting Plex Support Page
  • JayBirdJayBird Members Posts: 360 ✭✭
    edited May 2011
    Ill have a play with those suggestions when i get in tonight, but im not convinced it is entirely the same issue.

    When the videos start, the timer shows the incorrect time from the off....i.e. an episode that is 21:35 shows 17:21 for example.

    It doesn't show the correct time and stop early...it looks like plex thinks the file is shorter than it actually is
    Mac Mini 2.0Ghz | 17" i5 MacBook Pro | iPhone 4 | iPad 16GB Wi-Fi | Apple TV 2
  • atrusatrus Members, Plex Pass, Plex Ninja Posts: 11,093 Plex Ninja
    Hmm. You may be right about that. But still, the new ffmpeg may solve it as it is ffmpeg which does the analysis of the file, and "records" the video length (afaik). If the ffmpeg flavor that Elan baked into the latest build has a bug then I assume this could happen. We just need to track down this sucker!
     Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive) (PM score: 7347)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS (CPU: Intel Xeon E3-1240v2 3,4GHz, PM score: 9300) 
    New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
    Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
    Always attach log files if you are reporting an issue: Log file info & location
    Get Plex guides here: Howto name your files NAS guide Troubleshooting Plex Support Page
  • JayBirdJayBird Members Posts: 360 ✭✭
    Updated ffmpeg with the one in the link and it hasn't made a difference.

    I only have 2 tv episodes this has happened with...one was 45 mins long, but being reported as 27 mins by plex, and the other was 22 mins but being reported as 17 mins by plex

    They both display the correct time when playing it through the main plex client on the Mac Mini, but both klexi and plex app report the incorrect times.

    Where does this lead you to think the problem lay?
    Mac Mini 2.0Ghz | 17" i5 MacBook Pro | iPhone 4 | iPad 16GB Wi-Fi | Apple TV 2
  • atrusatrus Members, Plex Pass, Plex Ninja Posts: 11,093 Plex Ninja
    It was a bit of a long shot, but it was worth a try. I don't really have solution I am afraid to say. We must await the devs.
     Mac mini 2,3 GHz Quad-Core Intel Core i7 (With Fusion drive) (PM score: 7347)  Panasonic VT50 (55 inch)  Pioneer VSX-2021 Receiver  Norco 24-bay NAS (CPU: Intel Xeon E3-1240v2 3,4GHz, PM score: 9300) 
    New to Plex/Nine? Watch my screencast video (slightly out-dated nowadays, but still informative for new users)
    Want to know how to handle subtitles? Watch my subtitle screencast video (out-dated, but still informative), and this One Minute Subtitle Addendum screencast
    Always attach log files if you are reporting an issue: Log file info & location
    Get Plex guides here: Howto name your files NAS guide Troubleshooting Plex Support Page
  • worstepisodeeverworstepisodeever Members Posts: 199
    just to add and keep this bumped..... this happened last night to us on multiple episodes of stuff on our ATV2. United States of Tara, Nurse Jackie, etc.....same problems as above. Plex shows incorrect length of program being watched and obviously ends early. Never had this problem before this latest build of PMS/ATV2. (9.2.7/0.7.1)
  • apesterapester Members Posts: 3

    just to add and keep this bumped..... this happened last night to us on multiple episodes of stuff on our ATV2. United States of Tara, Nurse Jackie, etc.....same problems as above. Plex shows incorrect length of program being watched and obviously ends early. Never had this problem before this latest build of PMS/ATV2. (9.2.7/0.7.1)


    Just wanted to mention that the ffmpeg workaround mentioned worked for my situation, watched several of the shows that were ending a few minutes early last night and today to test and all of the ones that failed earlier played to the end. It might not be the fix for everyone but at least in some of the cases it does indeed work.
  • MastihaMastiha Members, Plex Pass Posts: 3 Plex Pass
    The workaround seems to be for Mac's.

    I have the issue and I'm running Windows.

    Are there any solutions?
  • Inception76Inception76 Members Posts: 18
    I have a similar problem like this that just started recently.
    I have ripped Frasier from my dvd to make it easier to watch with plea. But the episode stops maybe 30 or 40 seconds before the ending. At first i though that there was something wrong with my rip ( ripped with handbrake). but when i play the video on my Mac the entire episode is there and also the ending. I have not had this problem with Fringe.
    I run the latest version of PMS. this happens when i watch episodes on my ATV2
  • lofilofi Members, Plex Pass Posts: 9 Plex Pass
    Just to mention that this issue is still around. I have it on all my iOS devices. Seems to mainly affect Mpeg4 files.
«1
Sign In or Register to comment.