Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex limits upload speed to 20Mbps

J0akimJ0akim Posts: 12 Plex Pass
edited March 7 in FreeBSD

Hi, So i have the latest version. Had it when it was a plexpass version and this problem did come with this update. Because I did revert to an old version and it worked like it should. So do you know a fix for this issue? I am trying to stream a file with a high bitrate about 38Mbps. And i have tested that i get speeds of 60Mbps from my server here. So that is not an issue and this file works with the old version.. But now when i check the networking tool in freenas it shows clearly that plex uploads only to 20Mbps and that causes stuttering with a file that has bitrate of 38Mbps.

Edit: The server settings is Limit remote stream bitrate Original (no limit)
And internet upload speed is empty

Answers

  • gbooker02gbooker02 Posts: 509 Plex Employee

    First, your file is not 38Mbps, it's much higher:

    Streaming Resource: Adding session 0x80e020ae0:cb4c9e768e085834-com-plexapp-android which is using 63319kbps of WAN bandwidth.  Used is now 63319kbps
    

    See the latter part of this page for more information: https://support.plex.tv/hc/en-us/articles/227715247-Server-Settings-Bandwidth-and-Transcoding-Limits

    Second, the server is measuring ~20Mbps to the client (it is not limiting it to such, it is measurement only) so that figure is accurate.

    Given that the server allowed adding of the session (quoted text), then it sees it as having enough bandwidth for that playback (according to the settings). Additionally, traffic shaping on the server is disabled for connection where bandwidth is not limited. Since you have no limit set, the server will not limit the traffic transfer.

  • J0akimJ0akim Posts: 12 Plex Pass

    Okay where can I find the old versions so I can revert? Because I watched today too and Wan usage today was Streaming Resource: Adding session 0x80d01df20:cb4c9e768e085834-com-plexapp-android which is using 22908kbps of WAN bandwidth. Used is now 22908kbps. But this did work with the old version without problems. And i have measured with iperf the speeds from the server to my computer here and it did show speeds of 60Mbps

  • J0akimJ0akim Posts: 12 Plex Pass

    Does anyone know where i can find the old versions so i can revert because these files did work with the old versions. But now with these new versions they won't work..

  • johnm_ColaSCjohnm_ColaSC Posts: 449 Plex Pass

    If on Windows they are in the app data folder I believe.not at a computer at the moment to verify. I personally normally manually download and keep versions in a folder.

  • J0akimJ0akim Posts: 12 Plex Pass

    Yeah true, But i have it installed in a jail on freenas and it updates automatically with a script. I had the script configured so it did remove all old versions so i don't have the last working version left anymore. It was like version 1.3. something.

  • J0akimJ0akim Posts: 12 Plex Pass

    I did find that the plugin in freenas hasn´t been updated. So it do have the old working version still. Version: plexmediaserver-1.3.4.3285-amd64.pbi I did install this in a new jail and put on a similar file an it works perfect.

    Streaming Resource: Session 0x80cc67f20:cb4c9e768e085834-com-plexapp-android changed from using 12209kbps to 61619kbps of WAN bandwidth. Used bandwidth is now 61619kbps

    And nothing else have changed just the server version so the measuring component or something must be broken or something.. But this version works for me and I ain't updating before I make sure it works as it should :smiley:

  • J0akimJ0akim Posts: 12 Plex Pass

    I tried version: 1.6.1.3722 and i don´t have this problem anymore. So this is working now if anybody wonders.

    Thanks!

Sign In or Register to comment.