Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Is the Plex app for Vizio dead?

mikecousinsmikecousins Members, Plex Pass Posts: 31 Plex Pass

I feel like Plex has completely stopped supporting the Vizio televisions and it's super sad. I bought this TV because at the time it seemed like the best supported TV brand by Plex (https://www.plex.tv/blog/plex-vizio/). I have asked this on Twitter as well but received no response:

Current Issues:
1. No cover art or any images at all in the interface: https://forums.plex.tv/discussion/255171/images-not-appearing-in-vizio-app
2. Fast forward and rewind are broken (workaround is using the left and right arrows, but this only works if the controls aren't on the screen): https://forums.plex.tv/discussion/256989/bug-plex-no-longer-responds-to-remote-commands
3. Controls randomly appear and disappear on the screen while you're watching: https://forums.plex.tv/discussion/260682/status-bar-is-popping-up-at-random-times
4. Some files will change aspect ratio when captions are turned off.
5. DirectPlay seems completely broken. Nothing actually gets DirectPlay'd and it absolutely crushes the server with load: https://forums.plex.tv/discussion/247443/vizio-update-broke-plex-aspect-ratio-only-allowing-transcoding-any-word-from-plex

Can somebody from Plex please comment on this platform? Is it going to be fixed one day? Should I give up and get another TV or buy another device to use Plex on instead?

Tagged:

Answers

  • bueller425bueller425 Members Posts: 96 ✭✭
    edited March 20

    I'm also seeing that my direct play is very much unusable on my Vizio. The TV was working fine just a week or so ago but now my movies are super choppy. I hope they get on some of these issues soon.

    UPDATE: I think some of my videos are still playing fine while direct playing. It might have to do with how high the bitrate is. The fact still remains though that these higher bitrate videos were playing fine just two weeks ago so something has changed to make them not playing smoothly.

  • bueller425bueller425 Members Posts: 96 ✭✭

    So now I'm not having any issues direct playing my high bitrate videos. Maybe the last non-Plex Pass server update fixed a few things I don't know but for me that problem has now gone away.

  • krash86.7krash86.7 Members, Plex Pass Posts: 8 Plex Pass

    I too am having the same issues mentioned above.

    I noticed that all is solved for me when I drop the bit-rate to 720p quality. Sometimes I have to go to the lowest 720p setting.
    When I do this the controls stop popping up randomly, and there are no more issues at all during playback.

    Dave

  • masterfammasterfam Members Posts: 4

    Was having the same issues on Plex Media Server 1.3. I've since updated to 1.4.4 but haven't retested on the Vizio. Will try later and post an update.

  • masterfammasterfam Members Posts: 4

    No go with media server 1.4.4

Sign In or Register to comment.