If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Tracking PMP functionality with Apollo Lake and Kaby Lake NUCs

SystemSystem Posts: 279 Plex Employee
This discussion was created from comments split from: Plex Media Player 1.2.3-RC1.
«13456

Comments

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass
    edited March 2017

    NUC7i3XXX running through this USB Type C Adaptor to HDMI 2.0

    No 7.1 Sound on any movie, most movies 5.1 appears to work

    however, on The Accountant, the 1080P Stutters heavily "Like goes to black screen for 10 seconds then comes back for 3 seconds, - Repeat" and no sound.. no matter what I select. 7.1, 5.1, nothing.

    CONF and LOGS attached.

    and

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    I will be testing the NUC7i3BNK tomorrow with the same adapter.

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass
    edited March 2017

    @Ach!lles have you tested the NUC7i3 yet? After further testing, I can say that its stuttering on all high quality 1080P movies.

    The overlay says "Hardware Decoding: vaapi (vaapi-egl)"

    I am not sure that means its transcoding (I wish the debug overlay would give CPU/Memory Information as well as clear Transcoding information) but the server is thinking its Direct Playing.

    Also, the read ahead buffer never really gets anything in it.

    More Logs Attached for those who are interested

    logs.zip 376.2K
  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @wesman said:
    @Ach!lles have you tested the NUC7i3 yet? After further testing, I can say that its stuttering on all high quality 1080P movies.

    The overlay says "Hardware Decoding: vaapi (vaapi-egl)"

    I am not sure that means its transcoding (I wish the debug overlay would give CPU/Memory Information as well as clear Transcoding information) but the server is thinking its Direct Playing.

    Also, the read ahead buffer never really gets anything in it.

    More Logs Attached for those who are interested

    I just started testing it yesterday. I do not see any stuttering with typical BD sourced content. However 4K HEVC content stutters badly.

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    @Ach!lles Added the nightly build 1.2.3.622-9c809060 and still seeing the issue with heavy stuttering. but its realated to the audio, have you tried the following?

    I have narrowed the problem down to the Audio.

    IF i have DTS-HD MA or Dolby TrueHD "selected as playable formats" and the file has one of those types of tracks. it stutters badly. (See image 1 below)

    IF i select a AC3 or DTS track, it works.

    IF i have DTS-HD MA or Dolby TrueHD "selected as NOT playable formats" and i have selected on of those files to play. it transcoded to PCM Stereo (see image 2)

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @wesman said:
    @Ach!lles Added the nightly build 1.2.3.622-9c809060 and still seeing the issue with heavy stuttering. but its realated to the audio, have you tried the following?

    I have narrowed the problem down to the Audio.

    IF i have DTS-HD MA or Dolby TrueHD "selected as playable formats" and the file has one of those types of tracks. it stutters badly. (See image 1 below)

    IF i select a AC3 or DTS track, it works.

    IF i have DTS-HD MA or Dolby TrueHD "selected as NOT playable formats" and i have selected on of those files to play. it transcoded to PCM Stereo (see image 2)

    Can I see what is in your mpv.conf if you have one?

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    @Ach!lles said:
    Can I see what is in your mpv.conf if you have one?

    Do you mean the plexmediaplayer.conf? (attached)

    I can't find a mpv.conf, where is that located?

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @wesman said:

    @Ach!lles said:
    Can I see what is in your mpv.conf if you have one?

    Do you mean the plexmediaplayer.conf? (attached)

    I can't find a mpv.conf, where is that located?

    Same directory. If you don't see it, you don't have one.

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    yeah, i just read that it's not created by default, since I didn't create one, there isn't one..

    would this help? have you tested DTS MA 7.1?

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    has anyone else confirmed issues with Plex Media Player 1.2.3-RC1 with DTS HD MA or TRUEHD?

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @Ach!lles said:

    @wesman said:
    @Ach!lles Added the nightly build 1.2.3.622-9c809060 and still seeing the issue with heavy stuttering. but its realated to the audio, have you tried the following?

    I have narrowed the problem down to the Audio.

    IF i have DTS-HD MA or Dolby TrueHD "selected as playable formats" and the file has one of those types of tracks. it stutters badly. (See image 1 below)

    IF i select a AC3 or DTS track, it works.

    IF i have DTS-HD MA or Dolby TrueHD "selected as NOT playable formats" and i have selected on of those files to play. it transcoded to PCM Stereo (see image 2)

    Can I see what is in your mpv.conf if you have one?

    @wesman Yes I see the same issue with PCM functioning erratically. This is because of that stupid Megachips LSPCon. Until Intel does something about this, Apollo Lake and Kaby Lake are drowning in the water for embedded.

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    @Ach!lles said:

    @Ach!lles said:

    @wesman said:
    @Ach!lles Added the nightly build 1.2.3.622-9c809060 and still seeing the issue with heavy stuttering. but its realated to the audio, have you tried the following?

    I have narrowed the problem down to the Audio.

    IF i have DTS-HD MA or Dolby TrueHD "selected as playable formats" and the file has one of those types of tracks. it stutters badly. (See image 1 below)

    IF i select a AC3 or DTS track, it works.

    IF i have DTS-HD MA or Dolby TrueHD "selected as NOT playable formats" and i have selected on of those files to play. it transcoded to PCM Stereo (see image 2)

    Can I see what is in your mpv.conf if you have one?

    @wesman Yes I see the same issue with PCM functioning erratically. This is because of that stupid Megachips LSPCon. Until Intel does something about this, Apollo Lake and Kaby Lake are drowning in the water for embedded.

    I though the USB C Adaptor did not go through the LSPCon chip, is that not correct?

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    @Ach!lles said:
    @wesman Yes I see the same issue with PCM functioning erratically. This is because of that stupid Megachips LSPCon. Until Intel does something about this, Apollo Lake and Kaby Lake are drowning in the water for embedded.

    Also, when I uncheck those as supported, it transcode the Audio to Stereo, that can't be the chip.

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @wesman said:

    @Ach!lles said:

    @Ach!lles said:

    @wesman said:
    @Ach!lles Added the nightly build 1.2.3.622-9c809060 and still seeing the issue with heavy stuttering. but its realated to the audio, have you tried the following?

    I have narrowed the problem down to the Audio.

    IF i have DTS-HD MA or Dolby TrueHD "selected as playable formats" and the file has one of those types of tracks. it stutters badly. (See image 1 below)

    IF i select a AC3 or DTS track, it works.

    IF i have DTS-HD MA or Dolby TrueHD "selected as NOT playable formats" and i have selected on of those files to play. it transcoded to PCM Stereo (see image 2)

    Can I see what is in your mpv.conf if you have one?

    @wesman Yes I see the same issue with PCM functioning erratically. This is because of that stupid Megachips LSPCon. Until Intel does something about this, Apollo Lake and Kaby Lake are drowning in the water for embedded.

    I though the USB C Adaptor did not go through the LSPCon chip, is that not correct?

    I had tested with the built in HDMI port.

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @wesman said:

    @Ach!lles said:
    @wesman Yes I see the same issue with PCM functioning erratically. This is because of that stupid Megachips LSPCon. Until Intel does something about this, Apollo Lake and Kaby Lake are drowning in the water for embedded.

    Also, when I uncheck those as supported, it transcode the Audio to Stereo, that can't be the chip.

    I will give that a deeper look with and without the Club 3D adapter.

  • wesmanwesman Posts: 616Members, Plex Pass Plex Pass

    @Ach!lles said:
    I will give that a deeper look with and without the Club 3D adapter.

    According to the Intel Posts the Club Adaptor does not use the LSPCon chip so, should not be affected by that.

    Give it a shot, DTS HD MA, ATMOS, TRUEHD. All cause serious stuttering. and when transcoded, go to stereo

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja

    @wesman said:

    @Ach!lles said:
    I will give that a deeper look with and without the Club 3D adapter.

    According to the Intel Posts the Club Adaptor does not use the LSPCon chip so, should not be affected by that.

    Give it a shot, DTS HD MA, ATMOS, TRUEHD. All cause serious stuttering. and when transcoded, go to stereo

    We are flip flopping back and forth here. Which OS so that I can reproduce?

  • KaraokeAmericaKaraokeAmerica Posts: 266Members, Plex Pass Plex Pass

    @Ach!lles said:

    Also, when I uncheck those as supported, it transcode the Audio to Stereo, that can't be the chip.

    I will give that a deeper look with and without the Club 3D adapter.

    "Club 3D adapter"? What is that?

  • AchillesAchilles Posts: 2,123Members, Plex Pass, Plex Ninja Plex Ninja
    edited March 2017

    @KaraokeAmerica said:

    @Ach!lles said:

    Also, when I uncheck those as supported, it transcode the Audio to Stereo, that can't be the chip.

    I will give that a deeper look with and without the Club 3D adapter.

    "Club 3D adapter"? What is that?

    A DisplayPort to HDMI adapter.

  • KaraokeAmericaKaraokeAmerica Posts: 266Members, Plex Pass Plex Pass

    @Ach!lles said:

    @KaraokeAmerica said:

    @Ach!lles said:

    Also, when I uncheck those as supported, it transcode the Audio to Stereo, that can't be the chip.

    I will give that a deeper look with and without the Club 3D adapter.

    "Club 3D adapter"? What is that?

    A DisplayPort to HDMI adapter.

    Cool, but disappointing. I thought it was some "club" (PlexPass or something) adapter for Plex that allowed it to play real, full-resolution 3D like Kodi.......;)

    Still searching for that capability.......

«13456
Sign In or Register to comment.