Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Adding music videos to my PLEX music library

ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

Have followed the PLEX help/tutorials and still having problems getting my music videos to come up in my music library in my PLEX server. Have organised the library like so...
Volumes/
.HD10TB/
.Media/
.Plex/
.Music/
.Foo Fighters/
.Foo Fighters - Learn To Fly/
.01-Learn To Fly - Learn To Fly-video.mp4

MUST the mp3 version of the track be in the file as well for it to work?
What am I doing wrong here?

A.BISHOP-O'NEILL B)

Best Answer

«1

Answers

  • ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

    Wow, so strange... will give it a go.
    Thanks

    A.BISHOP-O'NEILL B)

  • ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

    But the directory... is it correct? The file name etc?

    A.BISHOP-O'NEILL B)

  • ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

    Yes refreshed after each change with the directory etc

    A.BISHOP-O'NEILL B)

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 22,735 Plex Ninja

    @ajbishoponeill said:
    But the directory... is it correct? The file name etc?

    If you don't have a track 01-Learn To Fly - Learn To Fly.mp3 in the same folder, the video should at least appear directly under the Artist.

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

    So right now I have:
    .Radiohead/
    .A Moon Shaped Pool/
    .01 Burn The Witch.flac
    .01 Burn The Witch - Burn The Witch-video.mkv

    but only the mkv file is showing up in the Plex player/library, is there something I'm doing wrong here? The rest of the audio tracks are showing. Just not the audio track for "Burn The Witch".

    A.BISHOP-O'NEILL B)

  • ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

    Nothing showed up without the audio track (Foo Fighters) still playing with all of this and seeing what works. I have a lot of videos from albums/DVD/Blu-Ray that I'd love to add to the artists folders etc. Will be a challenge I can see...

    A.BISHOP-O'NEILL B)

  • ajbishoponeillajbishoponeill Members, Plex Pass Posts: 16 Plex Pass

    okay, finally got it working/sorted it out... thanks for the help @OttoKerner

    A.BISHOP-O'NEILL B)

  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass

    I want ask is the the way you name Music Video's in global Folder?
    in the documentation it shows them named like this as well

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 22,735 Plex Ninja
    edited June 28

    1) leave out the space characters before and after the last hyphen (before the 'type' of the videoclip).

    2) videos will only appear after you 'Refresh Metadata' of your music library

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass

    @OttoKerner said:
    1) leave out the space characters before and after the last hyphen (before the 'type' of the videoclip).

    2) videos will only appear after you 'Refresh Metadata' of your music library

    thank you for that Otto, So the naming would be Ice Cube - It Was A Good Day(video).mp4 and can you give me syntax to put in Filebot for correct naming of music videos so when i rename it automatically will get done buy Filebot. Thanks

    .

  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass
    edited June 30

    @OttoKerner said:
    1) leave out the space characters before and after the last hyphen (before the 'type' of the videoclip).

    2) videos will only appear after you 'Refresh Metadata' of your music library

    2Pac - Brenda's Got A Baby(video).mp4 correct?

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 22,735 Plex Ninja

    @blueeyiz702 said:
    This is What i Came up with for my Music Video Collection so far got ,thanks Otto
    2Pac - Brenda's Got A Baby(video).mp4 correct?

    I think that should be
    2Pac - Brenda's Got A Baby-video.mp4

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass

    @OttoKerner said:
    Have you 'Refresh'ed the Artist after adding the video?

    Artist videos must be in a directory that contains at least one music track for the artist.

    Otto,i used your naming convention,and have videos named also with matching audio track but nothing shows for videos.
    using global folder and have it set up exactly like it shows you how ? Refreshed metadata and scanned files again and nada.

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 22,735 Plex Ninja

    @blueeyiz702 said:
    Otto,i used your naming convention,and have videos named also with matching audio track but nothing shows for videos.
    using global folder and have it set up exactly like it shows you how ? Refreshed metadata and scanned files again and nada.

    Do you have it in a subfolder? Like so:

    Musicvideos/2Pac/2Pac - Brenda's Got A Baby-video.mp4
    

    And the 'Local Media Assets' is still active both under Artists and Albums?

    You might also have to refresh your whole library (instead of just one artist) is you use a 'global' music videos folder.

    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass
    edited July 2

    @OttoKerner said:

    @blueeyiz702 said:
    Otto,i used your naming convention,and have videos named also with matching audio track but nothing shows for videos.
    using global folder and have it set up exactly like it shows you how ? Refreshed metadata and scanned files again and nada.

    Do you have it in a subfolder? Like so:

    Musicvideos/2Pac/2Pac - Brenda's Got A Baby-video.mp4
    

    And the 'Local Media Assets' is still active both under Artists and Albums?

    You might also have to refresh your whole library (instead of just one artist) is you use a 'global' music videos folder.

    I just checked and it keeps going to back to default, after i set path to Global Folder for music videos in both Artist and Album when i go back in Plex the path is empty again..
    And my GlobalFolder is just named MusicVideos, is there a certain way to name it?
    and folder is set up like this. MusicVideos/Aerosmith/Aerosmith - Jaded-video.mp4

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 22,735 Plex Ninja

    @blueeyiz702 said:
    And my GlobalFolder is just named MusicVideos, is there a certain way to name it?
    and folder is set up like this. MusicVideos/Aerosmith/Aerosmith - Jaded-video.mp4

    No, there is not a special name required for the top folder.

    I just checked and it keeps going to back to default, after i set path to Global Folder for music videos in both Artist and Album when i go back in Plex the path is empty again..

    This appears to be the problem.
    Try with a different web browser.

    If that doesn't help, we'll need to take a look at your server log files.

    1. activate debug logging (not 'verbose'!)
    2. quit Plex Server
    3. wait 1 minute
    4. start Plex Server
    5. wait 2 minutes
    6. try to set the global music videos folder
    7. wait 3 minutes
    8. fetch log files and attach them here
    Help others too - by reporting back with your results!
    Have you checked the Documentation before posting a question in the forums?
    Use the SEARCH function before starting a new thread!
    No PMs unless requested, please! Do not use 'verbose' logging
  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass
    edited July 3

    @OttoKerner said:

    @blueeyiz702 said:
    And my GlobalFolder is just named MusicVideos, is there a certain way to name it?
    and folder is set up like this. MusicVideos/Aerosmith/Aerosmith - Jaded-video.mp4

    No, there is not a special name required for the top folder.

    I just checked and it keeps going to back to default, after i set path to Global Folder for music videos in both Artist and Album when i go back in Plex the path is empty again..

    This appears to be the problem.
    Try with a different web browser.

    If that doesn't help, we'll need to take a look at your server log files.

    1. activate debug logging (not 'verbose'!)
    2. quit Plex Server
    3. wait 1 minute
    4. start Plex Server
    5. wait 2 minutes
    6. try to set the global music videos folder
    7. wait 3 minutes
    8. fetch log files and attach them here

    I just filed this in not 10 minutes ago,this is one problem i have its not sticking when i fill it in! I'm using Opera and it works fine,so there must be a issue with Chrome browser going on.And even with correct folder and naming the videos still won't show up,UGH!

  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass

    @OttoKerner hhere is log file and it from Opera Browser. Started having problems scanning albums,when i tried to add 2pac folder in 3 hours only 6 albums showed up.Rest of time is just kept spinning and did nothing.

  • blueeyiz702blueeyiz702 Members, Plex Pass Posts: 47 Plex Pass
    edited July 4

    @OttoKerner i think i figured out problem. because i redid my music,i never optimized data base after emptied trash and cleaned bundles. that was the step i was missing and i have a browser ext called HTTPS Everywhere that encrypts everything that goes thru plex,forgot to disable it and my ad blocker. So i'm redoing music and i will let you know. And thanks again! >:)
    Funny i unchecked use embedded tags when you first ad music and it blew through my 35 album Aerosmith Collection like it was butter without problem.it processed 15 albums in about 5 minutes so i thinking i'll not use the tags embedded.

«1
Sign In or Register to comment.