Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[RELEASE] OpenPHT 1.8.0

2456

Comments

  • daniel.culldaniel.cull Posts: 300Members, Plex Pass Plex Pass

    what 'device profile' is your harmony IR remote set to use for the odroid?

    Enjoy Rasplex/OpenPHT? Consider dropping some bones into our development war chest! All donations go toward development expenses so our volunteers spend less out of pocket. rasplex.com

    Check out the Epic Aeon Nox Skin for OpenPHT
    Like Aeon Nox 5 and want to donate some money to help support development? Click here to donate.

  • nielsvdpnielsvdp Posts: 59Members, Plex Pass Plex Pass
    edited March 22

    Installed 1.8 last night on my Wetek Hub - Awesome release - everything works as expected, Harmony Remote no issues.

    4k HEVC files are now playable and look awesome ! many thanks for the update !

    Will install this weekend on Chromebox and try it out.

  • daniel.culldaniel.cull Posts: 300Members, Plex Pass Plex Pass

    @jakmak said:
    On The Odroid C2 embedded I get no response from my harmony IR remote.
    From Update or fresh install its the same. Dead remote.
    If I roll Back everything works fine.

    apparently there is a setting now to disable/enable lirc in the settings, please check its turned on

    Enjoy Rasplex/OpenPHT? Consider dropping some bones into our development war chest! All donations go toward development expenses so our volunteers spend less out of pocket. rasplex.com

    Check out the Epic Aeon Nox Skin for OpenPHT
    Like Aeon Nox 5 and want to donate some money to help support development? Click here to donate.

  • plexburkeplexburke Posts: 494Members, Plex Pass Plex Pass
    edited March 22

    @Stephen3001 said:
    Has anyone had any problems with frame rates? Using Ver 1.8.0 and everything plays at 24fps. I've tried some 25i material (TV shows) and I get judder everytime when it adds a frame..

    It seems as though it's not changing frame rates based not he material. The previous version (1.7.1) worked fine.

    Any ideas?

    I'm using the same exact nuc (awesome) and OPHT (Intel embedded) and can confirm I've not had any issues with frame rates. I have some sports running at 50 and 60 FPS (at 1080p and 720p) and it's playing them properly. I haven't run across any 25 fps shows or movies but will report back if I do.

    Edit- I saw you were using a qnap NAS and thought it might be a lack of processing power. Definitely wrong about that. You didn't mess around picking your machine. Impressive.

  • wally007wally007 Posts: 1,233Members, Plex Pass Plex Pass

    Thank you for the new version. So far as stable as 1.71

  • jakmakjakmak Posts: 4Members, Plex Pass Plex Pass
    edited March 22

    @daniel.cull said:

    @jakmak said:
    On The Odroid C2 embedded I get no response from my harmony IR remote.
    From Update or fresh install its the same. Dead remote.
    If I roll Back everything works fine.

    apparently there is a setting now to disable/enable lirc in the settings, please check its turned on

    The Remote sends Microsoft keyboard commands.
    The lirc setting was enabled by default.
    When I turned the lirc setting OFF my logitech harmony one started working perfectly.

    Thanks for pointing me in the right direction.

  • Stephen3001Stephen3001 Posts: 171Members, Plex Pass Plex Pass

    @daniel.cull

    Yeah somethings not right. The version I am running is the Intel embedded version. It plays 24fps movies just fine, the 25fps stuff is juddering.

    I've tried rebooting etc. Still the same on startup. It just looks like the framerate out of the device is locked permanently to 24fps and won't change.

    I'll have to dig it out on the weekend and reinstall the software from scratch and see if that fixes it. I will also update the NUC to the latest firmware (Its been sitting the entertainment centre quietly doing its job no problems).

    @plexburke Yes this QNAP does have a bit of horsepower, handles multiple transcodes with ease. Not your entry level device.

    ****My Equipment****

    PMS Media Server/Storage - QNAP TVS-1282T (I7, 32Gb RAM) 48TB Storage, QNAP TVS-463 12TB

    1Gb Wired Networking.

    Media Players
    OpenPHT on Intel NUC6I5SYH Core i5 NUC, XBOXOne, iPad, iPhone, Android Phone, Chromecast

  • finagle69finagle69 Posts: 76Members, Plex Pass Plex Pass

    You guys are doing great work. This release is running great and feels snappier than before on 1.7x :)

  • nielsvdpnielsvdp Posts: 59Members, Plex Pass Plex Pass

    @Kwiboo noticing some files in the .cache/cores dir ;
    core.!usr!lib!plexht!plexhometheater.1489950071 and core.!usr!lib!plexht!plexhometheater.1489718770

    Together they take up 1.5GB of space making the backups much larger.

    What are these and can they be deleted ?

  • l-rsl-rs Posts: 177Members, Plex Pass Plex Pass

    I complained about 1.7.1 quite a bit (and switched to Chromecast for the last couple of months) but just wanted to say this version has fixed all my issues. :)

  • jun6leejun6lee Posts: 7Members ✭✭

    Running smoothly. Thank you.

    Small request:
    Can we add this acknowledged bug to the known issues just so it's not lost in a black hole?
    https://github.com/RasPlex/OpenPHT/issues/95

    I'm hopeful with the visibility some smart cookie may crack the problem.

  • Stephen3001Stephen3001 Posts: 171Members, Plex Pass Plex Pass

    So the 1.8.0 experience isn't working for me here in 25fps land.

    If I set the output of OpenPHT to 4K/24Hz, all 25p material on the output judders (576p, 1080p). If I set the output of OpenPHT to 1080p there is no judder in the playback.

    So it looks like I can't use a 4K resolution if I want to watch 25Hz material. How can I report this?

    ****My Equipment****

    PMS Media Server/Storage - QNAP TVS-1282T (I7, 32Gb RAM) 48TB Storage, QNAP TVS-463 12TB

    1Gb Wired Networking.

    Media Players
    OpenPHT on Intel NUC6I5SYH Core i5 NUC, XBOXOne, iPad, iPhone, Android Phone, Chromecast

  • KwibooKwiboo Posts: 192Members, Plex Pass Plex Pass

    @Stephen3001 said:
    So the 1.8.0 experience isn't working for me here in 25fps land.

    If I set the output of OpenPHT to 4K/24Hz, all 25p material on the output judders (576p, 1080p). If I set the output of OpenPHT to 1080p there is no judder in the playback.

    So it looks like I can't use a 4K resolution if I want to watch 25Hz material. How can I report this?

    Please try with these preferences options set:

    • Playback -> Advanced video -> Adjust display refresh rate: On start / stop
    • Playback -> Advanced video -> Sync playback to display: Unchecked
    • System -> Advanced -> Resolution: 1920x1080p (TV should switch to 4K when playing a 4K video)
    • System -> Advanced -> Refresh rate: 60.00
    • System -> Advanced -> Vertical blank sync: Let driver choose

    If this does not work, please provide a sample file that is showing the same problem and a debug enabled log file from openpht, thanks.

  • KwibooKwiboo Posts: 192Members, Plex Pass Plex Pass

    @nielsvdp said:
    @Kwiboo noticing some files in the .cache/cores dir ;
    core.!usr!lib!plexht!plexhometheater.1489950071 and core.!usr!lib!plexht!plexhometheater.1489718770

    Together they take up 1.5GB of space making the backups much larger.

    What are these and can they be deleted ?

    It looks like very big crash dumps from before 1.8.0 (2017-03-19 and 2017-03-17 when converting the unix time suffix) and should be safe to delete.

  • Stephen3001Stephen3001 Posts: 171Members, Plex Pass Plex Pass

    @Kwiboo

    I set the preferences as you suggested. The only variation I employed was that I set the Refresh rate to 50.00.

    The frame stuttering on the 25p material has now gone. Thank you.

    Although it used to work before when I had the display set to 3840 x 2160 24p.

    Anyway it shows 25p material okay now, I haven't checked the output change when playing 4K as yet. Will do that in the coming days.

    Once again thanks for your help.

    ****My Equipment****

    PMS Media Server/Storage - QNAP TVS-1282T (I7, 32Gb RAM) 48TB Storage, QNAP TVS-463 12TB

    1Gb Wired Networking.

    Media Players
    OpenPHT on Intel NUC6I5SYH Core i5 NUC, XBOXOne, iPad, iPhone, Android Phone, Chromecast

  • fbauta2fbauta2 Posts: 1Members

    Thanks for the support.
    I installed the openPHT version 1.6.2 first, and today I installed 1.8.0, in my Qnap TS 251+, in both versions I have problems to play 3D movies, openPHT identify the files, it is configured to select the format, side by Side Or over under, which are the movie formats that I own, identify the 3D format, but do not put the pictures together, and I tried to rename the files of different ways, but I continue with the same problem, these same files I Play On a raspberry PI 2 with rasplex 1.8.0 and here work perfectly in 3D, I have changed video configurations in many ways in openPHT and I have not been able to put the images together in 3D.
    Any help please with this problem, I currently use raspberry to see 3D and openPHT on the NAS to have TRUE HD audio, not supported in raspberry, I would like to have all in the openPHT version in my NAS.

  • brimurbrimur Posts: 26Members, Plex Pass Plex Pass
    edited March 31

    Just an FYI on an issue I saw with OpenPHT 1.8.0 that does not exist on my other LibreElec based devices. I have changed my setup now so unfortunately I cant provide logs.

    My setup was OpenPHT box ->connected to the TV via HDMI and the TV ->connected to the AV receiver via optical. With my other boxes I go to the Audio section in Settings and set the speaker number to 5.1 and checked passthrough and select all the available options that my receiver supports. The TV is also set to passthrough and I could hear audio fine through all my speakers. With OpenPHT I could not hear any audio at all, with or without Passthrough checked, unless I set the speakers to 2.0. My understanding was this was ok as multichannel would still work with the speakers set to 2.0 as long as Passthrough was checked. This was not the case for me. With the speakers set to 2.0 and passthrough checked I only got audio from the center speaker and it was very low.

    This was unfortunate but I have shuffled my devices around now though so I have the OpenPHT box directly connected to the AV receiver and passthrough is working perfectly. Thanks guys

  • jmaxlowjmaxlow Posts: 6Members ✭✭

    The new release is functioning terrifically (love the new way the home screen can be customized) except in one area for me. Any video file I play is very washed out - blacks are light grays, contrast is low, and everything has a flat appearance. This happens whether the file is encoded in h264 or h265. It's independent of my TV brightness and contrast settings, because playing the same files in VLC media player shows them with the correct black levels, etc. Even the Aeon Nox skin itself of the new release shows black levels and contrast correctly. Only videos themselves get washed out.

    I looked for some sort of color calibration within the release and can't find any. The wash out did not happen with the previous few releases.

    Does anyone have any ideas on what is causing this? I have an i5 running Windows 10 with the latest Intel video drivers.

  • daniel.culldaniel.cull Posts: 300Members, Plex Pass Plex Pass

    @jmaxlow said:
    The new release is functioning terrifically (love the new way the home screen can be customized) except in one area for me. Any video file I play is very washed out - blacks are light grays, contrast is low, and everything has a flat appearance. This happens whether the file is encoded in h264 or h265. It's independent of my TV brightness and contrast settings, because playing the same files in VLC media player shows them with the correct black levels, etc. Even the Aeon Nox skin itself of the new release shows black levels and contrast correctly. Only videos themselves get washed out.

    I looked for some sort of color calibration within the release and can't find any. The wash out did not happen with the previous few releases.

    Does anyone have any ideas on what is causing this? I have an i5 running Windows 10 with the latest Intel video drivers.

    Hi

    i have 3 core i5 machines with windows 10, was no difference upgrading to the latest version,

    What advanced video settings have you changed from default if any?
    Is 'use limited colour range (16-235) enabled or disabled?

    Enjoy Rasplex/OpenPHT? Consider dropping some bones into our development war chest! All donations go toward development expenses so our volunteers spend less out of pocket. rasplex.com

    Check out the Epic Aeon Nox Skin for OpenPHT
    Like Aeon Nox 5 and want to donate some money to help support development? Click here to donate.

  • nielsvdpnielsvdp Posts: 59Members, Plex Pass Plex Pass

    @daniel.cull said:

    What advanced video settings have you changed from default if any?
    Is 'use limited colour range (16-235) enabled or disabled?

    Where is that setting btw ?

Sign In or Register to comment.