Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to turn Subtitles off by default?

rbhamiltonrbhamilton Members Posts: 12 ✭✭

I'm watching Plex on a Roku 4.

My movie is in English. I speak English. I have one set of subtitles available also English. I don't need English subtitles.

My subtitle automatically plays. Every. Freekin. Time.

I can turn it off by going down to the bottom, selecting options, selecting streams, etc. But is there any way to disable all subtitles by default?

Even better... when you are watching an English show that has English subtitles available but you've turned them off. Suddenly the characters encounter somebody speaking German. How do you get the English subtitles to pop up but only for the non-english parts?

Any advice would be appreciated.

Tagged:

Answers

  • NewPlazaNewPlaza Members, Plex Pass Posts: 280 Plex Pass
    edited March 28

    There is a way you can disable all subtitles. If you want this to be as flawless as possible you will need to make some changes. Will this work for the classic Plex version for Roku... Probably not..

    1st) Server settings.

    2nd) The subtitle(s) tracks for the movie must be set correctly.

    You should see something like this.

    As you can see, SRT track 1 is on and set as the default and will be shown in the movie.

    Remember though, the last part of your question relies on you. If you don't have a subtitle file that only contains the non-English parts of the movie then it won't work the way you want it to. This of course is for local files you have, not some online source...

    I do not use any online sources to automatically pull down subtitles so I do NOT know if subtitles will display for non-English parts...

Sign In or Register to comment.