Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can't resume from last position

sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

I am having an issue when I cast to my Chromecast that the show is now always starting from the beginning and ignoring the last position? I am running server version 1.5.2.3557 and it does this from the web interface and the iOS app. Any ideas?

«134

Answers

  • Sitruk86Sitruk86 Members, Plex Pass Posts: 135 Plex Pass

    YES! This! This is a new development after the most recent Plex Pass server update.

    Software:
    - Windows Server 2012 R2
    - PMS v1.5.2.3557
    - Plex Android v5.7.1.255 (b7c2f214)

    Troubleshooting:
    - Restart Windows Server
    - Restart Android Phone
    - Restart Chromecast

    The issue is only present when casting to a Chromecast (from any source). The web interface in Chrome the Android app (without Chromecast) resumes from the previous stopping point normally.

    PMS Log attached. Please let me know if any more information is required.

  • sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

    The latest Plex Server update did not resolve this extremely frustrating issue. :# Every time I try to throw a show up on my Chromecast Ultra it loses its last position and starts over at the beginning

  • Sitruk86Sitruk86 Members, Plex Pass Posts: 135 Plex Pass

    Yea, I'm a little disappointed that there has been no acknowledgement of this post. I also don't see this issue mentioned anywhere else.

    I'm glad I can still play my media, but you're right, this issue is very frustrating.

  • Sitruk86Sitruk86 Members, Plex Pass Posts: 135 Plex Pass

    Well, resume randomly started working again. Nothing has changed... It wasn't working all day, I stopped using plex for about 2 hours and when I went to resume a show it started it at the correct time. I dunno.

  • sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

    I wouldn't get your hopes up too high. Mine randomly worked once a few days ago and then right back to not working again. I just tried it on mine and it failed to resume the last position.

  • Sitruk86Sitruk86 Members, Plex Pass Posts: 135 Plex Pass

    Still resuming properly. Such a mysterious issue. I wish I had some indication of why it happened and what resolved it.

  • sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

    I'm glad you were able to get yours to work because apparently Plex isn't going to offer any support or even acknowledge that they are aware of the issue...My particular favorite is the fact that their contact form directs you here for support and says that support questions will go unanswered on the contact form....then they just ignore your forum posts.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,371 Plex Employee

    @sircolby45 - Can you provide more details on the steps you are performing. Are you given the option to resume when you hit play? I'm not able to reproduce the problem you describe. I have a Windows based server, using my Android phone to cast to a 1st gen CC. When I hit play for something that is in progress, I get the option to resume or start from the beginning. If I choose resume, it starts playing at the expected spot.

    @Sitruk86 - I'm not seeing the problem in your log. It shows that Plex knows the current resume spot. Note that times are in milliseconds.

    Apr 01, 2017 12:06:23.874 [3344] INFO - [Chromecast] Offset: 309000

    Then it trys to start from that location

    Apr 01, 2017 12:06:24.567 [3272] INFO - [Chromecast] [Player] Resuming at 309000

    It couldn't start at that exact spot due to the way the file is made so it backed up a bit

    Apr 01, 2017 12:06:26.580 [4888] DEBUG - Completed: [::ffff:192.168.1.3:36905] 200 OPTIONS /:/timeline?hasMDE=1&ratingKey=611786&key=%2Flibrary%2Fmetadata%2F611786&state=playing&playQueueItemID=271291&time=300747&duration=1297152 (8 live) TLS GZIP 1ms 555 bytes (pipelined: 1)

    The progress than continues as expected

    Apr 01, 2017 12:06:30.165 [4080] DEBUG - Completed: [::ffff:192.168.1.3:36911] 200 OPTIONS /:/timeline?hasMDE=1&ratingKey=611786&key=%2Flibrary%2Fmetadata%2F611786&state=playing&playQueueItemID=271291&time=303628&duration=1297152 (6 live) TLS GZIP 1ms 555 bytes (pipelined: 1)

  • Sitruk86Sitruk86 Members, Plex Pass Posts: 135 Plex Pass

    @MovieFan.Plex said:
    @sircolby45 - Can you provide more details on the steps you are performing. Are you given the option to resume when you hit play? I'm not able to reproduce the problem you describe. I have a Windows based server, using my Android phone to cast to a 1st gen CC. When I hit play for something that is in progress, I get the option to resume or start from the beginning. If I choose resume, it starts playing at the expected spot.

    @Sitruk86 - I'm not seeing the problem in your log. It shows that Plex knows the current resume spot. Note that times are in milliseconds.

    Apr 01, 2017 12:06:23.874 [3344] INFO - [Chromecast] Offset: 309000

    Then it trys to start from that location

    Apr 01, 2017 12:06:24.567 [3272] INFO - [Chromecast] [Player] Resuming at 309000

    It couldn't start at that exact spot due to the way the file is made so it backed up a bit

    Apr 01, 2017 12:06:26.580 [4888] DEBUG - Completed: [::ffff:192.168.1.3:36905] 200 OPTIONS /:/timeline?hasMDE=1&ratingKey=611786&key=%2Flibrary%2Fmetadata%2F611786&state=playing&playQueueItemID=271291&time=300747&duration=1297152 (8 live) TLS GZIP 1ms 555 bytes (pipelined: 1)

    The progress than continues as expected

    Apr 01, 2017 12:06:30.165 [4080] DEBUG - Completed: [::ffff:192.168.1.3:36911] 200 OPTIONS /:/timeline?hasMDE=1&ratingKey=611786&key=%2Flibrary%2Fmetadata%2F611786&state=playing&playQueueItemID=271291&time=303628&duration=1297152 (6 live) TLS GZIP 1ms 555 bytes (pipelined: 1)

    I am currently unable to replicate the issue. However, when it did occur Plex would do everything normally up until the media started to play. Then it would jump from the resume position just before playing and start at the beginning.

    I had the issue crop up again randomly but I reset my Chromecast to factory defaults and the issue went away. Since the only constant in the situation was the Chromecast, I assume it had something to do with that.

    I'm not completely sure, but the issue may be triggered by a improper disconnect event while playing media. For example, while playing something, Plex disconnects from the Chromecast mid-stream and the stream continues. When you attempt to reconnect, the stream will stop and start from the beginning on its own. Then you go to stop the stream and resume it from where it had stopped and then you are presented with the issue. This doesn't occur all the time but once it happens it seems to get stuck in this limbo state where it refuses to resume properly. The last time it happened I performed the factory reset and it resolved the problem. Not an optimal solution but it worked.

  • sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

    I see the same issue that Sitruk86 described. I choose the resume option and on whatever I am casting from it shows it starting at the correct time and then all of a sudden the progress bar jumps back to 0 right before the video starts on the Chromecast. It doesn't matter if I am casting from the web app or the iOS app I get the same result every time. I tried hard reseting my Chromecast, but unfortunately I still got the same result afterwards unlike Sitruk. I can drag the time back to the original position and it jumps there just fine. It is just the initial Resume that is resetting. Even though it happened immediately after v1.5.2.3557 server update rolling back to the previous version still exhibited the same issue. (I rolled it back to the version before that by uninstalling it and reinstalling from the installer in the app data folder.)

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,371 Plex Employee

    The only thing I can think is that the playback is trying to resume but then failing for some reason, so the playback then has to fallback to something else which is then losing the position of the file. I'll try and see if I can cause a failed playback to see if it does lose the position.

  • sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

    Any luck? Mine is still not resuming properly. :(

  • Ted_ShecklerTed_Sheckler Members Posts: 18 ✭✭

    Just started experiencing this same issue tonight. Nothing mentioned in this thread fixed the issue. Hopefully a fix is in the works.

  • lefung666lefung666 Members Posts: 2

    This started happening to me as well about a week ago. It will not resume. It starts the video from the beginning. This only happens on the chromecast when i'm casting to it, on the phone resume is fine and on the pc.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,371 Plex Employee

    @sircolby45 said:
    Any luck? Mine is still not resuming properly. :(

    Sorry no luck reproducing the problem. I've tried a bunch of different video types and they all resume properly for me. Can you provide me a new PMS log after recreating the problem?

  • sircolby45sircolby45 Members, Plex Pass Posts: 13 Plex Pass

    @MovieFan.Plex said:

    @sircolby45 said:
    Any luck? Mine is still not resuming properly. :(

    Sorry no luck reproducing the problem. I've tried a bunch of different video types and they all resume properly for me. Can you provide me a new PMS log after recreating the problem?

    I sent you 2 PMs. One had the logs and the other had a video demonstrating the issue. Let me know if you need anything else.

    Thanks,
    Colby

  • Ted_ShecklerTed_Sheckler Members Posts: 18 ✭✭

    @lefung666 said:
    This started happening to me as well about a week ago. It will not resume. It starts the video from the beginning. This only happens on the chromecast when i'm casting to it, on the phone resume is fine and on the pc.

    Exactly the same for me. Chromecast is the problem it would seem.

  • kalmard@gmail.comkalmard@gmail.com Members, Plex Pass Posts: 1 Plex Pass

    Same bug here, happens 100% of the time.

  • mrThirstymrThirsty Members, Plex Pass Posts: 12 Plex Pass

    Same here @MovieFan.Plex Any media cast to my chromecast in the same scenarios as mentioned above will always restart from the beginning, not from the resume position.

    The IOS App does show the correct position but then once chromecast starts playing it jumps to zero in the app, while chromecast gives no indication of it trying to resume.

    I don't get the option to resume or restart in the app like I used to anymore as well.

  • MovieFan.PlexMovieFan.Plex Members, Plex Pass, Plex Ninja Posts: 15,371 Plex Employee

    Please provide me the log from the app you are casting from.

«134
Sign In or Register to comment.