Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

BT Home Hub + Chromecast + Plex (ready to cast but won't play content via browser)

shanomurphyshanomurphy Posts: 3Members ✭✭

I have a BT Home Hub 4 router and a Chromecast v2 but can't play content via the browser (Chrome). Steps to recreate issue

  1. Open Plex Web app
  2. Click cast icon and select chromecast (Plex logo + 'ready to cast' now appears on the TV)
  3. Try to play any media and web app will just display spinning loading icon and TV will remain on 'ready to cast'

Using a mobile device to initiate playback works fine.

I know it's something to do with the BT Home Hub as my previous router (Sky Hub) worked without issues. I also have experienced the exact same issue with a Home Hub 5 and Chromecast v1 at a relatives. Using the desktop app (windows) also has the same issue.

Things I've tried:

  • Turning off 'Smart Setup' on the hub
  • Turning off UPnP on the hub
  • Splitting wireless channels into separate 2.4GHz and 5GHz
Tagged:

Answers

  • shanomurphyshanomurphy Posts: 3Members ✭✭

    Forgot to say… initiating playback via Chrome browser for other websites/web-apps works fine (Netflix, YouTube etc.) Some it's some unique problem with Plex and the BT Home Hubs.

  • pauldwilson78pauldwilson78 Posts: 1Members

    Hi shanomurphy,

    Did you ever find a solution to this problem? I've just switched to BT and have this exact same problem.

    Thanks,

    Paul

  • shanomurphyshanomurphy Posts: 3Members ✭✭

    @pauldwilson78 said:
    Did you ever find a solution to this problem? I've just switched to BT and have this exact same problem.

    Well funnily enough I tried it again last week and it's now working perfectly :smiley:

    I don't know whether it was a Plex update that fixed it because I haven't tried since March. I guess a software update somewhere must have fixed it, either with plex the chromecast or maybe even the homehub itself.

Sign In or Register to comment.