If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Problem with Plex App on Xbox One - Green Screen output for Video

thegeezerthegeezer Posts: 23Members ✭✭
edited April 9 in Xbox One

After the recent spring Xbox update the Plex app no longer works properly.

On a number of media files all I get now is just a green screen whilst the audio plays normally. These are all files that previously played fine within the Xbox One Plex app, and still play fine with Plex iOS, Home Theatre, and Apple TV apps.

Particularly affected seems to be the following video format/codec:

  • Format: Matroska
  • Encoder: Lavf57.67.100
  • Codec: H.265 / HEVC

Plex Media Server is running on a MacMini, with the media stored on a Drobo. This setup has worked fine, and still works for the iOS, Apple TV and PHT apps - just not on the Xbox since the update.

Any ideas?

  • PMS - Version 1.5.3.3580
  • macOS - 10.12.2
  • Plex App Xbox - 1.8.0.0
  • Xbox OS - 10.0.15063.1005 (rs2_release_xbox_1703.170323-1228)
«1

Answers

  • PummyPummy Posts: 6Members, Plex Pass Plex Pass

    Having the same issue since xbox update, unable to play x265 videos. Just a green screen with sound. Potentially broken by xbox with the update?
    Had to turn off direct play to get video to work.

  • MoussaMoussa Posts: 1,364Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Hi there. Could you post the media info XML for any problematic files that worked pre-update? Also server logs, with logging enabled in the app, would be helpful. Thanks.

  • thegeezerthegeezer Posts: 23Members ✭✭

    I can try.. but I'm not that technical..
    How do I get the media info XML for the files?
    And how do I get the hold of logs etc from the Xbox One Plex app?

  • MoussaMoussa Posts: 1,364Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @thegeezer This article should help. Make sure you click the View XML link and grab that information.

    In the Xbox One Plex app go to settings and there should be a toggle to enable logging. After enabling logging, try playing the problematic media and then grab the server logs.

  • thegeezerthegeezer Posts: 23Members ✭✭
    edited April 12

    Hi @Moussa

    attached is the info you requested: logs from PMS as well as as the XML media info.
    I purged the log files and then played the files for 5 or 10 seconds in both the iOS app and in the Plex App for Xbox One. So that should all be in the logs I guess then. Couldn't find an option in the Plex Media Player (macOS) to toggle logging on/off.

    All these H.265/.mkv files still play fine in the iOS app, apple TV app and the Plex Media Player running directly on the mac mini. Just not on the Plex App for Xbox One anymore.

    Thanks for your help.

  • shanghailozshanghailoz Posts: 14Members, Plex Pass Plex Pass

    Same issue - audio works, but video shows a green screen.

    Works on other players, just not on Xbone, some stuff worked previously.

  • brodiegeigerbrodiegeiger Posts: 2Members, Plex Pass Plex Pass

    Im glad im not the only one having this issue.
    Yeah it is only doing this on the xbox one, all other players are fine.
    only h.265 hevc files on a MKV container.
    Is there any word of a fix soon?
    Is this on the XBONE side or the plex side?
    I have made sure that everything is up to date. Even deleted the app and reloaded it.

  • brodiegeigerbrodiegeiger Posts: 2Members, Plex Pass Plex Pass

    @pummy Did you turn the direct play off on the xbox one? or the plex server?

  • PummyPummy Posts: 6Members, Plex Pass Plex Pass

    Turned off in Xbox one app, forces server to transcode so you can at least watch.

  • ozbloggerozblogger Posts: 8Members ✭✭

    Just chipping in to say, happens to my x265 videos too
    And same green screen, on VLC app on xbox one with the same video
    So looks like xbox one update broke hevc direct play
    Microsoft's fault most likely

  • MoussaMoussa Posts: 1,364Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @thegeezer Thank you for your logs. Nothing particularly stands out to me there, so seems the issue might be with the file itself or the Xbox One decoder. Could you, or anyone else in this thread, perhaps send me a sample file that exhibits this issue? I have several h265 videos that playback fine post-Creator's Update.

  • gregculmergregculmer Posts: 1Members, Plex Pass Plex Pass

    I was getting the same issue and fixed it with the old classic.

    Hard Restart (long press on power button). After the restart my x265 encoded stuff appears to be working well!!

  • ghostmoon11ghostmoon11 Posts: 1Members

    I have been having the same issue since the latest Xbox One update.

    Glad to see it is not just me.

    Hopefully a fix will come soon as majority of my files are in HEVC.

    I have tried the few fixes a couple of people have mentioned here and neither have worked for my console.

  • thegeezerthegeezer Posts: 23Members ✭✭
    edited April 22

    @gregculmer thanks for the suggestion.

    I tried power cycling the Xbox, unfortunately no such luck.
    Still just a green screen with audio.

    The only thing that works is disabling Direct Play in the Xbox Plex app, which frankly can only really be accepted as a temporary work-around until the root cause has been fixed.

  • yoghovyoghov Posts: 127Members, Plex Pass Plex Pass

    I'm having this issue on Mac mini, so it's not related to Xbox only.

  • jratcliffe123jratcliffe123 Posts: 1Members, Plex Pass Plex Pass

    @Moussa said:
    @thegeezer Thank you for your logs. Nothing particularly stands out to me there, so seems the issue might be with the file itself or the Xbox One decoder. Could you, or anyone else in this thread, perhaps send me a sample file that exhibits this issue? I have several h265 videos that playback fine post-Creator's Update.

    Happy to send you a file with this problem, how do I get it to you?

  • PummyPummy Posts: 6Members, Plex Pass Plex Pass

    Still no update on this?

  • MoussaMoussa Posts: 1,364Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    @jratcliffe123 or anyone else. Please feel free to send me a sample file that exhibits this issue. I haven't managed to reproduce the issue described yet with any of my test files or samples sent to me.

  • snpcrkpoprcsnpcrkpoprc Posts: 2Members

    Girl on a train encoded using dvd fab ... Can send a piece of the file just tell me how

  • snpcrkpoprcsnpcrkpoprc Posts: 2Members

    General
    Unique ID : 183951904682485502605124160514246819776 (0x8A63D920B822849285C38E25ACE3BFC0)
    Complete name : Z:\PLEX\MOVIES\THE GIRL ON THE TRAIN.mkv
    Format : Matroska
    Format version : Version 2
    File size : 4.13 GiB
    Duration : 1 h 52 min
    Overall bit rate : 5 279 kb/s
    Movie name : THE GIRL ON THE TRAIN
    Encoded date : UTC 2017-02-26 17:51:27
    Writing application : DVDFab 9.3.1.9
    Writing library : libebml v0.7.8 + libmatroska v0.8.1

    Video
    ID : 1
    Format : HEVC
    Format/Info : High Efficiency Video Coding
    Format profile : Main@L5@High
    Codec ID : V_MPEGH/ISO/HEVC
    Duration : 1 h 52 min
    Bit rate : 4 726 kb/s
    Width : 1 920 pixels
    Height : 1 036 pixels
    Display aspect ratio : 1.85:1
    Frame rate mode : Constant
    Frame rate : 23.976 (24000/1001) FPS
    Color space : YUV
    Chroma subsampling : 4:2:0
    Bit depth : 8 bits
    Bits/(Pixel*Frame) : 0.099
    Stream size : 3.70 GiB (90%)
    Default : Yes
    Forced : No

    Audio
    ID : 2
    Format : AC-3
    Format/Info : Audio Coding 3
    Mode extension : CM (complete main)
    Format settings, Endianness : Big
    Codec ID : A_AC3
    Duration : 1 h 52 min
    Bit rate mode : Constant
    Bit rate : 448 kb/s
    Channel(s) : 6 channels
    Channel positions : Front: L C R, Side: L R, LFE
    Sampling rate : 48.0 kHz
    Frame rate : 31.250 FPS (1536 spf)
    Compression mode : Lossy
    Stream size : 359 MiB (8%)
    Language : English
    Default : Yes
    Forced : No

    Menu
    00:00:00.000 : en:(01)00:00:00:000
    00:06:01.778 : en:(02)00:06:01:778
    00:09:29.902 : en:(03)00:09:29:902
    00:18:15.969 : en:(04)00:18:15:969
    00:25:26.149 : en:(05)00:25:26:149
    00:32:04.505 : en:(06)00:32:04:505
    00:37:04.972 : en:(07)00:37:04:972
    00:44:52.314 : en:(08)00:44:52:314
    00:49:22.459 : en:(09)00:49:22:459
    00:55:07.012 : en:(10)00:55:07:012
    00:59:36.030 : en:(11)00:59:36:030
    01:03:34.811 : en:(12)01:03:34:811
    01:09:25.786 : en:(13)01:09:25:786
    01:14:36.430 : en:(14)01:14:36:430
    01:19:08.702 : en:(15)01:19:08:702
    01:23:44.728 : en:(16)01:23:44:728
    01:28:07.490 : en:(17)01:28:07:490
    01:33:49.457 : en:(18)01:33:49:457
    01:38:54.553 : en:(19)01:38:54:553
    01:45:55.182 : en:(20)01:45:55:182
    01:52:04.759 : en:(21)01:52:04:759

«1
Sign In or Register to comment.