If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[Rasplex 1.8.0] TV input keeps switching back to Rasplex

TyrannisHawkTyrannisHawk Posts: 7Members ✭✭

I did a fresh install of Rasplex yesterday evening and since then, the TV (an LG) keeps switching back to the Rasplex HDMI channel from the Ziggo Horizon HDMI channel. It does so every 5-10 minutes, which is very annoying when we are watching TV. I've been running Rasplex on my Raspberry PI1 for 2 years (I never really switch it off and just keep it running) and never had this issue before. I've searched the forums but haven't found anyone with the same issue.

Is there a (new) setting causing this behavior or could it be a bug in the new version of Rasplex (I was running 1.6 before my fresh install)? Does anyone else have this issue or can someone poke me towards a cause or solution?

Best Answer

Answers

  • videotecaCNSUvideotecaCNSU Posts: 309Validating, Plex Pass Plex Pass

    Mmm, I dont know
    I made a power button for mine

    Is it crashing or restarting itself? Did you check the logs?

  • TyrannisHawkTyrannisHawk Posts: 7Members ✭✭

    That's the weird part. It switches after 5 or 10 minutes without the device rebooting or crashing. It's like it gets a signal through HDMI which triggers the TV to switch back to the Rasplex. I'll try to flash the SD card again and see if it persists. If it does, I'll try to check the logs.

  • ValdhorValdhor Posts: 502Members, Plex Pass Plex Pass

    Which device is set to the first HDMI port? It may be that the TV is auto switching depending on if there is a signal. ie. The Pi is set to HDMI 1 and the Ziggo to HDMI 2. If the TV thinks there is no signal on HDMI 2 for any reason then it auto switches to HDMI 1.

    There may be an issue with the TV or the Ziggo or a cable for that matter. Try swapping ports and see what happens.

  • videotecaCNSUvideotecaCNSU Posts: 309Validating, Plex Pass Plex Pass

    Or it could be that the pi goes to sleep, it wakes up for some reason and as the hdmi powers on again it goes back to that port

  • TyrannisHawkTyrannisHawk Posts: 7Members ✭✭

    The Pi is using its normal AC power connector.

    I will check the CEC adapter settings. Even with a brandnew 1.8.0 install, the issue persists. I will keep you posted.

  • TyrannisHawkTyrannisHawk Posts: 7Members ✭✭

    @Valdhor said:
    Which device is set to the first HDMI port? It may be that the TV is auto switching depending on if there is a signal. ie. The Pi is set to HDMI 1 and the Ziggo to HDMI 2. If the TV thinks there is no signal on HDMI 2 for any reason then it auto switches to HDMI 1.

    There may be an issue with the TV or the Ziggo or a cable for that matter. Try swapping ports and see what happens.

    I will try this as well, although I never had this issue with version 1.6.x.

  • TyrannisHawkTyrannisHawk Posts: 7Members ✭✭

    Dlanor's answer was the one that fixed the issue for me. I tinkered with the CEC settings a bit and set everything so HDMI / TV interaction is reduced to a minimum.
    I do still have the issue that when I switch the TV to the Plex HDMI channel, I see a popup giving me the choice between "quit" (reboot) and "shutdown". I've not had time to fix this, but it is definitely in the CEC settings as well.

    Sorry for the late response and everyone thanks for helping me troubleshoot and fix this.

Sign In or Register to comment.