If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Will not play any Transcoded material

izznogoooodizznogooood Posts: 34Members ✭✭

Ubuntu 16.04, plexconnect pulled git today, Plex latest (1,5x) atv3
After I updated my Plex server and Plexconnect today it will not play any movies that requires transcoding.

It starts paused and wont continue...

Plex seems slow and sluggish after I upgraded to 1,4... (Especially when transcoding both video and audio...) buffers alot.
I also experienced 120% cpu loads on i-7's... (which is ridiculous)
If this is because of 16.04's "old" packages, plex, or plexconnect I don't know.

I reverted back to a backup of Plex 1,2 with previous commit of Plexconnect. No problems... (Running containers are lifesavers!)

@baa: I dont know if you follow the forum, but thank you for this incredible piece of software. Made my life easier! Happy wife = Happy life!

Tagged:

Best Answer

Answers

  • kasholkashol Posts: 1Members

    I had the same problem. It has something to do with AC 5.1 playback that was "fixed" in the latest commit of PlexConnect. Either reverting to commit e9a37a9 or setting Dolby Digital to auto (from disabled) in ATV settings solved it for me.

  • RaszowskiRaszowski Posts: 7Members, Plex Pass Plex Pass

    Hello.
    I had the same problem, but after switching to ATV - Dolby Digital ON, all movies work but someone have no sound. Any solution ?
    My ATV is connect to Samsung TV through HDMI cable.

  • moody_bluemoody_blue Posts: 2,906Members, Plex Pass, Plex Ninja Plex Ninja

    @iQBTV Can you please post the medio info of such movies ? In xml format, please.

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • RaszowskiRaszowski Posts: 7Members, Plex Pass Plex Pass
    edited April 23

    I start of my hardware and software:
    Ubuntu 16.4 LTS
    PMS 1.5.5.3634
    Plexconnect 0.5-dev-110616
    ATV3 7.2.2(8015)
    TV Samsung LE40N71BX/XEH connect through HDMI cable

    Settings:
    ATV - Dolby Digital ON (when i turn off or auto, then only movies with stereo sounds working.
    AC5.1 permanent paused)

    Underworld.xml - working with sound
    Skyfall.xml - working without sound

    [PlexConnect] enable_plexgdm = True ip_pms = 192.168.0.88 port_pms = 32400 enable_dnsserver = True port_dnsserver = 53 ip_dnsmaster = 8.8.8.8 prevent_atv_update = True enable_plexconnect_autodetect = True ip_plexconnect = 192.168.0.88 hosttointercept = trailers.apple.com port_webserver = 80 enable_webserver_ssl = True port_ssl = 443 certfile = ./assets/certificates/trailers.pem allow_gzip_atv = False allow_gzip_pmslocal = False allow_gzip_pmsremote = True loglevel = Normal logpath = .

    Before last update everything work fine.

    p.s. Sorry for my bad english.

  • moody_bluemoody_blue Posts: 2,906Members, Plex Pass, Plex Ninja Plex Ninja
    edited April 23

    Thanks for the xml files. Can you please activate debug logging in PMS ? Then, when playing above films, you will have an entry in Plex Media Server.log like the following one:

    Apr 23, 2017 10:29:26.440 [0x7f1536fff700] DEBUG - Streaming Resource: Reached Decision id=7205 codes=(General=1001,Direct play not available; Conversion OK. Direct Play=3001,Not enough bandwidth for direct play of this item. Required bandwidth is 6145kbps and only 3000kbps is available. Transcode=1001,Direct play not available; Conversion OK.) media=(id=7533 part=(id=11693 decision=transcode container=mpegts protocol=hls streams=(Video=(id=9578 decision=transcode bitrate=2642 encoder=libx264 width=718 height=480) Audio=(id=9579 decision=transcode bitrate=203 encoder=aac channels=2 rate=48000))))

    You can search the PMS log using "reached" as the key.

    From your xml files (this is what I think, but I need this to be confirmed with the PMS log):

    1) Skyfall - Has one hevc video track, and one aac 5.1 channel audio track. PlexConnect detects that hevc is not supported by the ATV3 and asks PMS to transcode. Video is transcoded to H264, but audio, previous to this patch, was transcoded to AAC-stereo and now is transcoded to AC3 5.1, so if your TV does not "understands" AC3 5.1 you will have no sound from it
    2) Underworld - Has one h264 video track, and one ac3 2 channel audio track. PlexConnect detects that ATV3 supports this natively and asks PMS to DirectPlay the file. If you get sound from it is because your TV "understands" AC3 2 channel. If, instead of AC3-2ch the audio track was AC3-5.1 you would have no sound, even with the previous PlexConnect version, because PlexConnect would DirectPlay the entire file (video and audio)

    What I am planning to do is to create a new ATV parameter (in PlexConnect settings) so that, by default, users with AC3 audio tracks get them transcoded to AAC (as happened in the past), and users with Dolby Digital capable players (AC3 5.1) can use that functionality.

    Ideally I should pick the "ATV Setting" and not create a new "PlexConnect Setting", but the problem is that nobody (even Baa and roidy, the "parents" of PlexConnect) knows how to query the "Dolby Digital" status of the ATV.

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • RaszowskiRaszowski Posts: 7Members, Plex Pass Plex Pass
    edited April 23

    Btw on windows 10 everything work fine, also on iphone 5s.

    If possible, ATV can convert sound to 2CH stereo.
    I do not need DD on ATV.

    p.s.
    If the wine is on the side of the TV, is it possible to connect the ATV to the speakers by the following converter, the possibility is that the sound will appear?
    Speakers BOSE companion 5

    Http://www.ebay.com/itm/Digital-Optical-Coaxial-Toslink-Signal-to-Analog-Audio-Converter-Adapter-RCA-DAC-/301250190191?_ul=BR

  • moody_bluemoody_blue Posts: 2,906Members, Plex Pass, Plex Ninja Plex Ninja
    edited April 23

    @iQBTV said:
    Btw on windows 10 everything work fine, also on iphone 5s.

    Win10 and iPhone use different clients. Both request PMS to transcode audio to AAC (as PlexConnect used to be).

    If possible, ATV can convert sound to 2CH stereo.
    I do not need DD on ATV.

    I'm sure you don't need it, but some users need DD, so we need to implement a solution that pleases both.

    If the wine is on the side of the TV, is it possible to connect the ATV to the speakers by the following converter, the possibility is that the sound will appear?

    I can't be sure. I used one of these devices, it broke 18 months later, and I've never tried AC3 5.1 on it. Please wait for the next PlexConnect update, or return to a previous one instead of spending money on such devices.

    Thanks for your PMS log but it only shows skyfall. Can you please attach a new one that includes underworld ?

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • moody_bluemoody_blue Posts: 2,906Members, Plex Pass, Plex Ninja Plex Ninja

    @iQBTV Can you please install PlexConnect from here and test if your problem is solved ?

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • RaszowskiRaszowski Posts: 7Members, Plex Pass Plex Pass

    @moody_blue said:
    @iQBTV Can you please install PlexConnect from here and test if your problem is solved ?

    moody_blue
    Thank you very much for your help.
    Everything works great.

  • moody_bluemoody_blue Posts: 2,906Members, Plex Pass, Plex Ninja Plex Ninja
    edited April 23

    Great, thanks. I've asked another user to test (he has 2x ATV's, one with DD and another without), which is an "interesting" situation, if his tests are also positive I will try to apply my patch to the PlexConnect master.

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

  • RaszowskiRaszowski Posts: 7Members, Plex Pass Plex Pass

    I checked it for you.
    Several movies in each mode.
    .mkv .avi .mp4
    Result
    DD - ON - WORK
    DD - OFF - WORK
    DD-AUTO-WORK

    Once again thank you heartily.

  • moody_bluemoody_blue Posts: 2,906Members, Plex Pass, Plex Ninja Plex Ninja

    My fork has been merged with iBaa's. Thanks for your testing.

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

Sign In or Register to comment.