Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Rasplex automatically use srt files on client side when present option??

timae2003timae2003 Posts: 1Members

I have a seagate personal cloud that is not strong enough to transcode the srt on the server side but the raspberry pi 3 with rasplex on the client side will play them but I have to turn them on every time. I only use subtitles that are for non-english parts of my movies so I would like to know if there is an option for it to use the srt if present but cannot find anything like that in rasplex settings. Could there be another way of doing this? If not, could it be added in the next update please?

Answers

  • benjaminwolfbenjaminwolf Posts: 979Members, Plex Pass Plex Pass

    That setting is in PMS.

    Settings > Server > Languages

    Change Subtitle mode to "Shown with foreign audio" or "Always"

    Enjoy Rasplex/OpenPHT? Consider dropping some bones into our development war chest! $25, $10, $5, or even $1 helps. All donations go toward development expenses so our volunteers spend less out of pocket. rasplex.com

  • eckartheckarth Posts: 450Members, Plex Pass Plex Pass

    Isn't it a question of setting the "forced" bit associated with the subtitle stream in the media file?

    If I understand the OP right, he means those subtitles which e.g. translate a German speaking character in an otherwise English language movie. That is neither a 'foreign audio movie' (for a native English speaker) nor does he want subtitles for English spoken audio (i.e. 'Always').

  • edjonesyedjonesy Posts: 58Members ✭✭
    edited April 18

    If you have an .srt file that is for the non-english parts of the movie you force flex to use the .srt without transcoding it. if your movie is called 'moviename.mp4' make sure the corresponding .srt file is called 'moviename.en.forced.srt' and it will force the subtitles to be used.

    the '.en' flag is the language (en = English) and '.forced' forces the subtitles to be used.

    That is what I have read, I forget where, but I do use that naming convention on my setup and it works for me.

    Plex Server Version 0.9.16.4 | Mac Pro 1.1 | OS X10.7.5 | 13gb RAM | Gigabit Ethernet
    Raspberry Pi 2 Model B | RasPlex v1.8.0 | Edimax EW-7811UN 150Mbps Wireless N USB Adapter
    TP-LINK TD-W9980 Wireless router - 4-port gigabit switch

Sign In or Register to comment.