Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Bug - Incorrect track progress and time over bluetooth

ridentrident Posts: 10Members, Plex Pass Plex Pass

I have found a weird bug where, when I play tracks over bluetooth in a car, the progress bar, playback time, and track time get all messed up on the car's display. The track time will read as less than the playback time but not match the track itself. The playback time won't reset between tracks sometimes and won't match actual playback or limits of the track. The progress bar will start a track looking like it's almost played the whole thing or other times will jump back while the track is still playing.

Other apps I listen to in the car like Youtube, Soundcloud, or Google Play Music don't seem to have this issue.

It still displays the correct track info (artist, title, album, etc.) and the controls in the car still change tracks, play/pause, etc. Also, the playback data is correctly displayed on the phone while this bug is happening as well.

I've seen this issue on a Samsung S4 and Google Pixel when connected to a Mazda 3, Subaru Impreza and Peugeot 308 over bluetooth.

Any help would be appreciated!

Answers

  • igno2kigno2k Posts: 38Members, Plex Pass Plex Pass

    Same here on a Android device (Galaxy S7) and a new Volkswagen Passat. No problem with Spotify & Co via bluetooth. Problem stays after ugprade from Android 6 to Android 7.

    Very annoying - please help!

  • gconceptsgconcepts Posts: 2Members, Plex Pass Plex Pass

    Yeah this bug is quite annoying. Works fine with other audio apps like Google Play Music, Spotify, Apple Music e.t.c

  • ridentrident Posts: 10Members, Plex Pass Plex Pass

    @MovieFan.Plex, can you help push this bug along as well?

  • celgersmacelgersma Posts: 1Members, Plex Pass Plex Pass

    Also having the same issue, Nexus 6P ( Android 7.1.2 ) playing local synced audio content to 2015 Chevy Suburban factory radio and the Sony XAV-AX100 head unit on my car. Seems when skipping to the next song any time played on current song gets added to the play time of the next song which causes it to meet the next songs end time prematurely and skip it. Pressing play/pause key on phone or vehicle mid song seems to reset the counter on the vehicle and the rest of the song will play completely. Occasionally the player progress bar on the vehicle will not display at all.

  • ridentrident Posts: 10Members, Plex Pass Plex Pass

    This issue has been partially fixed. With linux server version 1.8.2.4209, android (oreo) client version 6.4.1.1644 I now see the correct total track time in a Mazda3. I do not see a playback time or the progress bar fill, yet I do consider the current state a major improvement over my original report for this issue!

    Thank you for working on this one Plex devs! I look forward to future improvements related to this issue and will report back as I see them.

Sign In or Register to comment.