Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Subtitles out of sync on Samsung TV

Hi,

This is a bug report.

I have been using Plex for about a year now on many different platforms, but within the last few weeks my Samsung TV (model UE50KU6075XXE - bought in January 2017) has displayed subtitles out of sync - sometimes up to 10-20 seconds off. This does not happen when watching the movie from the beginning; only when resuming a movie in a later session. Sometimes it fixes it (or at least gets better) if I toggle the subtitle language within the app or stop and the start the movie again. Note that when I do this on other platforms (e.g. Android or Chromecast) the subtitles work fine and are in perfect sync. Note also that I have only tried this with external .srt files - it may also occur of internal subtitles but I have not tried that.

It seems that the out-of-sync offset is related to the time it takes to start the movie. So if the server is slow to react the out-of-sync offset is bigger.

I am running latest server on my QNAP NAS (1.5.5.3634) and the TV auto updates to latest version of the client.

Please let me know if you need any other information or let me know if there is anything I can do.

Thank you.

«1

Answers

  • gkkovacsgkkovacs Members Posts: 4

    I have the exact same problem. I am running the Tizen Plex app on my Samsung Smart TV, with a Plex Media Server running on Windows providing the media (I keep it updated). Since last week subtitles started to show about 5 seconds earlier. Stopping the movie and restarting the server sometimes fixes the problem, but if I seek in the player, the subtitles quickly become out of sync again.

    Plex app version: 3.0.11 (3.1.0)
    Tizen version: 2.4.0
    Plex Media Server version: Version 1.5.5.3634 (Windows 7)

  • softeristsofterist Members Posts: 15 ✭✭

    Same problem here!
    First I though it's a problem with my subtitle file, but on other devices subtitle work perfectly.
    Only on my Samsung TV (KS9000 - 2016 model) the subtitle it's ahead of video.

    I hope you guys (from Plex or Samsung) will fix this soon. I'm using Plex every night, and I don't know how I'll watch my movies without this fixed.

    P.S. The Plex App on Tizen 2.4.0 is poor and you cannot sync manually subtitles, and this is really annoying, I hope this will be implemented too in the near.

  • Timotheus123Timotheus123 Members Posts: 4 ✭✭

    Experiencing the exact same problems! (KS8000)

  • jacobmarnerjacobmarner Members, Plex Pass Posts: 6 Plex Pass

    Still a problem. The workaround I am using is basically to use a Chrome cast on my tv instead of using the tv app. Not ideal.

  • washington23washington23 Members, Plex Pass Posts: 13 Plex Pass

    @Timotheus123 said:
    Experiencing the exact same problems! (KS8000)

    Same tv, same issue. Very frustrating.

  • dobo.laszloudobo.laszlou Members, Plex Pass Posts: 6 Plex Pass

    Same issue here. I have a Samsung UE49KU6400SXXH TV. Can confirm: very very frustrating. Last night I was really close to punch a hole in my brand new TV. If I start from the beginning it's all good, but If I fast-forward or resume, the subtitle is way off. I can't delay the subtitle because that feature does not exists...yet...in 2017. So I can't do anything.

    /off
    I am starting to lose hope in Plex. Every update is worse (for us). We are experiencing a lot of issues. I don't know what you guys are doing. The UX is very bad. You created several different clients and UI's for one thing. I would love to use the same (ugly, simple, basic) interface on all devices but have working basic features. Can't care less for the eye-candy. Maybe If you eliminated the playback issues you can do some UI polising. Maybe. I'm with you guys from the beginning but you're losing me. I tried almost every client of yours and all of them had very big issues. Before every viewing session I have to spend 10-30 minutes to fix something. One day my wife will kill me as I restart, unplug, reinstall, update, download, configure, etc. You should know that I won't include you guys in my will. Just sayin... I know, I know: "Please provide logs, report the issue for every version of every client to the correct thread bla bla bla'. You know what? Ain't nobody got time for that. I would like to watch my daily fix of content and that's all. I'm a full-time software engineer and I'm doing that all day. The "living room experience" is not about that. I was very patient. I calmed my family for years: it's okay, just 10 more minutes, they'll figure it out for the next release, etc. etc. I can't do that any more... Ofc I know you could't care less.
    /on

    Have a nice day!

  • softeristsofterist Members Posts: 15 ✭✭

    @dobo.laszlou said:
    Same issue here. I have a Samsung UE49KU6400SXXH TV. Can confirm: very very frustrating. Last night I was really close to punch a hole in my brand new TV. If I start from the beginning it's all good, but If I fast-forward or resume, the subtitle is way off. I can't delay the subtitle because that feature does not exists...yet...in 2017. So I can't do anything.

    /off
    I am starting to lose hope in Plex. Every update is worse (for us). We are experiencing a lot of issues. I don't know what you guys are doing. The UX is very bad. You created several different clients and UI's for one thing. I would love to use the same (ugly, simple, basic) interface on all devices but have working basic features. Can't care less for the eye-candy. Maybe If you eliminated the playback issues you can do some UI polising. Maybe. I'm with you guys from the beginning but you're losing me. I tried almost every client of yours and all of them had very big issues. Before every viewing session I have to spend 10-30 minutes to fix something. One day my wife will kill me as I restart, unplug, reinstall, update, download, configure, etc. You should know that I won't include you guys in my will. Just sayin... I know, I know: "Please provide logs, report the issue for every version of every client to the correct thread bla bla bla'. You know what? Ain't nobody got time for that. I would like to watch my daily fix of content and that's all. I'm a full-time software engineer and I'm doing that all day. The "living room experience" is not about that. I was very patient. I calmed my family for years: it's okay, just 10 more minutes, they'll figure it out for the next release, etc. etc. I can't do that any more... Ofc I know you could't care less.
    /on

    Have a nice day!

    U're a little dramatic.
    I'm sure in one or two months PLEX engineers will resolve this! They are the best for this.
    PLEX is a great product.
    I've stopped watching movies since last update, so, I'll wait for the update.

    Anyway, I'm a movie consumer, and I really hope you will find the right way to watch movies in future even you don't use PLEX anymore.

    Best Regards,
    -Claudius

  • gkkovacsgkkovacs Members Posts: 4

    Since the Tizen app hasn't been updated for a long time, the culprit must be in Plex Server, so I encourage all of you who experience the same issue to post to the Plex Server BUGREPORT thread as well:
    https://forums.plex.tv/discussion/268141

    I can only hope that if we make enough noise, the devs will notice.

  • mattseeleymattseeley HawaiiMembers, Plex Employee, Plex Pass, Plex Ninja Posts: 1,322 Plex Employee

    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

  • softeristsofterist Members Posts: 15 ✭✭

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Well, hello there mattseeley, do we have an ETA for the new version? :hushed:

  • jacobmarnerjacobmarner Members, Plex Pass Posts: 6 Plex Pass

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Good news! We are looking forward to a fix.

  • dobo.laszloudobo.laszlou Members, Plex Pass Posts: 6 Plex Pass

    @softerist said:

    @dobo.laszlou said:
    Same issue here. I have a Samsung UE49KU6400SXXH TV. Can confirm: very very frustrating. Last night I was really close to punch a hole in my brand new TV. If I start from the beginning it's all good, but If I fast-forward or resume, the subtitle is way off. I can't delay the subtitle because that feature does not exists...yet...in 2017. So I can't do anything.

    /off
    I am starting to lose hope in Plex. Every update is worse (for us). We are experiencing a lot of issues. I don't know what you guys are doing. The UX is very bad. You created several different clients and UI's for one thing. I would love to use the same (ugly, simple, basic) interface on all devices but have working basic features. Can't care less for the eye-candy. Maybe If you eliminated the playback issues you can do some UI polising. Maybe. I'm with you guys from the beginning but you're losing me. I tried almost every client of yours and all of them had very big issues. Before every viewing session I have to spend 10-30 minutes to fix something. One day my wife will kill me as I restart, unplug, reinstall, update, download, configure, etc. You should know that I won't include you guys in my will. Just sayin... I know, I know: "Please provide logs, report the issue for every version of every client to the correct thread bla bla bla'. You know what? Ain't nobody got time for that. I would like to watch my daily fix of content and that's all. I'm a full-time software engineer and I'm doing that all day. The "living room experience" is not about that. I was very patient. I calmed my family for years: it's okay, just 10 more minutes, they'll figure it out for the next release, etc. etc. I can't do that any more... Ofc I know you could't care less.
    /on

    Have a nice day!

    U're a little dramatic.
    I'm sure in one or two months PLEX engineers will resolve this! They are the best for this.
    PLEX is a great product.
    I've stopped watching movies since last update, so, I'll wait for the update.

    Anyway, I'm a movie consumer, and I really hope you will find the right way to watch movies in future even you don't use PLEX anymore.

    Best Regards,
    -Claudius

    U're a little dramatic.

    I don't think so. I'm not dramatic, I'm just really frustrated. I think they should work on the important things. I'd like to indicate that I'm using Plex, but not without problems.

    I'm sure in one or two months PLEX engineers will resolve this! They are the best for this.

    Maaan, I don't know what are you talking about... In what world is it normal to fix something in one or two months? What should I do while they spend their time fixing this bug? Not using Plex? I gave them years! I payed money for their services to finally release a decent product.

    I used Plex on my laptop, on my desktop, on my rp1, rpi2, pri3 and now on kodi and tizen. I can't remember one occurrence when I sat down, started the Plex app and watched something without a single problem. I couldn't find a device suited for the job.

    I love Plex, that's why I'm here. I don't like the current version, but the concept.

  • dobo.laszloudobo.laszlou Members, Plex Pass Posts: 6 Plex Pass

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Great. Could you or the QA team look into the issue with the whole app? Every operation takes ages to execute. If I start a movie the loading bar is there for like half a minute. If I fast forward, half a minute. Sometimes the whole app is frozen, the playback stops and then there is a "meaningful" error message: "Playback error" or something.

    Maybe that's a media server issue, I can't tell. I'm experiencing this issue using all sorts of clients.

  • Timotheus123Timotheus123 Members Posts: 4 ✭✭

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Is there a workaround we can use, maybe rollback to a previous version?

  • softeristsofterist Members Posts: 15 ✭✭

    @Timotheus123 said:

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Is there a workaround we can use, maybe rollback to a previous version?

    I agree with you, they sould let us rollback or something, or put the old version to the update, cause we don't have a rollback action button.

  • Timotheus123Timotheus123 Members Posts: 4 ✭✭

    @softerist said:

    @Timotheus123 said:

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Is there a workaround we can use, maybe rollback to a previous version?

    I agree with you, they sould let us rollback or something, or put the old version to the update, cause we don't have a rollback action button.

    I found a link where you can download previous versions. Like you said, you have uninstall your current version and reinstall an older version.

    http://www.filehorse.com/download-plex-media-server/old-versions/

    I will try it myself this coming weekend. I'll keep you posted. Cheers.

  • softeristsofterist Members Posts: 15 ✭✭

    @Timotheus123 said:

    @softerist said:

    @Timotheus123 said:

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Is there a workaround we can use, maybe rollback to a previous version?

    I agree with you, they sould let us rollback or something, or put the old version to the update, cause we don't have a rollback action button.

    I found a link where you can download previous versions. Like you said, you have uninstall your current version and reinstall an older version.

    http://www.filehorse.com/download-plex-media-server/old-versions/

    I will try it myself this coming weekend. I'll keep you posted. Cheers.

    Lol Timotheus123, this isn't about the Server.
    This is about the Player. PLEX PLAYER, on TIZEN.
    Get your facts straight.

  • Timotheus123Timotheus123 Members Posts: 4 ✭✭

    @softerist said:

    @Timotheus123 said:

    @softerist said:

    @Timotheus123 said:

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Is there a workaround we can use, maybe rollback to a previous version?

    I agree with you, they sould let us rollback or something, or put the old version to the update, cause we don't have a rollback action button.

    I found a link where you can download previous versions. Like you said, you have uninstall your current version and reinstall an older version.

    http://www.filehorse.com/download-plex-media-server/old-versions/

    I will try it myself this coming weekend. I'll keep you posted. Cheers.

    Lol Timotheus123, this isn't about the Server.
    This is about the Player. PLEX PLAYER, on TIZEN.
    Get your facts straight.

    What makes you so sure!? The Tizen version hasn't been updated for years so it seems logical (to me) the problem is on the server side..

  • gabrielragabrielra Members Posts: 47 ✭✭

    @Timotheus123 said:
    What makes you so sure!? The Tizen version hasn't been updated for years so it seems logical (to me) the problem is on the server side..

    TiZen version has been updated two weeks ago...

  • softeristsofterist Members Posts: 15 ✭✭
    edited April 27

    @Timotheus123 said:

    @softerist said:

    @Timotheus123 said:

    @softerist said:

    @Timotheus123 said:

    @mattseeley said:
    We've heard you. :)

    Our current Samsung release, in QA testing, also turned up some subtitle sync issues after seeking. Seeking and resuming sometimes tickle similar playback bugs. Looking into it.

    Is there a workaround we can use, maybe rollback to a previous version?

    I agree with you, they sould let us rollback or something, or put the old version to the update, cause we don't have a rollback action button.

    I found a link where you can download previous versions. Like you said, you have uninstall your current version and reinstall an older version.

    http://www.filehorse.com/download-plex-media-server/old-versions/

    I will try it myself this coming weekend. I'll keep you posted. Cheers.

    Lol Timotheus123, this isn't about the Server.
    This is about the Player. PLEX PLAYER, on TIZEN.
    Get your facts straight.

    What makes you so sure!? The Tizen version hasn't been updated for years so it seems logical (to me) the problem is on the server side..

    Just the simple fact that subtitles are synced on other platforms where PLEX players runs, but on TIZEN platform the player works bad at sync, gives us the answer where the problem is.

«1
Sign In or Register to comment.