Our forum migration to Discourse is underway and scheduled to last through June 21. During the migration, the forums will be read-only, except for a single temporary forum (contents of which will not be getting transferred). Read our announcement post for more information about the forum migration.
Hey folks, there is a new Podcast category for forums https://forums.plex.tv/categories/podcasts
If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server service stops every morning

SHEW9664@hotmail.comSHEW9664@hotmail.com Members, Plex Pass Posts: 2 Plex Pass

PMS service stops every morning around the same time. This has never happened until I updated the server version (Version 1.5.5.3634). Every setting is the same from previous version and I even completely uninstalled it before the update. The server only crashes in the morning. No network/PC issues. Windows 7. Any suggestions? Thanks.

Answers

  • astrofisherastrofisher Plex Dwarf Star Members, Plex Pass Posts: 5,514 Plex Pass

    Is it crashing during "Scheduled Server Maintenance"?

    You should probably grab the logs after the crash and attach to your next post.

    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    Jim

    "I never had any friends later on like the ones I had when I was twelve. Jesus, does anyone?"
    Rule #32 "Enjoy the little things"
  • SHEW9664@hotmail.comSHEW9664@hotmail.com Members, Plex Pass Posts: 2 Plex Pass

    That's very possible. I believe my schedule is set from 2am-5am. I will post the logs. Do you have any recommendations on what I should disable or keep enabled within the scheduled tasks? In 5 years, I've never had this problem. Thank you for the help.

  • ecatapanoecatapano Members, Plex Pass Posts: 4 Plex Pass

    I am also having a similar problem for a few months now and thought it would have been correct with the last release. My service is stopping randomly not any given time... Attached are my log files

  • jswantekjswantek Members, Plex Pass Posts: 18 Plex Pass

    I am having this same issue. My PMS randomly stops running and I usually don't realize it until I attempt to watch a Show/Movie or realize that that recording didn't occur cause the PMS crashed before or during the recording.

    Windows 10 Pro (version 1709 | OS build 16299.248)
    PMS version: 1.12.0.4829

    Attached are two sets of logs that I copied form the Logs folder after PMS crashed but before I restarted it.

  • ecatapanoecatapano Members, Plex Pass Posts: 4 Plex Pass
    edited March 15

    @ecatapano@gmail.com said:
    I am also having a similar problem for a few months now and thought it would have been correct with the last release. My service is stopping randomly not any given time... Attached are my log files

  • jswantekjswantek Members, Plex Pass Posts: 18 Plex Pass

    Anyone seen this issue lately? I am running the latest PMS (version: 1.12.1.4885) and have not seen this issue lately but am interested to hear other people's experiences.

  • jswantekjswantek Members, Plex Pass Posts: 18 Plex Pass

    I have noticed that I haven't had any issues since disabling the "Use hardware acceleration when available" option in the "Transcoder" PMS setting. I wonder if this is related? I will turn it back on shortly and see if this causes the crashes to return.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @ecatapano said:
    I am also having a similar problem for a few months now and thought it would have been correct with the last release. My service is stopping randomly not any given time... Attached are my log files

    Sorry for not seeing your logs earlier

    They show memory allocation errors

    Mar 03, 2018 05:55:26.370 [8716] ERROR - Format [JPEG] - DIB allocation failed, maybe caused by an invalid image size or by a lack of memory
    

    and

    Mar 03, 2018 07:17:02.584 [11208] ERROR - Format [JPEG] - Insufficient memory (case 4)
    

    and eventually to errors like this which would end up with a crash after

    Mar 03, 2018 07:18:07.834 [5468] ERROR - Thread: Couldn't add a new thread to the pool of size 0: boost::thread_resource_error: An attempt was made to load a program with an incorrect format
    

    A memory leak was identified following extensive investigations for this forum topic http://forums.plex.tv/discussion/310320/pms-crashing-version-1-11-3-4803-windows-7

    A fix will be released in a future version of Plex Media Server. I believe it missed the cut-off date for 1.12.2 so I would expect it after that

    If this is happening very frequently, I can make a special pre-release build available to you

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 31,470 Plex Team Member

    @jswantek said:
    I am having this same issue. My PMS randomly stops running and I usually don't realize it until I attempt to watch a Show/Movie or realize that that recording didn't occur cause the PMS crashed before or during the recording.

    Windows 10 Pro (version 1709 | OS build 16299.248)
    PMS version: 1.12.0.4829

    Attached are two sets of logs that I copied form the Logs folder after PMS crashed but before I restarted it.

    @jswantek said:
    Anyone seen this issue lately? I am running the latest PMS (version: 1.12.1.4885) and have not seen this issue lately but am interested to hear other people's experiences.

    @jswantek said:
    I have noticed that I haven't had any issues since disabling the "Use hardware acceleration when available" option in the "Transcoder" PMS setting. I wonder if this is related? I will turn it back on shortly and see if this causes the crashes to return.

    I have not been able to find any crash reports for your server / account after 15th January 2018

    When capturing logs manually please note down the time you do that - this is important to identify a real hang/crash. For example for 3rd march, the logs were being written to up to 20:00.
    To identify crash reports, one would need logs captured after the restart to see what the Crash Uploader log files contain. But they probably would not have helped here, as I did search by plex.tv account and there was only the 15 January 2018 crash report

    suggest waiting for next crash

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    Please do not send logs by Private Message unless specifically requested to
     
Sign In or Register to comment.