If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[Issue] Metadata failing to load for some items, but not all.

SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass
edited May 6 in Windows

I've recently starting having an issue where some movies and TV shows will not load the proper metadata. It's not everything, just a few at random it seems, but it also seems to have started happening more frequently. For TV shows it seems to recognize nothing, it just keeps "Episode X" and the auto generated thumbnail, It seems like no matter what I do it won't load. For movies it will sometimes think that it has matched, but only load the poster and nothing else. In the case of movies, sometimes doing "Fix Incorrect Match" and just re-selecting the same Plex Movie result will fix it, other times that does not work but switching to TheMovieDB result fixes it.

I feel like I've tried everything, so here's a brief rundown:

I'm running the latest PMS version, 1.5.5.3634
All of my files are named properly for PMS naming conventions.
I've tried updating/refreshing the items numerous times, including removing them from the library, optimizing the database, cleaning bundles, emptying trash, then putting them back, but it still doesn't recognize them then.
I've verified that IPv6 is disabled on my router and on PMS.
I've followed the instructions to repair a corrupted database with SQlite3.

And despite all that, the issue has not changed at all. I've tried looking at the logs, but I can't make heads or tails of all that information. If anyone can please give me a suggestion I haven't tried, or tell me which part of the logs I should be looking at, it would be greatly appreciated. Thanks.

UPDATE: I hadn't thought of it before, but for the first time since this issue started I tried adding a whole new series (44 episodes, 3 seasons) all at once. It correctly loaded the metadata for the series, but selectively skipped episodes at random. It missed 1 of the 8 season one episodes, 1 of the 13 season 2 episodes, and 5 of the 22 season 3 episodes. It also failed to load ANY of the images for the series.

I'm kind of OCD so this issue is proving extremely stressful for me. I've put a lot of effort into organized my library and making sure that everything has images (even if I have to make them myself). With all the movies & TV show episodes I have there are literally tens of thousands of files here, so I really don't want to have to wipe out the library files and load everything in from scratch again, but I'll try that if that's what it comes to. If anyone has any other suggestions for me to try other than the nuclear option I will gladly try them...

UPDATE 2: I've attached the .zip file of my logs as requested. Please help.

EDIT: Removing Logs for privacy reasons now that the issue is solved.

Best Answers

Answers

  • cayarscayars Posts: 4,217Members, Plex Pass, Plex Ninja Plex Ninja

    Lets do this. Pick something that isn't scanning correct and make sure the file names follow the correct naming format which you will find here:
    https://support.plex.tv/hc/en-us/articles/200381023-Naming-Movie-files
    https://support.plex.tv/hc/en-us/articles/200220687-Naming-Series-Season-Based-TV-Shows

    Once they are using the correct naming convention try a MATCH or FIX MATCH on the item noting the time of day. Wait 1 minute after the match is done and get the log zip file and upload it here along with the time you tried to match the item. Also let us know the movie/show that isn't matching correct.

    This information will help us to find the information in the log files.
    Carlo

    10K+ Movies, 400 Shows - 33K+ TV Episodes, 400 Christmas Movies, 405 Documentary, 290 3D Movies, 1300 NFL Games, 1280 Educational Videos, Premium Music: 215K+ Tracks, 775 GB Plex Meta-Data.
    Thread on my setup with some tips and tricks: https://forums.plex.tv/discussion/131308/cayars-setup-walk-through-and-some-tips-and-tricks/p1
  • JuiceWSAJuiceWSA Posts: 6,769Members ✭✭✭✭✭
    edited April 26

    Of Interest: http://thetvdb.com - TVDB
    Of particular interest: http://thetvdb.com/?tab=series&id=286272&lid=7 - Lucha Underground

    @cayars offers some good info, but I'll cut right to a severed artery (one of many):

    I:\PLEX 1\Plex TV - Wrestling A-L\
    ..........Lucha Underground (2014-\
    .............S02 - Season 2 (2016)\
    ...............Lucha Underground - S02E02.mp4

    I'm going to say the same thing Plex and TVDB are saying: What in the name of Sweet Baby Lucha is that?!
    Having trouble with metadata? I'm not surprised!

    A TV Show Library/
    ........Lucha Underground/
    ..........Season 02/
    .............Lucha Underground - S02E02.mp4

    Produces an instant and fully populated:

    @cayars can resume the regularly scheduled program already in progress...

    :)

    Tony

    FileBot For Easy Plex File Naming: http://www.filebot.net/

    Automated Plex Naming With Filebot: https://forums.plex.tv/discussion/191687/plex-naming-schemes-for-filebot

    Plex Friendly Handbrake Guide - DVDs/BluRays: https://forums.plex.tv/discussion/comment/1335697/#Comment_1335697

    Plex Clients: AFTVs, Androids, PMP, Rokus (running RARflix: http://mkvxstream.blogspot.com/2014/09/roku-plex-setup-guide.html ) Link May Work - May Not

  • cayarscayars Posts: 4,217Members, Plex Pass, Plex Ninja Plex Ninja

    Don't need to now. @JuiceWSA just covered it extremely well LOL

    10K+ Movies, 400 Shows - 33K+ TV Episodes, 400 Christmas Movies, 405 Documentary, 290 3D Movies, 1300 NFL Games, 1280 Educational Videos, Premium Music: 215K+ Tracks, 775 GB Plex Meta-Data.
    Thread on my setup with some tips and tricks: https://forums.plex.tv/discussion/131308/cayars-setup-walk-through-and-some-tips-and-tricks/p1
  • SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass
    edited May 6

    I was under the impression that the most important part was the file name, which is correct. I've never had an issue with my folder hierarchy in the past 2+ years that I've been using Plex. This issue only presented itself in the past couple weeks, with the only change I can see being updates to PMS itself. Also, Lucha Underground is not one of the problem files. That all has the proper data with no issues under my file system. As I mentioned before, I have 20,000+ items in my library, so going back to redo the entire file structure would take forever, so hopefully that isn't the problem.

    I've tried what @cayars advised, and the log is attached. The series I tried it with is "The Mick", which had not loaded the info for the latest episode, 16. I started the "Fix Match" scan at approximately 18:29. Oddly, doing this not only did not get the data for ep. 16, it also wiped out the existing data for the other 15 episodes, but kept the show overview and poster. I also noticed when looking for a problem file that the show I had been experimenting with yesterday now miraculously has the metadata on it, apparently having matched at some point during the night on it's own.

    I'm not saying that you're wrong about the file system... But for the sake of my time and sanity I really hope you are.

    Thanks.

  • JuiceWSAJuiceWSA Posts: 6,769Members ✭✭✭✭✭
    edited April 26

    Ok, well here's the deal. 'The Mick' doesn't exist in ANY of your scanner logs. What I do see in your scanner logs are endless searches through one horribly named and structured item after another. Non-Compliance has finally and basically turned your Plexiverse into a smoldering wreck.

    My Plexiverse is populated by Compliant files and structures. When I add something new it is instantly found and indexed and fully populated - in seconds. I don't have to 'Fix Match'. FileBot has already been to the database and gotten the correct name to match against. FileBot can also do your structures, but I do those myself - it's fun, Man! I can start a full libraries update and it's over in 40 seconds. Scheduled deep analysis takes a few minutes each day then Plex is twiddling it's thumbs with it's feet up on a desk. I can optimize the database for my entire Plexiverse in 15 seconds. My database in on a local HDD drive - not buried in the OS on my SSD drive.

    I know this isn't what you or anyone else holding on to non-compliance like their lives depended on it wants to hear, but it's time to start over and start doing it right.

    FileBot can conceivably get this done in a day (or three), but it's not going to happen without some labor and time and a certain amount of dedication to this process. What you get out of Plex ultimately relies on what you put into it. Once you comply and continue to do so - things get a whole lot easier.

    Tony

    FileBot For Easy Plex File Naming: http://www.filebot.net/

    Automated Plex Naming With Filebot: https://forums.plex.tv/discussion/191687/plex-naming-schemes-for-filebot

    Plex Friendly Handbrake Guide - DVDs/BluRays: https://forums.plex.tv/discussion/comment/1335697/#Comment_1335697

    Plex Clients: AFTVs, Androids, PMP, Rokus (running RARflix: http://mkvxstream.blogspot.com/2014/09/roku-plex-setup-guide.html ) Link May Work - May Not

  • SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass

    OK... So if I were going to re-do the file system, can I just verify what the right way would be? I've looked at the guidelines page, but it's not entirely clear on one thing, which I apparently misunderstood to begin with. I want to have things separated some. Multiple movie libraries, multiple TV libraries. If I wanted to do this my main question is the top level folder. I see your example:

    A TV Show Library/
    ........Lucha Underground/
    ..........Season 02/
    .............Lucha Underground - S02E02.mp4

    So if I want to have, say, a TV library, a Wrestling library, etc. what would the requirement be for the top folder that you have named "A TV Show Library"?

  • SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass
    edited May 17

    Hello again, I have an update, and still a problem.

    I hadn't been able to try playing with Plex for a little while because an issue came up with my PC that required doing a full re-install of Windows 10. All my media was on external drives, so it's fine, but my Plex library info was in the default location on the C: drive, so it was lost and I have to rebuild my library from scratch again. (I've redirected Plex to keep all local files on external now so hopefully my library will survive any future issues).

    I took this opportunity to go through and rework my file structure to match what you said, but now upon trying to add my media back into Plex I'm still having the same issues. Seeing as this is a completely clean Windows & Plex Media Server install, meaning that as far as Plex is concerned I'm setting up my library for the first time, this makes no sense.

    As before, the issue is as follow:

    For TV shows, when I add a series it will randomly decide not to download metadata for some episodes. Sometimes if I remove the file, refresh the library, then put it back to be identified again it will work, sometimes it does not. Either way, this is a huge hassle if I'm going to have to verify that every single episode is loaded correctly as I'm adding them.

    For movies, it will sometimes say that it matched (on Plex Movie search), but it will only download the title and/or a low res poster, and no other data. Sometimes if I go into fix match and re-select the exact same item it thinks it matched, it will update correctly. Other times that does not work and I have to switch agents to TheMovieDB for it to update. Again, having to take time to match and re-match each movie is very annoying.

    I'm attaching a new log file. I tried to update my media at about 10:38 PM, and the file giving me an issue this time is the series 'My Hero Academia', season 2, episode 4. This is one that I have tried removing and re-adding, and had give me a problem more than once.

    Sorry for coming back again, but I'm just confused by what this issue could possibly be. I'm not sure how it could be anything on my end, since it's a completely fresh install of everything, but it seems like more people would be complaining if the issue was on Plex's end, so I just have no clue what is going on.

    Thanks.

    EDIT: Also, I just thought about it, when searching for metadata it can take an oddly long time sometimes, when you made it sound like it should be fairly quick. Is this normal? I don't even have that much on here right now. I've only put back like 3 TV series and 30 or so movies so far.

    Also also, one thought I had that could be a problem, I guess, is that I am using a VPN. Would that cause an issue possibly? I have port forwarding and everything set up, and I'm able to access my library from outside my network with no problem, so I'd think it should be fine, but is it? I feel like I'm just grasping at straws now.

  • astrofisherastrofisher Plex Dwarf Star Posts: 5,514Members, Plex Pass Plex Pass

    (I've redirected Plex to keep all local files on external now so hopefully my library will survive any future issues).

    Caution advised here. Do not put your database and local app data on a network share, a drive using ReFS, or any type of drive pool.

    I do keep my Plex database and associated files on a non-os drive. It's an internal SSD.

    Jim

    "I never had any friends later on like the ones I had when I was twelve. Jesus, does anyone?"
    Rule #32 "Enjoy the little things"
  • SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass

    @astrofisher said:

    Caution advised here. Do not put your database and local app data on a network share, a drive using ReFS, or any type of drive pool.

    I think I'm fine there. Currently my only internal drive is my OS drive (I had a second, but it just died). I moved the files to a locally connected USB external hard drive that I always have connected. That's also where my media is.

    Side question: Is there anyway to change this post so that it doesn't say "answered" on it? I'm concerned that no one is going to look at this post again now that it's marked answered, but since I jumped the gun on that and it's actually not solved... Yeah. So is there a way to un-accept an answer, or would I need to create a new post? Also if I create a new post would it get locked for cross posting?

  • SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass

    Not sure why it would say no such file or directory, those paths are correct and have never changed. Regardless, I tried clearing the cache (just went ahead and cleared all the agents to be safe) and upon refreshing my library it seems to have pulled data correctly for everything, including the ones it previously did not. Hopefully this means that fixed it, though I can't imagine how the problem carried over through a full OS re-install... But anyway, for now it seems to be good and if it starts acting up again I can try clearing the cache again I suppose.

    As for the permissions issue, dunno what that would be about. I marked PMS to run as an admin so that it will hopefully have full permissions in the future, though I did this after clearing the cache, so it may not have been a part of the problem at all.

    So, for now it seems like I'm in the clear. I'll continue adding stuff back into my library and see if any new problems occur. Thanks!

  • kegobeer-plexkegobeer-plex Posts: 5,324Members, Plex Pass, Plex Ninja Plex Ninja

    @SeiryuX said:
    As for the permissions issue, dunno what that would be about. I marked PMS to run as an admin so that it will hopefully have full permissions in the future, though I did this after clearing the cache, so it may not have been a part of the problem at all.

    Running as admin means a completely different user when it comes to Plex. I know - I made the mistake of running my Plex Server using "run as admin" and it wasn't a pretty sight. Go ahead and stop the Plex server and then run it normally...I wager your errors will come back.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • SeiryuXSeiryuX Posts: 9Members, Plex Pass Plex Pass

    OK, so I went back and removed the "run as admin" from PMS, don't know if it was doing anything or not anyway.

    Now I seem to be having the same problem again. I guess either clearing the cache was only a temporary fix or it was a fluke that it looked like that worked.

    Since things seemed to be going smoothly I decided to test the server by adding a series with over 500 episodes all at once. It didn't work. Most of the episodes got their data, but many did not, and none of the series or season images downloaded. I tried clearing the cache again, but no change. Then I tried just adding the first season of the show (16 episodes) and it seemed to work a little better. It got the data for all the episodes, but it still refuses to download any series or season images.

    I took a look in my logs and found this:

    2017-05-19 00:52:37,335 (2258) : INFO (logkit:16) - Problem with the request: 'NoneType' object has no attribute 'get'
    2017-05-19 00:52:37,335 (2258) : INFO (logkit:16) - Bad image type data for TVDB id: [Series ID #]
    2017-05-19 00:52:37,338 (2258) : DEBUG (threadkit:234) - Starting a parallel task set named DownloadImages with 0 tasks
    2017-05-19 00:52:37,338 (2258) : DEBUG (threadkit:244) - Parallel task set DownloadImages ended

    I guess it's hitting some kind of error when it tries to get images? Anyone have a clue what this could be?

Sign In or Register to comment.