Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex not seeing all folders on NAS

oaklandoakland Posts: 4Members ✭✭
edited April 29 in NVIDIA SHIELD

Hi, this happened twice now. My Nvidia Shield has stopped seeing some of the folders on my nas. I have 8 folders on there including movies, pictures and music. When I try to add a folder they are not there but I can see them and access them from my PC.

Searched high and low and cant find an answer. Help please!

Thanks

Comments

  • jordighjordigh Posts: 15Members, Plex Pass Plex Pass

    Hi,
    How many files do you have in your movies folder? There seems to be a limitation in the Nvidia SMB implementation where PMS is unable to list all the contents of a folder directory if it contains more than a certain number of entries, I think it is something around 83.
    Check this post:
    http://forums.plex.tv/discussion/223458/cant-add-more-than-487-movies-to-my-library/p1

  • slimshiznslimshizn Posts: 31Members, Plex Pass Plex Pass

    Jordigh I am also having this issue. The support page is detailed but this is not one of the things they tell how to fix. I have two different mounted drives on my shield, one is a WD Mycloud the other is a Qnap 251A. Shield can view all of the folders on both devices. Very interesting thing though, you can see that the shield shows 0 bytes for each folder on the Qnap. The WD however works perfectly fine. Going to try to add a library in the plex web app the Qnap shows no folders at all. Any indication or do I need to provide more information?

  • jordighjordigh Posts: 15Members, Plex Pass Plex Pass

    If you're seeing 0 bytes on a given folder even though it contains data it's probably because the user you mounted the drive has no rights to see the contents of the folder or the files inside.
    Try granting full access permission to the folder and its contents.

  • slimshiznslimshizn Posts: 31Members, Plex Pass Plex Pass

    There is full access permission, I'm able to see the folders and files using other means such as my PC plex server.

  • slimshiznslimshizn Posts: 31Members, Plex Pass Plex Pass

    @oakland said:
    Hi, this happened twice now. My Nvidia Shield has stopped seeing some of the folders on my nas. I have 8 folders on there including movies, pictures and music. When I try to add a folder they are not there but I can see them and access them from my PC.

    Searched high and low and cant find an answer. Help please!

    Thanks

    Just figured something out, if you just sign in as guest on the shield, the folders will show up correctly and you wil lbe able to add them. Something with signing in with certain NAS has been giving people issues. This seems to be a work around. Hope it works for you.

  • oaklandoakland Posts: 4Members ✭✭

    Thanks for the response guys but unfortunately none of the above has worked. Again I deleted everything and did a fresh install and I still have the same problem.

    I've attached a pic to help describe what I mean. On the left is the files that the PC can see on the nas and on the right is what Plex is seeing.

    http://i223.photobucket.com/albums/dd178/Oakland2020/Misc/7BCC6B43-51A9-4696-BD08-ABDEF3F9FD55_zpsoxcp97fj.jpg

  • FordGuy61FordGuy61 Posts: 157Members, Plex Pass Plex Pass
    edited May 4

    @oakland
    This is a known issue for the Shield TV. NVIDIA & Plex are working on a fix. Another thread on this same issue said the fix was in beta, but didn't provide a release date (the person posting that info was another Shield TV owner, not a Plex or NVIDIA employee).

    Basically, there is nothing you can do until NVIDIA & Plex release their update.

  • oaklandoakland Posts: 4Members ✭✭

    Thanks Ford for the heads up. In a weird way i'm kinda glad it's a known problem because I was beginning to think I was the only guy in the world that had this problem!!! How long has PLEX/Nvidia known about this and do you have a link to that post?

    Thanks again :)

  • kegobeer-plexkegobeer-plex Posts: 5,324Members, Plex Pass, Plex Ninja Plex Ninja

    @oakland said:
    Thanks Ford for the heads up. In a weird way i'm kinda glad it's a known problem because I was beginning to think I was the only guy in the world that had this problem!!! How long has PLEX/Nvidia known about this and do you have a link to that post?

    Thanks again :)

    Just look around this board, you'll find threads that talk about it. You can also visit the NVIDIA Shield TV forum, as it's well documented there too. It's been a problem ever since the "feature" was enabled. Basically it's never worked right.

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.8.0 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

Sign In or Register to comment.