If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Video plays, no audio AAC-LC codec?

TheBlackMiniTheBlackMini Posts: 11Members, Plex Pass Plex Pass

Hey,

Just installed 1.8.0 embedded EGL on an Intel NUC and videos which use AAC-LC codec doesn't output audio?

Have I goofed up the settings?

Cheers,
TheBlackMini

Audio settings in OpenPHT:
Output 7.1
Passthrough enabled with all options ticked.

Output from MediaInfo on the file:
Format : Matroska
Format version : Version 4 / Version 2
Writing application : FastLE v3.0.0 - AVS
Writing library : libx264 + libebml + libmatroska + libfastrar

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Codec ID : V_MPEG4/ISO/AVC

Audio
ID : 2
Format : AAC
Format/Info : Advanced Audio Codec
Format profile : LC
Codec ID : A_AAC
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 kHz
Frame rate : 46.875 FPS (1024 spf)
Compression mode : Lossy

Best Answer

  • TheBlackMiniTheBlackMini Posts: 11Members, Plex Pass Plex Pass
    Accepted Answer

    Preferences -> Cog Icon -> Audio Settings
    Change output to 2.0
    Scroll down to transcode audio

    Turns out I was passing through audio which my amplifier doesn't understand. Turned off passthrough and changed back to 7.1 and I've got audio working again.

Answers

  • RichardURichardU Posts: 8Members ✭✭

    Same here. Also, the AAC audio plays fine through the Plex Roku app. I'm guessing we need to tell the Plex server to transcode this, but I haven't figured out how. Please post here if you figure this out and I'll do the same.

    Richard

  • TheBlackMiniTheBlackMini Posts: 11Members, Plex Pass Plex Pass

    So I've changed my output to 2.0 and enabled transcoding and it works. EAC3 doesn't work though, and I'd like to keep 7.1 enabled?

  • RichardURichardU Posts: 8Members ✭✭

    Do you mind saying where exactly you enabled transcoding? I'll work on mine and see what I can find out.

  • TheBlackMiniTheBlackMini Posts: 11Members, Plex Pass Plex Pass
    Accepted Answer

    Preferences -> Cog Icon -> Audio Settings
    Change output to 2.0
    Scroll down to transcode audio

    Turns out I was passing through audio which my amplifier doesn't understand. Turned off passthrough and changed back to 7.1 and I've got audio working again.

  • RichardURichardU Posts: 8Members ✭✭

    Where are you finding these settings? I don't see them in my server or player.

Sign In or Register to comment.