Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

SEAGATE PERSONAL CLOUD - "Your Changes Could Not be Saved."

mauroorrumauroorru Members, Plex Pass Posts: 1 Plex Pass

Hi All

I really could do with some help. I had to restore my Seagate Personal Cloud 5TB and plex stopped working.
I then realised music had moved to another folder under a Recovery directory.
I then moved all the music back under Public\Music and reinstalled the Plex Media Server App nto the NAS device.

I now am trying to add the music library back but it keeps telling me "Your Changes Could Not be Saved."

I am attaching a screenshot and the logs. Need help please as I am really not technical at all

Thanks a lot
M

Answers

  • mechiefmechief Members, Plex Pass Posts: 1 Plex Pass

    Same issue here for me as well. Cannot not add movie or tv show library. Your changes could not be saved.

  • pdwaterheadpdwaterhead Members, Plex Pass Posts: 1 Plex Pass

    same here. i just got a seagate personal cloud this weekend and i keep getting this same error message when i try to configure plex. i've looked at other threads that seem to be discussing this issue (or something like it) but i'm not techno-savvy enough to quite understand how to fix this based on those other replies.

  • jefflaingjefflaing Members Posts: 1

    I've been having this as well, though I may be different because I have another Plex Server (that this one is replacing) on the same network.

    Just this minute (literally) I found that changing the Settings>Server>Network>Enable Discovery (GDM) to off appears to have fixed the problem.

    I am suspicious that it was somehow trying to save its settings to "the other server".

    So, now it's busy rediscovering the 5TB of content - we'll see how it plays out.

  • jimmitjimmit Members, Plex Pass Posts: 1 Plex Pass

    I am having the same issue when adding a music library. Unfortunately, disabling discovery didn't help.

  • spatter01@gmail.comspatter01@gmail.com Members Posts: 1

    I am having the same issue. Just received a Seagate Personal Cloud that I purchased because it runs Plex and cannot save a library, screen looks like the post above. I have tried this in both the Plex Media Player app (Win 10) and Chrome. I have another Plex server on the network running on Win 10 and can connect, create directories, and play from that without any problems on Chrome, Plex Media Player (Win 10 and FTV).

    Definitely interested in signing up for a Plex Pass but won't do it unless it works for me.

  • MoskeetoMoskeeto Members Posts: 1

    I've been having this issue myself as well and I think I figured it out...

    When naming the library you're trying to add, make sure you give it the exact same name as the name of the directory (folder). So, for example, if you have a folder named "superhero movies" that you want to add, make sure you name it "superhero movies" when adding it to your Plex library.

Sign In or Register to comment.