If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Should I have to enter a PIN everytime I use my LG Smart TV?

I have a Smart LG TV and am using the Plex for LG (NetCast) App to stream video from my PC.

Everything works fine other than everytime I open the App on the TV I need to enter a four digit PIN on the PC. I exit the App without logging out, so I would expect it to open directly without having to visit the PC to log the TV back in (just as it does on my Android and Apple devices).

Is this normal behaviour?

All the best,

Steve

Tagged:

Best Answer

  • steveoldhamsteveoldham Posts: 5Members
    Accepted Answer

    [SOLVED]. Short answer - a factory reset on the LG TV solved this issue for me. I now go straight into the Plex app without having to log in each time.

    My LG Smart TV was showing 4GB used out of 4GB system storage - and all of this system applications. Following the reset it is showing 2.7GB used out of 4GB - most of this being system applications plus a small amount for user apps. It appears, as summised elsewhere, that LG's 'dirty' upgrades have been leaving orphaned files in memory, subsequently filling the memory and that this lack memory was impeding operation of the Plex app. The reset was not onerous - all my channels are on a separate STB - my only issue is that the LG Smart World logon would not accept my username/password combo, but it accepted my email address/password. The reset and reconfig took me around 30 minutes.

    Thanks to those helpful folk who responded, and hopefully my experience may help other people.

    All the best,

    Steve

Answers

  • bignick8t3bignick8t3 Posts: 1Members, Plex Pass Plex Pass

    I also experience this issue with my LG TV.

    Other devices such as Nvidia Shield, Samsung TV (Smart Hub) and a variety of Android devices have no such trouble.
    Is there any logs we can get to try and ascertain as to what the issue is?

    Cheers,

    Nick

  • SE56SE56 Posts: 1,675Members ✭✭✭✭
    edited May 12

    @steveoldham said:
    I have a Smart LG TV and am using the Plex for LG (NetCast) App to stream video from my PC.

    Everything works fine other than everytime I open the App on the TV I need to enter a four digit PIN on the PC. I exit the App without logging out, so I would expect it to open directly without having to visit the PC to log the TV back in (just as it does on my Android and Apple devices).

    Is this normal behaviour?

    All the best,

    Steve

    Just make sure you have your TV IP in the allowed IP addresses with Authorization in PMS network settings, may help if your router/modem has all your LAN devices IP addresses marked as static.

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • steveoldhamsteveoldham Posts: 5Members

    Hi Guys, thanks for taking the time to respond. I don't know how to take logs, but this is something I'll look into. Concerning the network. I have an Archer C50 cable router and two Netgear Gigabyte switches, the path is wired (Cat5e) and the wired devices all have reserved (static) IP addresses. I don't know about PMS network settings, this is something that I'll have to look into. If I look at Plex/settings/devices I have multiple (apparently identical) entries for the LG TV, but single entries for everything else? This annoying 'feature' just takes the edge off what is otherwise a fantastic app! Thanks again for your inputs, Steve

  • SE56SE56 Posts: 1,675Members ✭✭✭✭

    @steveoldham said:
    Hi Guys, thanks for taking the time to respond. I don't know how to take logs, but this is something I'll look into. Concerning the network. I have an Archer C50 cable router and two Netgear Gigabyte switches, the path is wired (Cat5e) and the wired devices all have reserved (static) IP addresses. I don't know about PMS network settings, this is something that I'll have to look into. If I look at Plex/settings/devices I have multiple (apparently identical) entries for the LG TV, but single entries for everything else? This annoying 'feature' just takes the edge off what is otherwise a fantastic app! Thanks again for your inputs, Steve

    Just delete the old ones in devices.

    Network settings

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • steveoldhamsteveoldham Posts: 5Members

    Hi Gdr56, I'll have a look at this. FWIW I've also been looking at this thread - https://forums.plex.tv/discussion/210502/lg-tv-app-doesnt-save-credentials-anymore/p1 - which suggests that the solution is to free up memory by doing a factory reset on the TV! Brave move, but I'll give it a try and report back. All the best, Steve

  • SE56SE56 Posts: 1,675Members ✭✭✭✭

    @steveoldham said:
    Hi Gdr56, I'll have a look at this. FWIW I've also been looking at this thread - https://forums.plex.tv/discussion/210502/lg-tv-app-doesnt-save-credentials-anymore/p1 - which suggests that the solution is to free up memory by doing a factory reset on the TV! Brave move, but I'll give it a try and report back. All the best, Steve

    Yes, just write down your complicated settings prior or take some pics. If you have the settings already covered and does not work. I would try turning the power off to the TV from the wall , wait a minute and restart. Prior to nuking you settings.

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • steveoldhamsteveoldham Posts: 5Members
    Accepted Answer

    [SOLVED]. Short answer - a factory reset on the LG TV solved this issue for me. I now go straight into the Plex app without having to log in each time.

    My LG Smart TV was showing 4GB used out of 4GB system storage - and all of this system applications. Following the reset it is showing 2.7GB used out of 4GB - most of this being system applications plus a small amount for user apps. It appears, as summised elsewhere, that LG's 'dirty' upgrades have been leaving orphaned files in memory, subsequently filling the memory and that this lack memory was impeding operation of the Plex app. The reset was not onerous - all my channels are on a separate STB - my only issue is that the LG Smart World logon would not accept my username/password combo, but it accepted my email address/password. The reset and reconfig took me around 30 minutes.

    Thanks to those helpful folk who responded, and hopefully my experience may help other people.

    All the best,

    Steve

Sign In or Register to comment.