Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Another Remote Access Problem

jrw8778jrw8778 Members, Plex Pass Posts: 4 Plex Pass

Hi,

I've been trying to get the remote access feature to work for (on and off) two plus years at this point. Here's what I can tell you:

  1. It's not double NAT
  2. My cable modem / router is a SBG6580
  3. I've had UPnP both enabled, disabled and I've tried toggling it on and off.
  4. The router firewall is off
  5. I've created a static local IP for my server.
  6. I've manually specified a port for Plex through the router's software.
  7. I've tried a variety of ports for the Plex media server, including the ubiquitous 32400
  8. Externally, canyouseeme.org times out when checking the specified port. Other software reports the port is closed.
  9. I've tried to put the server in the routers DMZ with no change
  10. I've futzed around with the Windows firewall setting to try to make this work, no success.
  11. My ISP is Comcast.

At this point I'm just a little tired of doing this for so long with absolutely no success. If anyone has any suggestions or advice I'd be most appreciative.

Best Answer

Answers

  • kegobeer-plexkegobeer-plex Members, Plex Pass Posts: 5,122 Plex Pass

    Wow, that's a lot of troubleshooting. Not much else I can suggest. Have you tried installing Plex Server on a different computer to see if you can get remote access working on it? Also, that particular router/modem has caused people grief getting remote access working. Can you detail all the steps you took to set up port forwarding on it?

    Where are my log files?

    How do I properly name my media files?

    NVIDIA SHIELD SMB/NAS Sharing How-To - / - NVIDIA SHIELD Support Documents

    Plex Server: 1.7.5 running on ThinkServer TS140 w/Server 2012 R2 Essentials
    Primary Plex Player: Shield TV, always the latest beta build, always the latest firmware revision

  • jrw8778jrw8778 Members, Plex Pass Posts: 4 Plex Pass

    Well, I basically went to the advanced settings, chose port forwarding forwarded 32400, 21000, 21001 and others to 192.168.0.7 (the static internal IP for the server), for TCP first and both TCP and UDP. I tried it with the firewall active and deactivated. I'm not holding out too much hope. I don't like posting for help, I prefer to try to look it up, this is kind of last ditch. Thanks for commenting.

  • BigWheelBigWheel Members, Plex Employee, Plex Pass, Plex Ninja Posts: 9,574 Plex Employee
    edited May 11

    so your settings are like below and 32400 is entered and field enabled for the manually specified port field in remote access settings?

    Logs > https://support.plex.tv/hc/en-us/articles/201869908-Log-Files
  • jrw8778jrw8778 Members, Plex Pass Posts: 4 Plex Pass

    Currently, I'd have to look, but I've certainly tried that arrangement (with my correct external ip address, of course).

  • padgettbrianpadgettbrian Members, Plex Pass Posts: 14 Plex Pass

    Hey any luck with this? Been having same issue for months since i moved. Still with Comcast and have the SBG6580, tried all the similar steps going to try hosting and IIS site tomorrow to see if I get any clues.

  • padgettbrianpadgettbrian Members, Plex Pass Posts: 14 Plex Pass

    Oh forgot to mention one thing.... does yours appear to connect outside for just a brief 3 seconds that seems like omg it's working, then boom. No connection :(

  • mimixyymimixyy Members, Plex Pass Posts: 7 Plex Pass

    With UPnP you won't need to port forward I believe.
    I have UPnP enabled and Remote is working fine without forwarding.

    Might seem silly, but have you disabled windows firewall or third party firewall?

  • fastballspecialfastballspecial Members, Plex Pass Posts: 29 Plex Pass

    these same set of circumstances is happening for me too with Verizon Fios. used to work and now it connects for 3 minutes or so and then loses the connection. Also weirdly even though I don't have remote access enabled (or it doesn't appear to be working) a friend is able to access my server still through an indirect connection - this is odd.

  • jmeehan11jmeehan11 Members, Plex Pass Posts: 81 Plex Pass

    also...
    if you specify another port in plex, say 5000, plex is still going to listen on 32400.

    what you have to do is forward 5000 on the wan side to 32400 on the lan side

    External (wan) 5000 ---> router ----> Internal (LAN) 32400 ----> Plex Server

    With comcast, do yourself a favor, get rid of their **** modem/router and get your own motorolla/arris modem and a separate router.

  • padgettbrianpadgettbrian Members, Plex Pass Posts: 14 Plex Pass

    Setting the EXTERNAL IP's as 0.0.0.0 did work for me!!!!

    I was also able to get an IIS server thru this mess. Thank you all!!!

  • padgettbrianpadgettbrian Members, Plex Pass Posts: 14 Plex Pass

    uPNP was also disabled which seems to have helped, as another suggested.

  • jrw8778jrw8778 Members, Plex Pass Posts: 4 Plex Pass
    edited May 23

    @BigWheel said:

    >

    pretty sure you should be leaving the external IP empty for that router. leave it at 0.0.0.0 . that settings is if you are trying to let a particular external computer/whatever find your internal computer. it is not for your personal external/public IP, your router already knows what that is.

    This worked! Amazing. I did not see this tip on any Plex documentation. Thank you so much!

Sign In or Register to comment.