Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Chromecast Ultra Crashing

mkrisacmkrisac Posts: 1 Plex Pass

I have been experiencing a lot of trouble with casting using my Chromecast ultra with Plex on my QNAP NAS. Certain types of video files will play without any issues, whereas others will cause the Chromecast to have a freakout. It's best explained using a video (NOTE: the TV flashes a lot, so be aware if you're prone to seizures):
Enjoy.

The video will always begin playing with a black screen, but audio can be heard. Then, if you attempt to alter the bitrate, seek further into the video, or stop playback the seizure mess will occur. Depending on the severity, this will either crash the Chromecast and cause it to restart or after 20-30 seconds of flashing it will return to the "Ready to Cast" screen.

Also attached is a log where the video output you see in the link happened. Here are a couple things I have found out along the way:

  • Playing any audio content works fine
  • Playing 720p, H.264 content recorded using DVR works fine
  • Playing 480p, H.264 content (which Plex incorrectly calls 576p) recorded using DVR works fine most of the time
  • 1080i and 1080p H.264 content will never work properly.

The same TV is also connected to a PC which can play any of the above video types without issues. Android as well. Chromecast seems to be the only problem area. I also have the two older generation Chromecasts and while they don't go into a full on seizure playing the video, they still do not properly play it, or just show a black screen.

I looked into modifying the chromecast.xml file on 1.5.5 and that made no difference. I also just updated to 1.6.1 today in the rare chance that it would be fixed. Nope.

Sign In or Register to comment.