If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

LG Plex App Asking for Sign-in Every time

Good Day,
I would just like to ask if there has been a resolution to this issue? as My LG Smart TV is asking for the credentials every time that the TV is turned on, even from Standby.
Thanks.

Answers

  • SE56SE56 Posts: 1,764Members ✭✭✭✭

    @MonsterT4ils said:
    Good Day,
    I would just like to ask if there has been a resolution to this issue? as My LG Smart TV is asking for the credentials every time that the TV is turned on, even from Standby.
    Thanks.

    Server settings/Network, add your TV IP address, Tv app add to settings your Server/ Computer IP address. Found in the top right of opening Page of app.

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • MonsterT4ilsMonsterT4ils Posts: 2Members

    @Gdr56
    Thanks for your response, but still no luck.

  • SE56SE56 Posts: 1,764Members ✭✭✭✭

    Have you restarted your Tv from the wall and or a factory default reset

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • MUIQMUIQ Posts: 20Members, Plex Pass Plex Pass

    Same issue, Plex app on my LG TV has asked to link with server every time I start app.

  • SE56SE56 Posts: 1,764Members ✭✭✭✭

    @MUIQ said:
    Same issue, Plex app on my LG TV has asked to link with server every time I start app.

    I had the same issue but i resolved it a while ago. To add to previous posts above. Maybe un install and re install, restart tv from Wall. Sign in and out of account prior may help. I can not remember exactly what i did.

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • stanimirttstanimirtt Posts: 1Members

    Hello, I have the same issue. Recently, the app start asking me for login. Can you help me?

  • steveoldhamsteveoldham Posts: 5Members

    I have solved this in the last couple of days by doing a factory reset on the LG TV. My full post on this is here : https://forums.plex.tv/discussion/270755/should-i-have-to-enter-a-pin-everytime-i-use-my-lg-smart-tv#latest

    All the best,

    Steve

  • MUIQMUIQ Posts: 20Members, Plex Pass Plex Pass

    One of these steps have helped me.

    1. Add home subnet to "List of IP addresses and networks that are allowed without auth" list (server setting).
    2. "Factory reset" on TV, then setup WiFi, LG account, install official Plex app and link it with server.
    3. Enter Plex server IP to "Server settings" in Plex app.

    I'll continue testing...

  • JDubbedNJDubbedN Posts: 93Members, Plex Pass Plex Pass

    Same problem here. See my OP.

    Can't really troubleshoot because I don't direct access to the TV. But wanted to confirm the problem is still live.

  • EelcoIJsselsteijnEelcoIJsselsteijn Posts: 1Members, Plex Pass Plex Pass

    I have the same problems here, already tried to re-install the LG plex app, no luck.
    I've also tried to put in the PMS IP in de server settings, but that didn't work either.
    I always run the last PMS version on my server.
    Problems started about 3 or 4 PMS versions ago.

  • nemesus1450nemesus1450 Posts: 3Members, Plex Pass Plex Pass

    I have the same problem - happens intermittently.
    I have done the factory reset, re-installed everything and added the server IP... not resolved.

  • JDubbedNJDubbedN Posts: 93Members, Plex Pass Plex Pass

    Yup. Problem still persisting here.

  • tomyuntomyun Posts: 45Members ✭✭

    I second it. My LG projector (PF1500W with WebOS 3.0) always keeps asking sign-in on launching Plex app after each power cycle. Factory reset, adding server IP didn't help at all.

  • SE56SE56 Posts: 1,764Members ✭✭✭✭

    @tomyun said:
    I second it. My LG projector (PF1500W with WebOS 3.0) always keeps asking sign-in on launching Plex app after each power cycle. Factory reset, adding server IP didn't help at all.

    Have you added it to server network settings, "list IP address allowed"

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • tomyuntomyun Posts: 45Members ✭✭

    @Gdr56 yes, I have. When I launch Plex app on TV (projector indeed), a message like "your credential is expired" shows up very shortly and moves on to sign-in screen.

  • SE56SE56 Posts: 1,764Members ✭✭✭✭
    edited July 28

    @tomyun said:
    @Gdr56 yes, I have. When I launch Plex app on TV (projector indeed), a message like "your credential is expired" shows up very shortly and moves on to sign-in screen.

    Try reserving or as some say making your LAN IP for Server and TV / projector Static in your modem / Router. Restart everything and see how you go. Do not confuse your ISP WAN IP address as Static, that is not required.

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • tomyuntomyun Posts: 45Members ✭✭

    @Gdr56 my server and project already had static IP address assigned and was confirmed in the logs saying "Allowed Network", but didn't work for auto sign-in. Do you need any logs to take a further look at?

  • tomyuntomyun Posts: 45Members ✭✭

    Just found the same issue reported by Amazon reviewers. Still not sure if it's to blame Plex or LG.

Sign In or Register to comment.