Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex insists that it cannot be reached remotely

QuadPieceQuadPiece Members, Plex Pass Posts: 6 Plex Pass
edited May 16 in Linux

I'm in quite an odd situation with Plex and trying to enable remote access.

It always tells me that my server is not reachable outside of my network. While in reality it is perfectly accessible. A friend I asked could access it fine via :32400. canyouseeme.org also agrees with me that everything is working fine. Yet while attempting to enable remote access it persistently gives me a "Not available outside your network" message.

Due to this, all apps, web UI on other machines and stuff like my PS4 at my parents' place are stuck using an "indirect" connection. Adding a manual connection in my apps works fine. It allows me to stream directly and with all the quality options. Problem is that my external IP is dynamic, so I'll have to re-add them. If I'm not home I won't know what my new external IP is either.

I'm suspecting it's due to me being stuck behind double-NAT. I have my own router, which is then connected to a second router that belongs to my landlord.

I did a typical double-NAT port forward like follows: -> (My own router) -> (My Plex server)

As mentioned above, this works perfectly if I just add my server manually. However the Settings -> Remote access wizard refuses to enable remote access and insists that it's local only.

To summarize, here's a TL;DR list with all important key points:

  • I'm stuck behind double NAT
  • UPnP is enabled on both routers
  • Local IP of Plex server and second router is static
  • External IP is dynamic
  • Friends, my phone's mobile data and canyouseeme.org all agree that my server is reachable
  • Plex says that Remote Access is not possible
  • I have attempted ports other than 32400 (And added respective translations to routers)
  • My server is running on CentOS. Though I tried reinstalling with Ubuntu to no avail. Back to CentOS now
  • Jumbo packets are disabled throughout the entire network chain

Any help would be high appreciated. This issue has had me beaten with hours of work by now.


  • QuadPieceQuadPiece Members, Plex Pass Posts: 6 Plex Pass

    I managed to solve it.

    I set up an ssh tunnel and forwarded port 32400 to an external VPS, to effectively sneak by the entire double-NAT setup.
    After doing that I was able to enable remote access via the plex.tv/web UI (But it only worked on the VPS where the port was forwarded to)

    When I killed the ssh tunnel afterwards, Plex somehow remained aware that it could be reached outside my network and was reachable again once it updated the IP to my residential one.
    For now it seems stable.

Sign In or Register to comment.