If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Sync "Waiting for server"

j3nesisj3nesis Posts: 1Members, Plex Pass Plex Pass

Android, S7 Edge. Android 7, Plex app latest version. Have tried reinstalling the app, deleting device from Plex server and readding, all the usual.

Sync just doesn't work. "Waiting for server." I've tried enabling insecure connections, that didn't work. No error messages and nothing ever syncs. Direct play and streaming works fine, but syncing doesn't and has never worked. I've tried syncing just a single episode or whatever at a time in case it's the file, tried at the lowest possible quality, made sure the VPN isn't running, etc etc.

Please advise. Where do I start to troubleshoot? What have I missed?



  • Daedalus7Daedalus7 Posts: 13Members, Plex Pass Plex Pass

    I was having an issue where the sync page in android would show a bunch of my items as "waiting to download", even though they were fully downloaded. I found out that when i would sync things from the phone's interface the items would get stuck. However, when i add things from the plex web client on the server, all of the items sync perfectly.

    There must be something fishy when syncing with the android app.

    Try to sync some content from the web interface on your server to your phone, and see if it works.

  • captainnapalmcaptainnapalm Posts: 11Members, Plex Pass Plex Pass

    I was having this issue, and my problem was that converting was "Paused" on the server. When I went to Plex Web to attempt @Daedalus7's solution, I initiated the sync but still saw that it was Waiting for Server. Going to the activity page and then to the conversion page I saw that there were other sync items "Waiting to convert" and noticed that there was a button top right that said "Resume" I clicked that and miraculously the items started to convert and sync properly.

Sign In or Register to comment.