Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can I use Plex Remote Access when my ISP-Provided Router doesn't support Port Forwarding?

mrumley02mrumley02 Members Posts: 10 ✭✭

Hi Everyone,
I've been a Plex user for about a year now. I've only been using my server locally. Now I'm interested in Remote Access. However, I've discovered my router (provided by my ISP and non-negotiable for at least a year until our service can be upgraded) doesn't support port forwarding. Does anyone have any ideas?
Help wold be greatly appreciated.
Thanks,

Tagged:

Best Answer

Answers

  • cayarscayars Members, Plex Pass, Plex Ninja Posts: 3,939 Plex Ninja

    You do not have admin access to it? Does it also serve as a WIFI hotspot as well?

    Very few routers don't support this. It is often buried in menus and called something else but most will support it.

    What brand/model is it?

    Carlo

  • JuiceWSAJuiceWSA Members Posts: 5,197 ✭✭✭✭✭

    That sounds diabolical, but I'm not surprised by anything ISPs do.
    I had CrapCast once upon a time and they 'tried' that tactic with me briefly, sending a guy out to 'upgrade' my ASUS Router to one of theirs (that would provide a CrapCast Hot Spot for the neighborhood), but as he was reaching for the cables I informed him that I would be using my router - or he could remove his modem from the premises and I would stop paying Crap-Cast.

    He was quick to call HQ and we came up with a suitable compromise - he installed a new modem and put his router/modem combo back in the truck. Too bad about that Crap-Cast Hotspot they had in their sights. I suppose they liked the sound of my continuing to pay for services rendered as opposed to me paying someone else.

    If your ISP has you over a barrel - no others to threaten to leave for, or you are contractually obligated - your options are:
    1) plead with HQ in the hopes a compromise can be struck.
    2) deal with it and no remote access.

  • mrumley02mrumley02 Members Posts: 10 ✭✭

    Thank you both.
    @cayars The modem is a Huawei ES186 The web OS at 192.168.*.*** has the ISP's logo so it may be different to everyone else's. It's a requirement for our Mobile Broadband Service. When NBN eventually makes it around we'll be able to ditch it and go with my wonderful Netgear router.

  • cayarscayars Members, Plex Pass, Plex Ninja Posts: 3,939 Plex Ninja

    It looks like you can port forward on this router. There are directions and pictures on this page showing how to do it: https://portforward.com/huawei/e5186s-22a/

  • mrumley02mrumley02 Members Posts: 10 ✭✭

    Thanks for that @cayars . The interface is accurate. However, I am missing the Virtual Server section. Probably an ISP block.

  • JuiceWSAJuiceWSA Members Posts: 5,197 ✭✭✭✭✭
    edited May 20

    When I was investigating things a bit back in the 'Crapcast' days I learned that their Super-Duper Hotspot Modem/Router had no real 'user' area in which to fiddle, but I could call their 'East India Office Complex' and have them do any fiddling that was necessary from half-way around the Earth.

    I decided rather quickly that option wasn't going to work out for me. If that's your only option you may want to give it a shot. India is a LOT closer to you than it was for me.

  • jjrjr1jjrjr1 Members, Plex Pass Posts: 1,704 Plex Pass
    edited May 20

    Exactly
    Remember @cayars all the crap we went thru because Time Warner's Router disabled certain aspects of Port Forwarding. (In our case it was the Time Warner Certified modem/router)

    Many cable provider routers DO disable port forwarding or severely disable parts of it..

    Go get yourself a decent standalone router and call your cable provider to replace the installed modem/router with a modem only or have you cable supplied modem/router configured to passthru mode.
    Also stay away from ANY modem/router combo for the same reason.

  • jjrjr1jjrjr1 Members, Plex Pass Posts: 1,704 Plex Pass

    Oh yeah.
    Knowing how ISPs can be, that pain medicine is administered rectally RIGHT!
    LOL

  • JuiceWSAJuiceWSA Members Posts: 5,197 ✭✭✭✭✭

    During my investigations that did seem the be the procedure and was the #1 reason I opted out.

    :)

  • mrumley02mrumley02 Members Posts: 10 ✭✭

    @jjrjr1 said:
    Oh yeah.
    Knowing how ISPs can be, that pain medicine is administered rectally RIGHT!
    LOL

    I found that mightily hilarious @jjrjr1 . Thanks for that guys!

  • JuiceWSAJuiceWSA Members Posts: 5,197 ✭✭✭✭✭

    When faced with a completely impossible situation - laugh. It beats axe-murdering and is more widely accepted in the community.

    lol

  • cayarscayars Members, Plex Pass, Plex Ninja Posts: 3,939 Plex Ninja

    You still have a few options.

    1) See if you have access to turn this into BRIDGE mode. If so this is could be used with your own router. Also do a check to see if you have access to any setting for DMZ zone.
    2) Go to http://consumer.huawei.com/en/support/smart-home/lte-router/e5186s_en-sup.htm and download your own firmware/software for the modem and update it. This would give you back your missing menus.
    3) Replace the firmware to something like www.dd-wrt.com if it's available for this modem.
    4) Use your own router and change the MAC address of it to use the MAC address on the providers router. Disconnect the one they gave you for 15 minutes to an hour then plug yours in with the spoofed MAC address.
    5) Keep everything the way it is now and use a VPN service such as PIA that allows you to get a fixed port/IP address for use on their system. Run Plex through the VPN service.
    6) Don't touch aything and use Plex Relay service which will limit throughput to 1.5/2.0 (non PP/PP).

    Obviously 2 and 3 may not be allowed by contract so read/check that. #4 is good to try if you have another router around or don't mind purchasing one (and can take back if it doesn't work).

    There are other things as well but these are the main things to check first.

  • cayarscayars Members, Plex Pass, Plex Ninja Posts: 3,939 Plex Ninja

    I was just wondering something. You said your router doesn't support port forwarding. Is this based on just looking at the interface? Have you tried to see if you can port forward via UPnP?

    For the heck of it download https://sourceforge.net/projects/upnp-portmapper/ this small program and see if it can do anything for you.

    It's quite possible (not likely) that you don't have access to a web page but it does support UPnP forwarding. Check the web interface to see if there are any UPnP options for turning it on or off as well.

    Carlo

  • jjrjr1jjrjr1 Members, Plex Pass Posts: 1,704 Plex Pass
    edited May 20

    I am pretty sure the ISP will either take out the combo unit and replace with a modem only device OR put it into Passthru (Bridge) mode. However that is usually only able to be accomplished thru ISP only accessible settings.

    The contract with an ISP usually (Like with cell phones) just means you will not cancel for a period of time in order to enjoy special pricing.

    My guess, as even time warner, will do this for you..

    BTW, as was in my case, the modem/router probably DOES support port forwarding but the ISP as part of the certification process has the vendor disable or modify the feature with firmware for the router.

    @cayars . I guess you did forget all we went thru just trying to setup FTP with time warner equipment... LOL. Probably a good thing. Was really a pain in the ass not to mention expensive. But a learning experience at least for me,,, LOL

  • OttoKernerOttoKerner Members, Plex Pass, Plex Ninja Posts: 22,146 Plex Ninja

    Since it is weekend, this kinda fits:

  • jjrjr1jjrjr1 Members, Plex Pass Posts: 1,704 Plex Pass

    @OttoKerner
    Toooo funny..

  • cayarscayars Members, Plex Pass, Plex Ninja Posts: 3,939 Plex Ninja

    @OttoKerner said:
    Since it is weekend, this kinda fits:

    Poor Comcast!

Sign In or Register to comment.