If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Smart Cache Upper Limit too high

tjcinnamontjcinnamon Posts: 46Members, Plex Pass Plex Pass

It seems that if I put the SmartCacheUpperLimit in the advanced settings too high: 400MB and then try to play a "smaller" file 2GB, the video won't be recognized until I lower the cache. Is this a bug? I have 16GB of RAM. I would like to set it to 4GB so when I have a REMUX bluray from my collection I can buffer a substantial amount.

I love the SmartCache because being able to use it makes for a much more consistent experience

I'm using that with a

BufferMode 1
CurlClientTimeout 30
ReadBufferFactor 40

Perhaps its those settings?

Best Answer

  • tjcinnamontjcinnamon Posts: 46Members, Plex Pass Plex Pass
    Accepted Answer

    I know this doesn't answer this for OpenPHT but with Plex Media Player I was able to change the cache by going to

    C:\Users\MYUSER\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf and changing the cache section to a higher number

Answers

  • tjcinnamontjcinnamon Posts: 46Members, Plex Pass Plex Pass

    anyone know what those settings mean?

  • ValdhorValdhor Posts: 502Members, Plex Pass Plex Pass

    I can take a guess...
    BufferMode looks like a boolean so I would say this turns the buffer on or off.
    curl is a *nix application for transferring data over a network using various protocols. CurlClientTimeout 30 says to timeout after 30 seconds when requesting data from the server.
    Now ReadBufferFactor I have no idea.

    I don't believe setting your cache extremely high is a good idea. Buffering 4GB will take a long time over the network so starting your movie could take a while as it buffers that much. I would have thought a few hundred megabytes would be plenty.

  • tjcinnamontjcinnamon Posts: 46Members, Plex Pass Plex Pass

    Thanks for responding

    If I'm going a 24GB over plex cloud I'll need a decent headstart. If I set to higher than 400MB the smaller videos won't play. I looked on Git to see if the datatype could support a value that high. It's an Int and it's also an Int in the Kodi source so it's not that (I don't think).

    There is a divergence between Kodi source and OpenPHT where the uppersmartcachelimit in the Kodi source does not exist in the advance settings .cpp nor .h files.

    I'm curious what that does. It's the only variable that affects the caching. Do you know what fork of Kodi this is. I suspect 16 because in 17 they changed the cache xml attribute to memorysize.

    So it could be a datatype issue or the problem is in the player file that is using the advance setting. I'm not sure where else that variable is. Someone suggested I "grep" it but I'm not sure how to do that. The best I could do thus far is find the advanced settings file cpp and .h in GIT

  • tjcinnamontjcinnamon Posts: 46Members, Plex Pass Plex Pass
    Accepted Answer

    I know this doesn't answer this for OpenPHT but with Plex Media Player I was able to change the cache by going to

    C:\Users\MYUSER\AppData\Local\PlexMediaPlayer\plexmediaplayer.conf and changing the cache section to a higher number

  • nielsvdpnielsvdp Posts: 61Members, Plex Pass Plex Pass

    Hope this still helps you; https://forums.plex.tv/discussion/comment/1443650/#Comment_1443650

    Although I am not sure what you mean by; I love the SmartCache because being able to use it makes for a much more consistent experience

    I have found no benefit in upping the cache - the only thing that did benefit from it is the readbuffer factor - this will actually fill up the cache in matter of seconds - I only found this handy when playing 4k films (80+mbps bitrates).

Sign In or Register to comment.