If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to default to Original quality

prbassplayerprbassplayer Posts: 9Members ✭✭

After a recent update, app changed how it handles it's "quality" defaults. It not longer has "original" now it has a broken switch that says if "video smaller than 20Mbps it will play at original quality" I select this for both "home" and "internet" and it always defaults something ridiculous like 20Mbps or 200Mbps. None of my media is larger than 10Mbps. It's getting really annoying. Attached android and server log.

As a side note to android app devs, you guys need to be slapped for messing with settings while playing video... dislike how intrusive it is now and more taps to do the same damn thing :neutral:

Tagged:
«1

Answers

  • aburhinoxaburhinox Posts: 8Members, Plex Pass Plex Pass

    I'm running into the same problem, I'm unable to select Original quality anymore in the android app. I've tried to pick it per video, but even that wont take. It starts transcoding even when I'm on the same LAN. My puny server cannot handle the transcoding so now I'm stuck with stuttering videos on my phone. I hope prbassplayer's logs are enough info, but I can dig mine up if needed.

  • BrausmithBrausmith Posts: 24Members ✭✭

    Same here, the latest app update has broken my ability to play high quality videos without transcoding. It's getting quite annoying.
    When playing the video it simply will not play at original quality. Instead it always uses 200 or 20mbps and is transcoding which my server cannot handle.
    It used to play just fine without transcoding. This needs to be fixed.

  • ycaballeroycaballero Posts: 17Members, Plex Pass Plex Pass

    I am also having the same issue. My files are not bigger than 8mbs, however the damn thing always wants to transcode to some weird 200mbps. Files that used to run on Direct Play are now transcoding. I don't know what setting to choose and I get the annoying "your server is not fast enough...." message that I never had before on Direct Play.

  • indiandennisindiandennis Posts: 1Members

    Same issue for me. If I choose to play original quality, the checkbox for it is checked on the app, but as soon as I return to playback and then open settings again, it shows this:

    If I try selecting another quality setting, it shows up correctly, but choosing original quality always results in 20mbps or 200 mbps regardless of the actual video quality.

  • pinglispinglis Posts: 11Members ✭✭

    same here
    tried downgrading the app but won't let me activate it without purchasing again

  • FlixNowFlixNow Posts: 99Members, Plex Pass Plex Pass

    Plex can you please acknowledge and fix this issue? Makes your platform useless on Android.

  • marcandre.isabelmarcandre.isabel Posts: 5Members ✭✭

    Same problem here. Always default to 200 Mbps since last plex android update

  • FlixNowFlixNow Posts: 99Members, Plex Pass Plex Pass

    Not only that, there doesn't seem to be any way to differentiate between mobile and wifi data.

    Previously you were able to set different qualities depending on what network you were connected to.

    Not any more!

  • MovieFan.PlexMovieFan.Plex Posts: 15,887Members, Plex Pass, Plex Ninja Plex Employee

    @prbassplayer said:
    After a recent update, app changed how it handles it's "quality" defaults. It not longer has "original" now it has a broken switch that says if "video smaller than 20Mbps it will play at original quality" I select this for both "home" and "internet" and it always defaults something ridiculous like 20Mbps or 200Mbps. None of my media is larger than 10Mbps. It's getting really annoying. Attached android and server log.

    Not sure if you are still having issues. Looking at your log it shows you are playing back video that has EAC3 (aka Dolby Digital Plus), which the device doesn't support so it's transcoding the audio only. So at least for this example, the app is working as expected.

    @aburhinox said:
    I'm running into the same problem, I'm unable to select Original quality anymore in the android app. I've tried to pick it per video, but even that wont take.

    Original Quality is not just called Maximum Quality.

    @ycaballero said:
    I am also having the same issue. My files are not bigger than 8mbs, however the damn thing always wants to transcode to some weird 200mbps. Files that used to run on Direct Play are now transcoding. I don't know what setting to choose and I get the annoying "your server is not fast enough...." message that I never had before on Direct Play.

    Showing 200Mbps is a bug right now. It may not actually be transcoding. You'll need to provide more info and logs for us to look into this.

    @pinglis said:
    same here
    tried downgrading the app but won't let me activate it without purchasing again

    If you've purchased the app before, there should be an option at the bottom of the page where it asks you to activate the app to say that you've purchase the app before. You need to scroll down on the page so maybe you just missed it.

    @FlixNow said:
    Not only that, there doesn't seem to be any way to differentiate between mobile and wifi data.

    There is an option for "Limit Cellular Data".

  • marcandre.isabelmarcandre.isabel Posts: 5Members ✭✭

    Showing 200Mbps is a bug right now. It may not actually be transcoding. You'll need to provide more info and logs for us to look into this.

    I wouldnt say that it is only a display bug on my side as when it switchs back to '200 Mbps', the stream gets extremely laggy and I have to manually go and set it back to original quality

  • MovieFan.PlexMovieFan.Plex Posts: 15,887Members, Plex Pass, Plex Ninja Plex Employee

    @marcandre.isabel said:

    Showing 200Mbps is a bug right now. It may not actually be transcoding. You'll need to provide more info and logs for us to look into this.

    I wouldnt say that it is only a display bug on my side as when it switchs back to '200 Mbps', the stream gets extremely laggy and I have to manually go and set it back to original quality

    There maybe other issues as well, but just seeing 200 does not mean there is a problem. Please provide your logs if you have a specific scenario we can look at.

  • FlixNowFlixNow Posts: 99Members, Plex Pass Plex Pass

    @MovieFan.Plex said:

    @marcandre.isabel said:

    Showing 200Mbps is a bug right now. It may not actually be transcoding. You'll need to provide more info and logs for us to look into this.

    I wouldnt say that it is only a display bug on my side as when it switchs back to '200 Mbps', the stream gets extremely laggy and I have to manually go and set it back to original quality

    There maybe other issues as well, but just seeing 200 does not mean there is a problem. Please provide your logs if you have a specific scenario we can look at.

    Moviefan.Plex, why is it next to impossible to direct play a file on Android now? No matter what option I select, on any file, it always transcodes, most of the time it transcodes to a random higher bitrate (ie. play a 4mbps file, but it gets Transcoded to 5.7mbps).

    What options do we select to direct play a file on Android?

  • MovieFan.PlexMovieFan.Plex Posts: 15,887Members, Plex Pass, Plex Ninja Plex Employee

    PMS does not upscale. If you are seeing that, something is definitely wrong. I can direct play files just fine, even HEVC 8-bit on my Samsung S6. If it is not working there is something definitely different going on. That's why I need logs.

    I've seen a few reports of high bitrate files (>20 Mbps) not direct playing, which I am investigating. But anything below that should work.

  • jefferycarlislejefferycarlisle Posts: 5Members, Plex Pass Plex Pass

    I have the same problem. Every recorded show on my android device lags...keeps getting a transcoding error. Annoying that I can't watch whay I need too. Plex please fix.

  • Dion250Dion250 Posts: 148Members, Plex Pass Plex Pass
    edited September 1

    This is probably why all my videos are transcoding on my Android Tablets. Says its converting 200Mbps on 480p?????

    Selecting Original does nothing.

    FlixNow i also brought up the issue on another thread about this. I was basically told Plex is working fine and its a problem with our media.. Which is complete BS and 100% passing blame to others.

    My tablet supports hevc decoding ffs.. 480p h264 is no contest for my Asus Zenpad 3s.

  • MovieFan.PlexMovieFan.Plex Posts: 15,887Members, Plex Pass, Plex Ninja Plex Employee

    @jefferycarlisle said:
    I have the same problem. Every recorded show on my android device lags...keeps getting a transcoding error. Annoying that I can't watch whay I need too. Plex please fix.

    Are you saving recordings as the original or transcoding them as they record? If you are recording as the raw original, what codec does PMS say the video is? If it's MPEG2, most android devices cannot direct play that so it has to be transcoded. If your PMS can't handle transcoding, then you will get the error you described.

  • MovieFan.PlexMovieFan.Plex Posts: 15,887Members, Plex Pass, Plex Ninja Plex Employee

    @Dion250 said:
    This is probably why all my videos are transcoding on my Android Tablets. Says its converting 200Mbps on 480p?????

    As mentioned earlier. This does not mean it is actually transcoding. It's just the setting in place at the time.

    Selecting Original does nothing.

    Changing the setting to original will not force direct play. You'll need to provide at least the XML from the video so we can check if it should be able to direct play or not.

    My tablet supports hevc decoding ffs.. 480p h264 is no contest for my Asus Zenpad 3s.

    Not sure exactly which 3S model you have but according to https://www.devicespecifications.com/en/model/edb93d2a, it does not have hardware h265 support. Our app cannot do software decoding client side so PMS has to transcode these.

  • hqt999hqt999 Posts: 2Validating, Plex Pass Plex Pass

    Same issue, no matter how low I tell the new Android app to play my videos it always goes back to "play maximum" and sets it to 200mbps even if the video is 1.6 I have set cell limits, internet limits, manually go in and change the player setting on the file. But the moment I go back into the settings it has changed it's self back causing the video to be unplayable.

  • vlasicolvlasicol Posts: 2Members, Plex Pass Plex Pass

    @hqt999 said:
    Same issue, no matter how low I tell the new Android app to play my videos it always goes back to "play maximum" and sets it to 200mbps even if the video is 1.6 I have set cell limits, internet limits, manually go in and change the player setting on the file. But the moment I go back into the settings it has changed it's self back causing the video to be unplayable.

    +1 to this

  • MrHazaMrHaza Posts: 1Members

    Same for me, when ever I select quality it just reverts back to 200mbps HD Maximum!!! This happens with all my media, and most of my files are films that are around 2gb in h264 format which my phone used to play fine until the new update...

«1
Sign In or Register to comment.