If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Video Playback Broken in iOS 11

1356711

Comments

  • freediverxfreediverx Posts: 104Members, Plex Pass Plex Pass

    @drdb said:
    Did some experimentation and I've come to the conclusion that this only happens for video with AC-3 encoded audio that has to be transcoded. MP4s with AAC audio work just fine both when direct played or transcoded. I can also confirm that playback does work in Plex Web.

    Same issue here.

  • ndaversandaversa Posts: 52Members, Plex Pass Plex Pass

    note that if you press play and pause after the spinner the video will play

  • DannyboyayyoDannyboyayyo Posts: 27Members, Plex Pass Plex Pass

    @wsavona said:

    @Dannyboyayyo said:
    Just to confirm, Sync'd content works fine right?

    Indeed, it does

    Thank you! Plex is usually the only app I'm concerned about when doing betas.

  • drdbdrdb Posts: 22Members, Plex Pass Plex Pass

    @ndaversa said:
    note that if you press play and pause after the spinner the video will play

    But only the audio from the video.

  • WunderwallyWunderwally Posts: 403Members, Plex Pass Plex Pass

    What formats and containers are you guys using? For me everything works as expected on iOS und tvOS. I transcode all my stuff to an "apple-friendly" format before adding it to plex and so far i have zero problems with Plex and the iOS and tvOS betas.

  • cyberinkcyberink Posts: 26Members, Plex Pass Plex Pass

    For the people who want to revert from TVOS11 to TVOS 10.2.1 ,

    • Download the latest firmware at : https://ipsw.me/AppleTV5,3 (AppleTV5,3_10.2.1_14W585a_Restore.ipsw)
    • Connect your apple tv4 to the machine running itunes with an USB-C cable.
    • Put in the power cable and wait till Itunes finds the device
    • For Mac: OPTION + Click on the “Update” button / For Windows: SHIFT + Click on the ‘Update’ button.
    • Select the downloaded restore .ispw file, and continue the restore process.

    After this update is done, you can re-connect the apple tv to your tv and configure it again.

  • drdbdrdb Posts: 22Members, Plex Pass Plex Pass

    @Wunderwally said:
    What formats and containers are you guys using? For me everything works as expected on iOS und tvOS. I transcode all my stuff to an "apple-friendly" format before adding it to plex and so far i have zero problems with Plex and the iOS and tvOS betas.

    I do the same! However, a friend of mine does not. That's why you're not having any problems. Any media that is direct playable (eg. mp4 w/AAC audio), works perfectly fine, but something like an mkv, will not work.

  • ryanrodioryanrodio Posts: 1Members, Plex Pass Plex Pass

    For tvOS I have been selecting what I want to watch and when it sits there with the spinning lines of death, I will hold the menu button to get dumped back to the Apple TV main screen and then load Plex again. The selected video starts playing so I click pause and then log into my user, unpause, and enjoy.

    EVERY
    SINGLE
    TIME though...

  • freediverxfreediverx Posts: 104Members, Plex Pass Plex Pass

    Easier fix: When video playback stalls at the beginning, tap Pause, and then Play again.

  • drdbdrdb Posts: 22Members, Plex Pass Plex Pass

    @freediverx said:
    Easier fix: When video playback stalls at the beginning, tap Pause, and then Play again.

    As I've already said, this only plays the audio from the video, not the video itself. (at least for me)

  • JoeyDee86JoeyDee86 Posts: 8Members, Plex Pass Plex Pass

    Pause/Play only works on tvOS 11, not iOS11.

  • freediverxfreediverx Posts: 104Members, Plex Pass Plex Pass
    edited June 30

    @JoeyDee86 said:
    Pause/Play only works on tvOS 11, not iOS11.

    Odd, I don't have any issues with movie playback on iOS 11 (iPad Air).

  • JoeyDee86JoeyDee86 Posts: 8Members, Plex Pass Plex Pass

    @freediverx said:

    @JoeyDee86 said:
    Pause/Play only works on tvOS 11, not iOS11.

    Odd, I don't have any issues with movie playback on iOS 11 (iPad Air).

    It’s definitely a transcoding Issue, so it’s not going to impact all videos. I have some that work just fine, but of course the series I’m trying to watch right now doesn’t work unless I’m on my Apple TVs.

  • JoeyDee86JoeyDee86 Posts: 8Members, Plex Pass Plex Pass

    What I’m thinking, but I need to research more, is let’s figure out what it’s trying to convert the audio to, then add that codec to the config file that lists what it doesn’t support? Or remove it from list of supported? I’m not sure how it works.

  • TavorX95TavorX95 Posts: 1Members, Plex Pass Plex Pass

    You also can no longer continue the audio in the background. Hope this gets fixed as well.

  • charles.suh@gmail.comcharles.suh@gmail.com Posts: 1Members, Plex Pass Plex Pass
    edited July 1

    While this doesn't appear to solve the buffering stall issue, this might be a potential workaround if you're having issues playing videos with Dolby Digital audio (AC3).

    1. Copy /Applications/Plex Media Server.app/Contents/Resources/Profiles/iOS.xml to ~/Library/Application Support/Plex Media Server/Profiles/iOS.xml.

      (Note: I'm assuming PMS running on OS X; translate to your appropriate OS. You should create the latter Profiles directory if it doesn't exist.)

    2. Edit your copy of iOS.xml from:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming">
        <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" />
      </VideoProfile>
      

      to:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming"/>
      

    I'm not exactly sure why, but deleting this setting seems to solve that issue.

    Based purely on the name, my impression of the deleted setting is that it causes Plex to provide multichannel AC3 in the stream (in addition to the stereo AAC which is always included.) So this may potentially affect you if you're AirPlaying from your iOS device to your audio receiver capable of decoding Dolby Digital and expecting multichannel sound, but if you're like me (playing videos to built-in speakers or stereo headphones), it shouldn't matter.

    You should also obviously delete your custom iOS.xml when there is actually a fix from Apple or Plex.

  • edward1edward1 Posts: 1Members, Plex Pass Plex Pass

    THANKS charles.suh !!!
    That worked for me, (just had to hit play/pause a few times) and now my iPad + iPhone with IOS11ß can read again from plex server !!
    thumbs up :-)

  • drdbdrdb Posts: 22Members, Plex Pass Plex Pass

    @charles.suh@gmail.com said:
    While this doesn't appear to solve the buffering stall issue, this might be a potential workaround if you're having issues playing videos with Dolby Digital audio (AC3).

    1. Copy /Applications/Plex Media Server.app/Contents/Resources/Profiles/iOS.xml to ~/Library/Application Support/Plex Media Server/Profiles/iOS.xml.

      (Note: I'm assuming PMS running on OS X; translate to your appropriate OS. You should create the latter Profiles directory if it doesn't exist.)

    2. Edit your copy of iOS.xml from:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming">
        <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" />
      </VideoProfile>
      

      to:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming"/>
      

    I'm not exactly sure why, but deleting this setting seems to solve that issue.

    Based purely on the name, my impression of the deleted setting is that it causes Plex to provide multichannel AC3 in the stream (in addition to the stereo AAC which is always included.) So this may potentially affect you if you're AirPlaying from your iOS device to your audio receiver capable of decoding Dolby Digital and expecting multichannel sound, but if you're like me (playing videos to built-in speakers or stereo headphones), it shouldn't matter.

    You should also obviously delete your custom iOS.xml when there is actually a fix from Apple or Plex.

    Thanks! For Windows users, the path to iOS.xml is C:\Program Files (x86)\Plex\Plex Media Server\Resources\Profiles\iOS.xml and it should be moved to %LOCALAPPDATA%\Plex Media Server\Profiles\iOS.xml.

  • SR_PennySR_Penny Posts: 21Members, Plex Pass Plex Pass

    Same issue on b2 (and tvOS 11 b2) :-(

  • bakman1bakman1 Posts: 221Members ✭✭

    Path for synology users:
    /volume1/@appstore/Plex Media Server/Resources/Profiles
    Solution works half for me, sometimes it won't play. Pause>play will trigger play.

Sign In or Register to comment.