If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Video Playback Broken in iOS 11

1246711

Comments

  • drdbdrdb Posts: 22Members, Plex Pass Plex Pass

    Annoying that this can't be fixed client-side.

  • IVNPIVNP Posts: 2Members

    I'm experiencing the similar problem but the weird thing is the exact same file worked fine before. It didn't happened after I update but after paused the video for a while. Then this started happening when I try to resume. I did sort of fix this before by uninstalling the server and client couple month ago. Unfortunately it didn't work this time. I keep getting the same thing with all my videos...

  • nick19872015nick19872015 Posts: 1Members

    Same here. iOS 11 9.7 iPad Pro. Cannot lay AC3 Files. Only plays the audio but not the video. AAC files play audio and visual fine.

  • shapethelolashapethelola Posts: 413Members, Plex Pass Plex Pass

    Same here on iPad air 2 ios 11 public beta.

    As a workaround on iOS 11 I'm currently using safari.

  • jfrankiller3jfrankiller3 Posts: 33Members, Plex Pass Plex Pass

    still broken after todays iOS 11 beta 3 update

  • EdcEdc Posts: 1Members

    @charles.suh@gmail.com said:
    While this doesn't appear to solve the buffering stall issue, this might be a potential workaround if you're having issues playing videos with Dolby Digital audio (AC3).

    1. Copy /Applications/Plex Media Server.app/Contents/Resources/Profiles/iOS.xml to ~/Library/Application Support/Plex Media Server/Profiles/iOS.xml.

      (Note: I'm assuming PMS running on OS X; translate to your appropriate OS. You should create the latter Profiles directory if it doesn't exist.)

    2. Edit your copy of iOS.xml from:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming">
        <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" />
      </VideoProfile>
      

      to:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming"/>
      

    I'm not exactly sure why, but deleting this setting seems to solve that issue.

    Based purely on the name, my impression of the deleted setting is that it causes Plex to provide multichannel AC3 in the stream (in addition to the stereo AAC which is always included.) So this may potentially affect you if you're AirPlaying from your iOS device to your audio receiver capable of decoding Dolby Digital and expecting multichannel sound, but if you're like me (playing videos to built-in speakers or stereo headphones), it shouldn't matter.

    You should also obviously delete your custom iOS.xml when there is actually a fix from Apple or Plex.

    Thanks it works well. Path for Linux /usr/lib/plexmediaserver/Resources/Profiles

  • scream88scream88 Posts: 17Validating, Plex Pass Plex Pass

    @charles.suh@gmail.com said:
    While this doesn't appear to solve the buffering stall issue, this might be a potential workaround if you're having issues playing videos with Dolby Digital audio (AC3).

    1. Copy /Applications/Plex Media Server.app/Contents/Resources/Profiles/iOS.xml to ~/Library/Application Support/Plex Media Server/Profiles/iOS.xml.

      (Note: I'm assuming PMS running on OS X; translate to your appropriate OS. You should create the latter Profiles directory if it doesn't exist.)

    2. Edit your copy of iOS.xml from:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming">
        <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" />
      </VideoProfile>
      

      to:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming"/>
      

    I'm not exactly sure why, but deleting this setting seems to solve that issue.

    Based purely on the name, my impression of the deleted setting is that it causes Plex to provide multichannel AC3 in the stream (in addition to the stereo AAC which is always included.) So this may potentially affect you if you're AirPlaying from your iOS device to your audio receiver capable of decoding Dolby Digital and expecting multichannel sound, but if you're like me (playing videos to built-in speakers or stereo headphones), it shouldn't matter.

    You should also obviously delete your custom iOS.xml when there is actually a fix from Apple or Plex.

    It works also for me in Ubuntu 16.04 LTS.

    @sergiou87 It look like the issue has something to wo with Multi Channel Audio on iOS. Maybe this could be a hint.

  • sergiou87sergiou87 Plex for iOS Developer SpainPosts: 609Members, Plex Employee, Plex Pass, Plex Ninja Plex Employee

    Thanks guys! We've seen some improvements in beta 3, so I assume there was something wrong on Apple's end too.

  • scream88scream88 Posts: 17Validating, Plex Pass Plex Pass

    @sergiou87 said:
    Thanks guys! We've seen some improvements in beta 3, so I assume there was something wrong on Apple's end too.

    So any ETA when a update should resolve this issue?

  • MwC_TrexxMwC_Trexx Posts: 168Members, Plex Pass Plex Pass
    edited July 11

    @charles.suh@gmail.com said:
    While this doesn't appear to solve the buffering stall issue, this might be a potential workaround if you're having issues playing videos with Dolby Digital audio (AC3).

    1. Copy /Applications/Plex Media Server.app/Contents/Resources/Profiles/iOS.xml to ~/Library/Application Support/Plex Media Server/Profiles/iOS.xml.

      (Note: I'm assuming PMS running on OS X; translate to your appropriate OS. You should create the latter Profiles directory if it doesn't exist.)

    2. Edit your copy of iOS.xml from:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming">
        <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" />
      </VideoProfile>
      

      to:

      <VideoProfile protocol="hls" container="mpegts" codec="h264" audioCodec="aac,mp3" context="streaming"/>
      

    I'm not exactly sure why, but deleting this setting seems to solve that issue.

    Based purely on the name, my impression of the deleted setting is that it causes Plex to provide multichannel AC3 in the stream (in addition to the stereo AAC which is always included.) So this may potentially affect you if you're AirPlaying from your iOS device to your audio receiver capable of decoding Dolby Digital and expecting multichannel sound, but if you're like me (playing videos to built-in speakers or stereo headphones), it shouldn't matter.

    You should also obviously delete your custom iOS.xml when there is actually a fix from Apple or Plex.

    Thank you so much for this interim fix. My iPad Pro 9.7 w/IOS 11b3 is working again.

    PMS: QNAP x73 running QTS 4.3.3.

    File Location was: /share/CACHEDEV1_DATA/.qpkg/PlexMediaServer/Resources/Profiles/IOS.xml

  • NinjaSverreNinjaSverre Posts: 1Members, Plex Pass Plex Pass

    I copied the file, removed the part, saved and restarted PMS. No joy, but now instead of getting just sound, I'm presented with an error message. And video that previously was working (stored as .avi, unsure of codec) didn't play.

  • drdbdrdb Posts: 22Members, Plex Pass Plex Pass

    @NinjaSverre said:
    I copied the file, removed the part, saved and restarted PMS. No joy, but now instead of getting just sound, I'm presented with an error message. And video that previously was working (stored as .avi, unsure of codec) didn't play.

    Have you tried playing an MKV?

  • my.testmy.test Posts: 9Members, Plex Pass Plex Pass

    I copied the file as you said, removed the part
    <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" /> </VideoProfile>
    saved and restarted PMS. The Series with AC3 Sound working again on iPad Air2 with iOS 11 (15A5318g).
    Thanks a lot :) :)

  • NevidicusNevidicus Posts: 1Members, Plex Pass Plex Pass

    This worked nicely. Thanks!

  • david_szymanskidavid_szymanski Posts: 2Members

    Yep! Same problem here on iOS 11 beta.

  • peterlinpeterlin Posts: 2Members, Plex Pass Plex Pass
    edited July 14

    @NinjaSverre said:
    I copied the file, removed the part, saved and restarted PMS. No joy, but now instead of getting just sound, I'm presented with an error message. And video that previously was working (stored as .avi, unsure of codec) didn't play.

    Not sure why some people are having success, but I'm seeing the error message after removing the HlsExtraMultiChannelAudioStream setting too, so I tried tinkering with the settings without deleting that entire line, and I was able to get the videos to play making the following change:

    from:
    <Setting name="HlsExtraMultiChannelAudioStream" value="ac3" />
    to
    <Setting name="HlsExtraMultiChannelAudioStream" value="mp3" />

    The strange thing is that if I pause and resume, sometimes it will be audio only again. However, I can get video again by playing a different video and then switching back to the one I was watching.

  • eddicteddict Posts: 1Members, Plex Pass Plex Pass

    Just installed beta 2, problem stays unchanged for me. Video playback broken on some, but audio is fine.

  • vortex0007vortex0007 Posts: 13Members, Plex Pass Plex Pass

    Developer Beta 3 and still issues persist. Unable to use the iOS app at all - have to use Safari and watch directly from a web browser.

  • ohiocitydaveohiocitydave Posts: 7Members, Plex Pass Plex Pass

    I have this same issue with iOS 11 on my iPhone 7 Plus and iPad Air 2. The interesting thing is that it only affects one user account. I have both an admin account and an “authorized user” account and the admin account can play all of the same files where the authorized user account only sees a movie poster during playback.

Sign In or Register to comment.