If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

How to set up Plex to work with PIA VPN?

WermhattWermhatt Posts: 3Members, Plex Pass Plex Pass

Hi,

I am really struggling to find a solution to get this to work, so any help will be greatly appreciated.

I want to to be able to remotely use Plex, which is based on my Mac without having to turn my VPN off. Plex says the server is remotely accessible but it isn't.

I am using:
Mac - El Capitan
Apple Airport Extreme router
PIA VPN

Is this possible? If so, I could really do with an ELI5 solution.

Tagged:

Answers

  • SE56SE56 Posts: 1,747Members ✭✭✭✭

    @Wermhatt said:
    Hi,

    I am really struggling to find a solution to get this to work, so any help will be greatly appreciated.

    I want to to be able to remotely use Plex, which is based on my Mac without having to turn my VPN off. Plex says the server is remotely accessible but it isn't.

    I am using:
    Mac - El Capitan
    Apple Airport Extreme router
    PIA VPN

    Is this possible? If so, I could really do with an ELI5 solution.

    I believe if you want it to work Universally in your network you must set it up in a compliant router. The airport will not do the job.

    TV:(1). LG 65UB950T UHD Smart TV, (2). Hisense 50K3300UW.Receiver Onkyo TX-NR646 Network Receiver, ARC configured. : Blu- ray Player: Playstation PS3.Server: iMac Late 2015, 32Gb Ram, 3.2GHz Intel i5 Skylake processors.Storage: 3 WD External USB3 HDD. Devices: 2 iPad Air 2 connected with AC Wifi Dual Band. Network: Gigabite Ethernet hardwired , 5 outlets with Cat 6 and 2 Ethernet switches, Full Duplex, AVB mode enabled Remotes: Onkyo ios app, Plex ios, Onkymote, LG Magic remote.Speakers: Bowers and Wilkins Floor Standing Fronts and Mordaunt-Short Genie, Centre, 200W Powered Sub & 4 Satellite Surrounds. Configured for 7.1 Channels.

  • TutuTutu Posts: 3Members, Plex Pass Plex Pass

    You can do it locally on your mac without changing your router using pf anchors.

    In PIA - Look at directions to enable port forwarding (must use assigned servers).

    On your Mac:

    Using terminal create a file in /etc/pf.anchors/plex.pia. run the following command:

    sudo nano /etc/pf.anchors/plex.pia

    in nano, copy the following:

    replace MYPORT, with the PIA forwarded port

    replace en0 with whatever your local interface is

    replace utun1 with whatever interface PIA is mapped to. Use ifconfig if you dont know

    rdr pass on en0 inet proto tcp from any to any port MYPORT -> 127.0.0.1 port 32400
    rdr pass on utun1 inet proto tcp from any to any port MYPORT -> 127.0.0.1 port 32400

    Create a pf config file by using the following command:

    sudo nano /etc/pf.plex.conf

    Copy this into it:

    rdr-anchor "my-plex"
    load anchor "my-plex" from "/etc/pf.anchors/my.plex.vpn.forward"

    Start pf by running:

    sudo pfctl -ef /etc/pf.plex.conf

    In Plex:

    Go to settings -> server -> remote access and manually put in whatever your PIA forwarded port is (same as MYPORT above).

    Hope this helps.

  • Sean_CezSean_Cez Posts: 2Members

    @Tutu thank you so much for this, it feels like the closest I've been to solving this issue. I'm getting an error when I try to start pf at the end.

    No ALTQ support in kernel
    ALTQ related functions disabled
    pfctl: /etc/pf.anchors/my.plex.vpn.forward: No such file or directory
    pfctl: cannot open the main config file!: No such file or directory
    pfctl: Syntax error in config file: pf rules not loaded
    pfctl: load anchors

    I was wondering if you might be able to help push me in the right direction on how I can correct it.

  • Sean_CezSean_Cez Posts: 2Members

    Oh and it had this before the other lines I sent

    pfctl: Use of -f option, could result in flushing of rules
    present in the main ruleset added by the system at startup.
    See /etc/pf.conf for further details.

Sign In or Register to comment.