If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[BUG] Chopping Playback / Buffering Towards End of File

GlynnRyanGlynnRyan Posts: 26Members, Plex Pass Plex Pass

Has anyone else been experiencing choppy / buffering playback towards the end of a file? Around the last 10 - 15 seconds recently?
Nothing on my Plex setup has changed or the Apple TV I use to watch my content on.

My Apple TV is connected via CAT6 LAN to my Windows PMS on a gigabit LAN throughout the house. This issue has also only started happening the last few days.

Any help would be much appreciated.

Server:
Dell Optiplex 7010
CPU: i7-3770 | RAM: 20GB DDR3 1600Mhz | OS: Windows 10 Pro 64-Bit |
Users: 7 (2 Local, 5 Remote) |
Connection: 100Mbps Download / 50 Mbps Upload |
Most Concurrent Streams: 5

Additional PMS Services:
PlexPy | Ombi | Sonar | Radarr | Jackett

B)
image

Best Answer

«1

Answers

  • BKSteveBKSteve Posts: 40Members, Plex Pass Plex Pass

    Yes, I'm having a similar problem.
    But it's not the last 10 - 15 second, it's in the last minutes just like it before. In fact I think it's specifically 2 minutes from the last episode that I watched.

    Plex did you reintroduce or deprecate the code that fixed this before?

    I'm also connect via LAN, AT4 on 1.11, Server Version 1.7.2.3878. I can't recall when this started again, whether it was with the updated to 1.11 or 1.7.2.3878 as I update both around the same time.

    But it seems to hit a time point then start to glitch the playback a couple of times then totally stops playing going to the screen after completion of playback. But it didn't complete.

    It doesn't happen on other clients Plex Kodi 102 or PMP 1.3.3 on windows.

    PlexServer on Syno DS 412+, Plex clients on AppleTV4, Cubox-i4pro (OpenELEC, Plex for Kodi), iOS, windows

  • h00ligan76h00ligan76 Posts: 150Members, Plex Pass Plex Pass
    edited June 12

    Same issue here. Starts to buffer every second or so. Then it stops the file. Only happening on appletv. I also would put it at two minutes.

  • whomemcwhomemc Posts: 2Members, Plex Pass Plex Pass
    edited June 13

    Same issue. It seems to only occur on our Apple TVs and at the end of any episode around the final minute or so.
    Plex Server 1.7.2.3878
    ATV 1.11

  • GlynnRyanGlynnRyan Posts: 26Members, Plex Pass Plex Pass

    This seems to have been the fix for me too. I changed the quality settings to the highest quality possible and made sure not to select the "Auto Adjust" option and everything seems to have returned to normal.

    @whomemc said:
    I've been messing around with my settings and may have found a fix.

    I recently enabled Settings - Video Quality - Auto Adjust Quality. I have since disabled and it appears to have fixed the issue.

    Server:
    Dell Optiplex 7010
    CPU: i7-3770 | RAM: 20GB DDR3 1600Mhz | OS: Windows 10 Pro 64-Bit |
    Users: 7 (2 Local, 5 Remote) |
    Connection: 100Mbps Download / 50 Mbps Upload |
    Most Concurrent Streams: 5

    Additional PMS Services:
    PlexPy | Ombi | Sonar | Radarr | Jackett

    B)
    image

  • h00ligan76h00ligan76 Posts: 150Members, Plex Pass Plex Pass

    Not a fix for me.

  • BKSteveBKSteve Posts: 40Members, Plex Pass Plex Pass

    Disabled Auto Adjust Quality on the ATV4 settings and problem resolved

    PlexServer on Syno DS 412+, Plex clients on AppleTV4, Cubox-i4pro (OpenELEC, Plex for Kodi), iOS, windows

  • h00ligan76h00ligan76 Posts: 150Members, Plex Pass Plex Pass
    edited June 18

    Once again this is not an answer for me. It's the same issue. So I did some checking and here's the deal. Direct stream seems broken. That's where the problem is. The auto off setting may work to stop it chopping the ending of files but the bottom line is I cannot play a mkv file to the Apple TV without transcoding video and audio both.

    If I set auto to off and I set the individual file to convert automatically it runs smoothly. But it shows transcoding video h264 to h264 and transcoding audio ac3 to ac3. If the file is set to original quality which is the only option for direct stream then it just chop chop chops away.

    Now before anyone asks no it's not my wireless connection. I may on an ac network and can stream smoothly to many other devices. The appletv INTERNET speed is 170mbps so there's is no speed issue, I should be able to play twenty streams minimum to the same device.

    As far as I am concerned plex on the appletv is still drastically broken and it make me sad there's is an accepted answer in this post hat simply doesn't cure the problems at all. If you check your server you'll see you guys are transcoding everything and that's not something that should be necessary.

    Bring back direct play and direct stream settings and make the appletv work again without having it transcode everything. This is ridiculous. It was working great and was completely broken and not one dev seems to have even acknowledged this issue. There no longer seems to be a way to even set it to transcode audio only. That's a huge take out.

    One final note too - it's very poor ui design to have choices for individual files which aren't present globally.

    Look under settings - quality - and you see original or 20. In individual files you have a convert automatically settings.

    At the end of the day the Devs have broken what was great. Mixed up the UI, taken away features, and generally made atv plex crappy.

  • ecantrellecantrell Posts: 74Members, Plex Pass Plex Pass

    Hmm... will try this to see if this resolve my issue which acted up with few mins to go...

  • ecantrellecantrell Posts: 74Members, Plex Pass Plex Pass

    @ecantrell said:
    Hmm... will try this to see if this resolve my issue which acted up with few mins to go...

    Confirmed... disabling the auto adjust quality worked for me.

  • h00ligan76h00ligan76 Posts: 150Members, Plex Pass Plex Pass

    We should probably confirm if it's fixing stuttering issues or the end of file playback issue or both.

    Also. I feel like it's a no brainer that setting plex to transcode everything fixes issues. The larger question is why direct stream / play is not working.

  • BadgerdogBadgerdog Posts: 206Members, Plex Pass Plex Pass

    @whomemc said:
    I've been messing around with my settings and may have found a fix.

    I recently enabled Settings - Video Quality - Auto Adjust Quality. I have since disabled and it appears to have fixed the issue.

    I had to do the same thing... working fine now with it OFF ...

    Regards,
    Doug

    Lifetime Plex Member
    Running Plex Pass Server Version 1.9.4.4325
    Running Plex Client 1.17.1 on IOS 11 for Apple TV and Apple TV 4k

  • twilsoncotwilsonco Posts: 9Members, Plex Pass Plex Pass

    @BKSteve said:
    But it seems to hit a time point then start to glitch the playback a couple of times then totally stops playing going to the screen after completion of playback. But it didn't complete.

    I'm having the exact issue you described. It occurs with Plex for iPhone and Apple TV 4, but NOT through the Plex web interface in Safari.

    I've confirmed several times that videos for which this stutter-crash occurs play completely without any problem when played directly on my Computer, iPhone, or with the Plex web interface.
    Therefore I think it's a problem with the iOS/Apple TV apps.
    Where can we go for actual support?
    As a paid user, it seems insufficient that the highest level of support is a user forum.

  • twilsoncotwilsonco Posts: 9Members, Plex Pass Plex Pass

    @whomemc said:
    I recently enabled Settings - Video Quality - Auto Adjust Quality. I have since disabled and it appears to have fixed the issue.

    Worked for my Apple TV 4 and multiple iOS devices. Still, not really a fix...

  • evanmorrisevanmorris Posts: 9Members, Plex Pass Plex Pass

    @whomemc said:
    I've been messing around with my settings and may have found a fix.

    I recently enabled Settings - Video Quality - Auto Adjust Quality. I have since disabled and it appears to have fixed the issue.

    Worked for me too. Definitely a bug that Plex needs to fix.

  • Mongoose69Mongoose69 Posts: 26Members, Plex Pass Plex Pass
    edited August 27

    @whomemc said:
    Same issue. It seems to only occur on our Apple TVs and at the end of any episode around the final minute or so.
    Plex Server 1.7.2.3878
    ATV 1.11

    Same here, tho not for everything.

    I found a different workaround.
    If I adjust the quality of the episode playing down one level, it doesn't happen.
    I'm using the latest PMS on Synology DS216+II NAS and the latest ATV version of Plex

  • BouncinDaveBouncinDave Posts: 13Members, Plex Pass Plex Pass

    Got the same issue on my AppleTV too. Glad to see its not just me!

  • BouncinDaveBouncinDave Posts: 13Members, Plex Pass Plex Pass

    In fact, I have the same issue on my iPad too.
    I tried to watch the last few minutes after the appleTV had failed, and the iPad did exactly the same thing.

  • europorsche914europorsche914 Posts: 2Members, Plex Pass Plex Pass

    Agreed this is unacceptable. I do not even see the setting to disable "auto adjust quality" in any of the settings on Apple TV to disable this. Just sent my logs to plex, 09/05/17 at 6:45pm CT...

  • kazibolekazibole Posts: 2Members, Plex Pass Plex Pass

    I am also experiencing this issue (stuttering near the end of a direct stream). I probably have the "auto adjust quality" option turned on, will disable and see.

«1
Sign In or Register to comment.