Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server exit signal 10

SystemSystem Posts: 209 Plex Employee
This discussion was created from comments split from: Plex Media Scanner exited on signal 11.

Comments

  • ebikeebike Members, Plex Pass Posts: 234 Plex Pass

    Slightly related:
    I have been running plex version: plexmediaserver-plexpass-1.7.3.3937 in a jail and found plex server stopped with a Signal 10 error, does anyone know what that is?

    Plex Media Server: 1.7.4 on FreeNAS-11 16G ECC RAM, Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, 3*2TB RaidZ1
    Client1: Odroid-XU3 running ArchLinuxARM and Kodi with plexbmc plugin.(Will be changed to PMP eventually)
    Client2: Sony laptop (Core2 Duo) running Arch and Plex Media Player (git version compiled on laptop)
    Client3: Nvidia Shield 2017 running Android TV Plex app .. my main lounge TV client.

  • shark2kshark2k Members, Plex Pass Posts: 119 Plex Pass

    @ebike said:
    Slightly related:
    I have been running plex version: plexmediaserver-plexpass-1.7.3.3937 in a jail and found plex server stopped with a Signal 10 error, does anyone know what that is?

    See: https://forums.plex.tv/discussion/264669/signal-10-on-freenas-9-10-2

    -Shark2k

  • ebikeebike Members, Plex Pass Posts: 234 Plex Pass
    edited June 16

    That doesn't help at all. I have the latest version. Also, it is trying to watch LiveTV that is crashing the server ..
    Hopefully someone has a fix sometime soon ...

    Update: It Seems it is only my Android TV Client (Nvidia Shield) that is crashing the server on LiveTV, my IOS phone plays tv fine, well at least after a long delay for transcoding to buffer ...

    This release has other issues though, videos don't play any more on my phone, only sound ....

    Plex Media Server: 1.7.4 on FreeNAS-11 16G ECC RAM, Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, 3*2TB RaidZ1
    Client1: Odroid-XU3 running ArchLinuxARM and Kodi with plexbmc plugin.(Will be changed to PMP eventually)
    Client2: Sony laptop (Core2 Duo) running Arch and Plex Media Player (git version compiled on laptop)
    Client3: Nvidia Shield 2017 running Android TV Plex app .. my main lounge TV client.

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,143 Plex Team Member

    @ebike I am splitting your issue into a separate topic as it is not related to the old scanner issue.

    You will shortly see a new topic raised in same forum with your issue

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
  • shark2kshark2k Members, Plex Pass Posts: 119 Plex Pass

    @ebike, well if you are using the latest FreeBSD/FreenNAS I didn't know that as you didn't mention that in your post. I, however, tried to be helpful to you since there was a post regarding the Signal 10 issue, albeit dealing with it on an older version of FreeBSD and a reason why it wouldn't be looked at. Also, because you didn't mention which version of FreeBSD/FreeNAS you were using, I was pointing that thread out because it was mentioned that the older versions are to hard to debug for the issue (the last post in it).

    As @sa2000 said, your issue is different so he's splitting it into a separate topic.

    Some advice for when asking for help. Give as much detail as possible, including the version of the OS (and in this case jail) you are using as it will help avoid getting non-helpful answers.

    -Shark2k

  • ebikeebike Members, Plex Pass Posts: 234 Plex Pass
    edited June 18

    @shark2k If you had read my signature, you would have seen the FreeNAS version I was running at the time :)
    It was (9.10.1), I am now running 11 (as per the updated signature) It would be helpful if you read the entire post, before you admonish people ;)

    I havn't done enough testing yet on Ver 11 to see if it is still an issue.

    Plex Media Server: 1.7.4 on FreeNAS-11 16G ECC RAM, Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, 3*2TB RaidZ1
    Client1: Odroid-XU3 running ArchLinuxARM and Kodi with plexbmc plugin.(Will be changed to PMP eventually)
    Client2: Sony laptop (Core2 Duo) running Arch and Plex Media Player (git version compiled on laptop)
    Client3: Nvidia Shield 2017 running Android TV Plex app .. my main lounge TV client.

  • JeffCrumJeffCrum Members, Plex Pass Posts: 94 Plex Pass

    Slow down skippy. It is not uncommon for people to fly through siggys as they often have info about the poster's dog/wife/kids/etc. Yes, in your case, that wasn't what was in your siggy. But, come on!

    If you are posting an issue, post all facts about the issue so people can try to help.

  • ebikeebike Members, Plex Pass Posts: 234 Plex Pass

    Then what is the point of a signature with all your setup details --- I thought that was the whole point of them, especially as plex recommends you do this when you post ..

    I also don't see what the point is with repeating the information "again" that is in the sig. .. and I have tried to put in all the information possible in relation to the issue. That is why I edited my post and gave additional information on the issue.

    But hey, you can't please everyone ....

    Plex Media Server: 1.7.4 on FreeNAS-11 16G ECC RAM, Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, 3*2TB RaidZ1
    Client1: Odroid-XU3 running ArchLinuxARM and Kodi with plexbmc plugin.(Will be changed to PMP eventually)
    Client2: Sony laptop (Core2 Duo) running Arch and Plex Media Player (git version compiled on laptop)
    Client3: Nvidia Shield 2017 running Android TV Plex app .. my main lounge TV client.

  • JeffCrumJeffCrum Members, Plex Pass Posts: 94 Plex Pass

    Dude, do it how you want then.

  • ebikeebike Members, Plex Pass Posts: 234 Plex Pass
    edited June 25

    Update:
    The issue seems to have gone in FreeNAS11, AndroidTV plex no longer crashes the server ..

    Plex Media Server: 1.7.4 on FreeNAS-11 16G ECC RAM, Intel(R) Core(TM) i3-6100 CPU @ 3.70GHz, 3*2TB RaidZ1
    Client1: Odroid-XU3 running ArchLinuxARM and Kodi with plexbmc plugin.(Will be changed to PMP eventually)
    Client2: Sony laptop (Core2 Duo) running Arch and Plex Media Player (git version compiled on laptop)
    Client3: Nvidia Shield 2017 running Android TV Plex app .. my main lounge TV client.

  • KJKingJKJKingJ Members, Plex Pass Posts: 53 Plex Pass

    I am seeing this issue on FreeNAS-11.0-U2. About a month or so back, I created a jail and installed the PMS Plex Pass port. However, periodically it crashes with "exited on signal 10" and I have to restart the jail.

    On 1.7.x this seemed to happen about once a week. However, since upgrading to 1.8.0 this seems to be happening about once a day.

    Is there anything I can do to track down the cause of this?

  • sa2000sa2000 Members, Plex Pass, Plex Ninja, Plex Team Member Posts: 28,143 Plex Team Member

    @KJKingJ said:
    I am seeing this issue on FreeNAS-11.0-U2. About a month or so back, I created a jail and installed the PMS Plex Pass port. However, periodically it crashes with "exited on signal 10" and I have to restart the jail.

    On 1.7.x this seemed to happen about once a week. However, since upgrading to 1.8.0 this seems to be happening about once a day.

    Is there anything I can do to track down the cause of this?

    Starting point to investigate: Attach here the Zipped Plex Media Server Logs with debug logging enabled in advance and logs captured on restart after a crash

    See
    https://support.plex.tv/hc/en-us/articles/201643703-Reporting-issues-with-Plex-Media-Server
    https://support.plex.tv/hc/en-us/articles/200250417-Plex-Media-Server-Log-Files

    Help given free on forums.            Fee-Based Personal Support & Help.        

    _______________________________________________________________________________________

    Plex Support Information              Troubleshooting               FAQs

    Plex Media Server:   Reporting Issues        Plex Web App: Debug Log    Plex Apps: Support pages and Logs    Logs: All Logs

    For list of 3rd party programs and malware / adware crashing Plex Media Server and mswsock.dll on windows, see Repeated crashing of Plex Media Server on Windows
     
Sign In or Register to comment.