Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

[Bugs] Photo Uploader loses Library/Album selection and gets stuck in an upload loop

eldon.mcguinnesseldon.mcguinness Members, Plex Pass Posts: 134 Plex Pass
edited June 17 in Android (mobile)

I recently decided to give the photo uploader feature a go, since I'm getting off of Amazon's services which included an auto uploader, and it has been a bit of a headache. The biggest issue is the mobile app seems to "lose" its settings from time to time, which results in the auto-uploader no longer auto uploading. As one can imagine, since this should happen seemlessly in the background, is a bit of an annoyance.

Andoid Client: 6.0.1.523
Android OS: 6.0.1

Server: 1.5.6.3790

  • I also tried the PlexPass Server versions up until I got bit by the latest transcoding bug and downgraded to the Public version.

Loses Library/Album Selection
Below I have included a few images to show this and a small video to document this issue.

This is the error you are given when you click the Camera Upload button in the Plex menu.
https://us.v-cdn.net/6025034/uploads/editor/fh/t0dijhhb65la.png

From there, if you try to pick an album, you are given an empty list of albums. When it should clearly be populated.
https://us.v-cdn.net/6025034/uploads/editor/3y/atps122h5y8s.png

After going all the way back to the main menu and back into the camera upload section you can then pick an album again.
https://us.v-cdn.net/6025034/uploads/editor/jd/o4woif2ua2ec.png

Upload Looping
The second issue is that the Android client frequently gets stuck in an upload loop where it repeatedly tries to upload an image over and over to no avail. Now, this is very annoying on two fronts. The first being that uploads are halted if that image happens to have other images that would be uploaded after it. The second being that WiFi (or Mobile data if you enable it) are hammered as it seems the file is repeated uploaded and chewing threw battery power. I have attached an image showing my battery usage once I came in for the day and set the phone to upload about 30 images, no videos, from my ZTE ZMAX PRO.
https://us.v-cdn.net/6025034/uploads/editor/ed/0y7wdv65mz1n.png

Additionally, here is a nice video of the foolery that photo upload is giving. It shows both the app losing the Library/Album Selection and Looping uploads.
https://nextcloud.progressivethink.in/index.php/s/zfblWv6PkAnhC56

I have seen both issues on multiple devices and have gone so far as to try to completely remove the application from the devices and reinstall it with the issues prevailing.

I was posting in the following thread, but noticed that it is marked as answered, when the issue was clearly not resolved.
https://forums.plex.tv/discussion/257249/plex-camera-upload-losing-library-album-selection#latest

Answers

  • gmfvisorgmfvisor Members, Plex Pass Posts: 4 Plex Pass

    Same here... for ages. Looking forward to a fix.

  • eldon.mcguinnesseldon.mcguinness Members, Plex Pass Posts: 134 Plex Pass

    I wonder if any Plex employees would care to make an official comment on this, is it a "Known Issue" on their side? Is there a resolution on the horizon?

Sign In or Register to comment.