Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to Cast Videos Suddenly

reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass

I've run into an issue where I am no longer able to cast from my TV Shows library to Chromecast. This started about three days ago. I have tried casting from two different Android phones and from the Chrome browser on my laptop. Each time, the TV briefly flashes 'Unable to cast' and returns to the media preview. I was able to cast from my music and movies libraries successfully, but no TV shows will work. The videos will play on Plex if it is not casting.

I have attempted the following: verify Plex is updated on the server, restart Plex service, restart server, reinstall Plex app on phone, factory reset Chromecast, and delete and recreate the TV Shows library. There has been no change in being unable to play the videos.

Does anyone have an idea as to what might be going on? I have not made any changes to my configurations prior to this happening.

Best Answer

  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass
    Accepted Answer

    Well, the problem seems to have finally resolved itself. The only thing that changed is that I updated my Linux CentOS and now things play normally. I guess it was a Linux problem. Not sure that's what was causing rayrluff's problem, but I'm good now!

Answers

  • rayrluffrayrluff Members, Plex Pass Posts: 29 Plex Pass

    I have had exactly the same problem also starting about 3 days ago.

  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass

    @rayrluff said:
    I have had exactly the same problem also starting about 3 days ago.

    Glad it's not just me. Hopefully this issue will be addressed soon.

  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass

    I have found additional information!

    First off, Plex just had an update for the server, but it didn't fix the problem. Second, the problem seems to be format specific: I have tested .avi and .mp4 files and they failed to play, but m4v and mkv files work fine!

    What might have changed to make certain formats not work?

  • ACiDxCHRiSTACiDxCHRiST Members, Plex Pass Posts: 2 Plex Pass

    What codec is the audio encoded in for the files that fail to cast.

    I don't have a Chromecast but I have Google Fiber and the TV boxes that come with Google Fiber have the Chromecast software built in. I have been having the exact same results when I try to cast a file with AC3 audio. Files with DTS, FLAC, or AAC play fine. My whole library is .mkv so I can't try a different file format right now.

    Here is a link to the thread I posted about my issue: https://forums.plex.tv/discussion/276991/google-fiber-tv-box-unable-to-cast-video-with-ac3-dolby-audio-debug-logs-included

  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass

    @ACiDxCHRiST said:
    What codec is the audio encoded in for the files that fail to cast.

    I don't have a Chromecast but I have Google Fiber and the TV boxes that come with Google Fiber have the Chromecast software built in. I have been having the exact same results when I try to cast a file with AC3 audio. Files with DTS, FLAC, or AAC play fine. My whole library is .mkv so I can't try a different file format right now.

    Here is a link to the thread I posted about my issue: https://forums.plex.tv/discussion/276991/google-fiber-tv-box-unable-to-cast-video-with-ac3-dolby-audio-debug-logs-included

    Following up on your lead, I looked at the codecs of several .avi videos and I found that most of mine use the MP3 codec. Others use A3C and some use AAC. None of them will play, but I have some .M4V files that play just fine with the AAC codec. I'm not seeing anything to link this particular issue to the audio codec.

    Thanks for your input and good luck with your issue!

  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass

    My latest troubleshooting led me to look at my media server folders. I found that Plex had read and execute permissions, so I added write permissions too. I saw a post about trying to move the transcoding location, so I created a folder in the same location as the other media folders and pointed Plex to it.

    Still no change to the playback issue. I'm hoping I won't have to convert all my files to m4v. That will take awhile...

  • BigWheelBigWheel Members, Plex Employee, Plex Pass, Plex Ninja Posts: 9,589 Plex Employee
    edited June 24

    Can your servers not transcode? are there any transcoder errors in server log?

    Logs > https://support.plex.tv/hc/en-us/articles/201869908-Log-Files
  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass

    @BigWheel said:
    Can your servers not transcode? are there any transcoder errors in server log?

    The only errors in reference to playing a file that I found are as follows:

    ERROR - Throttle: timed out trying to read chunk 2
    DEBUG - Using existing transcode session.

    WARN - [Chromecast] [Player] Media element error code: 2
    ERROR - [Chromecast] Playback error: There was a problem playing this item.
    INFO - [Chromecast] Received custom message: {"type":"STOP"}

  • reikozunakenreikozunaken Members, Plex Pass Posts: 7 Plex Pass
    Accepted Answer

    Well, the problem seems to have finally resolved itself. The only thing that changed is that I updated my Linux CentOS and now things play normally. I guess it was a Linux problem. Not sure that's what was causing rayrluff's problem, but I'm good now!

Sign In or Register to comment.