If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex on Android TV not respecting Android.xml with latest update.

yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass

Hi, I used to be able to force transcode all my files by using a modified Android.xml, but since the last update Plex doesnt respect my Android.xml and instead direct plays everything. I havent made any changes on the server what so ever.

Best Answer

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass
    Accepted Answer

    Newest Plex-app for Android TV fixed all the previous issues. There is no longer any need for a modified Android.xml.

Answers

  • teshiburuteshiburu Posts: 398Members, Plex Pass Plex Pass

    any reason why you want to force transcoding? if the client can direct play why not let it?

    3.63 Years of non repeating media

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass

    @teshiburu said:
    any reason why you want to force transcoding? if the client can direct play why not let it?

    Yeah, I'm using a Mi Box that is known to have trouble playing anything with AC3, so I modified my Android.xml to force transcoding of everything, which has worked until now.

  • teshiburuteshiburu Posts: 398Members, Plex Pass Plex Pass

    ahhhh ok fair enough - you should also be able to disable direct play and direct stream in the settings in the plex app for the mi box :) rather than the android.xml

    3.63 Years of non repeating media

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass

    Yeah, you'd think that was possible, but not even thats enough, you have to modify the Android.xml, and then disable direct play/direct stream. Only thing that works, but as I said, last update broke it so now everything direct plays. I've downgraded to a previous version so now everything works. at least for now.

  • abixbgabixbg Posts: 9Members ✭✭

    Workaround for Philips DTS bitrate limitation also depends on Android.xml...

  • mmmooommmooo Posts: 13Members, Plex Pass Plex Pass

    I'm doing the same w/ the android xml, its worse then ignoring android.xml, and technically it isn't even. Regardless of what you have the 'direct play' option set to (auto, force or disable), the client passes:

    "VERBOSE - * directPlay => 1"

    The reason your android.xml (and mine) previous fix isn't working is that the new version of the app now passes:

    add-limitation(scope=videoCodec&scopeName=h264&type=upperBound&name=video.level&value=51)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.width&value=3840&replace=true)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.height&value=2160&replace=true)+add-limitation(scope=videoAudioCodec&scopeName=aac&type=upperBound&name=audio.channels&value=6&replace=true)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=mp3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=ac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=eac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=dca)+add-transcode-target(type=subtitleProfile&context=streaming&protocol=http&container=mkv&subtitleCodec=srt)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=mpeg2video)+add-limitation(scope=videoCodec&scopeName=hevc&type=Match&name=video.profile&list=main|main 10)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=hevc)+add-limitation(scope=videoCodec&scopeName=*&type=NotMatch&name=video.anamorphic&value=999&replace=true)

    overriding all sorts of limitations. I haven't found a consistent way around it, but I also want to force transcoding, but each time the server's decision becomes 'direct play'.

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass

    @mmmooo said:
    I'm doing the same w/ the android xml, its worse then ignoring android.xml, and technically it isn't even. Regardless of what you have the 'direct play' option set to (auto, force or disable), the client passes:

    "VERBOSE - * directPlay => 1"

    The reason your android.xml (and mine) previous fix isn't working is that the new version of the app now passes:

    add-limitation(scope=videoCodec&scopeName=h264&type=upperBound&name=video.level&value=51)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.width&value=3840&replace=true)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.height&value=2160&replace=true)+add-limitation(scope=videoAudioCodec&scopeName=aac&type=upperBound&name=audio.channels&value=6&replace=true)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=mp3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=ac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=eac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=dca)+add-transcode-target(type=subtitleProfile&context=streaming&protocol=http&container=mkv&subtitleCodec=srt)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=mpeg2video)+add-limitation(scope=videoCodec&scopeName=hevc&type=Match&name=video.profile&list=main|main 10)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=hevc)+add-limitation(scope=videoCodec&scopeName=*&type=NotMatch&name=video.anamorphic&value=999&replace=true)

    overriding all sorts of limitations. I haven't found a consistent way around it, but I also want to force transcoding, but each time the server's decision becomes 'direct play'.

    Wow, great answer, hopefully the plex team can use this information to fix this. A temporary fix is to downgrade if you haven't already done that. I downgraded to 6.1.1.656 and everything works as expected.

  • lazi3b0ylazi3b0y Posts: 6Members, Plex Pass Plex Pass
    edited June 28

    @yeyeoke said:

    @mmmooo said:
    I'm doing the same w/ the android xml, its worse then ignoring android.xml, and technically it isn't even. Regardless of what you have the 'direct play' option set to (auto, force or disable), the client passes:

    "VERBOSE - * directPlay => 1"

    The reason your android.xml (and mine) previous fix isn't working is that the new version of the app now passes:

    add-limitation(scope=videoCodec&scopeName=h264&type=upperBound&name=video.level&value=51)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.width&value=3840&replace=true)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.height&value=2160&replace=true)+add-limitation(scope=videoAudioCodec&scopeName=aac&type=upperBound&name=audio.channels&value=6&replace=true)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=mp3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=ac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=eac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=dca)+add-transcode-target(type=subtitleProfile&context=streaming&protocol=http&container=mkv&subtitleCodec=srt)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=mpeg2video)+add-limitation(scope=videoCodec&scopeName=hevc&type=Match&name=video.profile&list=main|main 10)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=hevc)+add-limitation(scope=videoCodec&scopeName=*&type=NotMatch&name=video.anamorphic&value=999&replace=true)

    overriding all sorts of limitations. I haven't found a consistent way around it, but I also want to force transcoding, but each time the server's decision becomes 'direct play'.

    Wow, great answer, hopefully the plex team can use this information to fix this. A temporary fix is to downgrade if you haven't already done that. I downgraded to 6.1.1.656 and everything works as expected.

    I just noticed this as well... Really frustrating when you've been trying to get something too work for a couple of hours and then realizes that the xml is pretty much overridden.

    Are you sure that the version you've downgraded too is 6.1.1.656? Cause that's the version I have at the moment and it seems too be the latest version that I can get my hands on.

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass

    @lazi3b0y said:

    @yeyeoke said:

    @mmmooo said:
    I'm doing the same w/ the android xml, its worse then ignoring android.xml, and technically it isn't even. Regardless of what you have the 'direct play' option set to (auto, force or disable), the client passes:

    "VERBOSE - * directPlay => 1"

    The reason your android.xml (and mine) previous fix isn't working is that the new version of the app now passes:

    add-limitation(scope=videoCodec&scopeName=h264&type=upperBound&name=video.level&value=51)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.width&value=3840&replace=true)+add-limitation(scope=videoCodec&scopeName=&type=upperBound&name=video.height&value=2160&replace=true)+add-limitation(scope=videoAudioCodec&scopeName=aac&type=upperBound&name=audio.channels&value=6&replace=true)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=mp3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=ac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=eac3)+add-transcode-target-audio-codec(type=videoProfile&context=streaming&protocol=hls&audioCodec=dca)+add-transcode-target(type=subtitleProfile&context=streaming&protocol=http&container=mkv&subtitleCodec=srt)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=mpeg2video)+add-limitation(scope=videoCodec&scopeName=hevc&type=Match&name=video.profile&list=main|main 10)+append-transcode-target-codec(type=videoProfile&context=streaming&protocol=hls&videoCodec=hevc)+add-limitation(scope=videoCodec&scopeName=*&type=NotMatch&name=video.anamorphic&value=999&replace=true)

    overriding all sorts of limitations. I haven't found a consistent way around it, but I also want to force transcoding, but each time the server's decision becomes 'direct play'.

    Wow, great answer, hopefully the plex team can use this information to fix this. A temporary fix is to downgrade if you haven't already done that. I downgraded to 6.1.1.656 and everything works as expected.

    I just noticed this as well... Really frustrating when you've been trying to get something too work for a couple of hours and then realizes that the xml is pretty much overridden.

    Are you sure that the version you've downgraded too is 6.1.1.656? Cause that's the version I have at the moment and it seems too be the latest version that I can get my hands on.

    Yeah I just checked it's the right one. If you want to try a different version, here's all the apk's; http://www.apkmirror.com/apk/plex-inc/

  • mobartonmobarton Posts: 41Members Plex Pass

    Did you try shutting off 'Play Smaller Videos at Original Quality'? I has similar issue with a couple channels that would not transcode, turning this off fixed it.
    I opened a new discussion https://forums.plex.tv/discussion/277767/play-smaller-videos-at-original-quality-messes-up-some-channels#latest on that setting.

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass

    Today I tried to update the plex-app to the latest version, surely the team should've been able to resolve this issue by now, unfortunately they haven't. I've tried disabling all the new settings, such as "Play smaller videos at original quality" as well as trying to experiment with every combination I could think of. The only thing that works ight now is to downgrade the plex-app and disable automatic updates.

  • yeyeokeyeyeoke Posts: 40Members, Plex Pass Plex Pass
    Accepted Answer

    Newest Plex-app for Android TV fixed all the previous issues. There is no longer any need for a modified Android.xml.

  • mmmooommmooo Posts: 13Members, Plex Pass Plex Pass

    I think its better, but not for me. Its still not fully respecting direct play being disabled. And with direct play, eac3 still fails (the same w/ the previous video is faster then audio issue). That said my usual hack for android.xml seems to work again, and interestingly, the info shows that video still direct plays, just the audio is transcoded. So a step in the right direction.

  • mmmooommmooo Posts: 13Members, Plex Pass Plex Pass

    and false hope, still getting forced direct play, even with direct play disabled.

  • bobcobobco Posts: 16Members, Plex Pass Plex Pass
  • ipokampoipokampo Posts: 5Members ✭✭

    @mmmooo i have the same issue. In my philips android tv i needed to force transcoding mostly everything as all i play is mkv with ac3 5.1 and the tv is not capable of playing it, only shows a black screen. I've fixed it in previous versions editing the Android.xml file adding a restriction on both ac3, and eac3 to bitrate = 1, and that somehow did the trick to force transcoding, but now that trick is not working anymore, so i end up with everything being direct played, which the tv does not support so all my videos just show black and i can just hear the sound....
    Today i'll try to downgrade to the 6.1.1 version to see if it helps...

  • ipokampoipokampo Posts: 5Members ✭✭

    Update: I tried the downgraded 6.1.1 version, but did not help. Somehow everything keeps being direct played. I've tried reinstalling the server, rebooting both client and server, i don't know what else to do.
    My vids keep on direct stream which doesnt work with my tv.
    As always has happened for this tv, for mkv with ac3 5.1, audio works but image freeze after 1sec. The old workaround rewriting the Android.xml profile does not work anymore.
    Stucked with this situation. I need to be able to transcode my videos to my android tv, please help

  • mmmooommmooo Posts: 13Members, Plex Pass Plex Pass

    @ipokampo said:
    Update: I tried the downgraded 6.1.1 version, but did not help. Somehow everything keeps being direct played. I've tried reinstalling the server, rebooting both client and server, i don't know what else to do.
    My vids keep on direct stream which doesnt work with my tv.
    As always has happened for this tv, for mkv with ac3 5.1, audio works but image freeze after 1sec. The old workaround rewriting the Android.xml profile does not work anymore.
    Stucked with this situation. I need to be able to transcode my videos to my android tv, please help

    note sure why anyone said 6.1.1 would fix it, you need 6.0.1 (or earlier) to go back to 'the way it used to be'.

Sign In or Register to comment.