If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Direct Play Audio Track not changeable (SAMSUNG)

Never had this problem before (using Plex for maybe 6month+).
Happens to all formats available to me (ac3 dts / mp4 mkv).
The TV App shows all languages, I can select them but it doesn't change the audio track. Changing via PC "Now playing" doesn't work either.
It defaults to audio track 1
When I disable DTS(DCA) under settings in the TV App and Plex starts transcoding the correct audio plays.
Windows Plex 3.9.1
Samsung Plex (3.1.0(3.8.0))
Reinstalled Plex on both systems and tried to change settings without success.
Can anyone replicate this? Has there been a recent update?

Best Answer

«1

Answers

  • lctr01lctr01 Posts: 1Members

    I started experiencing this just after getting a Plex update tonight on my Samsung tv.
    Literally, a movie was playing in one language - I exited from Plex to check something else, started Plex again, got prompted with an update, and after then I wasn't able to change language anymore, in the same movie or any movie at all.

    As you mentioned, by forcing encoding, it works (e.g. applying a subtitle). I can replicate it with DD, DTS and AC3

    Plex 3.1.0 (3.8.0)
    Tizen 2.4.0 (UE65KS9500)
    Plex server Version 1.5.5.3634

  • MirxMirx Posts: 33Members ✭✭
    edited July 3

    Same here.

    And to make things even worse, the subtitle transcoding also seems to have deteriorated, so turning on subs will constantly buffer.

    Edit: Turning direct play off and disable subtitles will also trigger transcoding and play the correct audio track. The transcoder is only utilizing 2,9% CPU with plenty of spare on my Synology, but it still buffers and staff like mad making it unusable. Seems worse on high bitrate files.

    Disabling direct stream will trigger the full transcoder, which my synology isn't powerfull enough for.

  • dscox75@me.comdscox75@me.com Posts: 2Members, Plex Pass Plex Pass

    I have this issue too and it’s incredibly frustrating! Can we please get an update on when plex for tizen will be fixed? Mirx, thanks so much for the work around, it’s “back to normal” now. But, shouldn’t have happened in the first place.

  • wh0ootwh0oot Posts: 4Members ✭✭

    @Mirx said:
    Disabling direct stream will trigger the full transcoder, which my synology isn't powerfull enough for.

    Transcoding DTS buffers constantly for me too, the difference is I'm currently running Plex over LAN on a 4,5Ghz i7 processor. Processing speed doesn't seem to be the problem here.

  • ThesnipergeckoThesnipergecko Posts: 2Members

    I am getting this issue too now on my Samsung KS8000. Hopefully there will be a quick fix for it.

  • hexhex666hexhex666 Posts: 6Members ✭✭

    Dear Plex Team,

    please fix this issue.

  • CT1991CT1991 Posts: 5Members, Plex Pass Plex Pass

    Any news on fixing the bug?

  • mbze430mbze430 Posts: 130Members, Plex Pass Plex Pass

    this was reported a month ago, and no "Employee" seems to care or have any updates on a fix. That's call quality service.

  • SifjarSifjar Posts: 2Members, Plex Pass Plex Pass
    edited August 9

    Same issue here. Samsung KS9000. MKV264 with about 8 tracks of audio within in different formats (AAC, AC3, DTS). No matter which track i choose same is playing. Strange thing is that this bug appear not everywhere. I am watching GoT and in first 4 seasons everything was fine, but whole 5 season is bugged. Tried change flags in MKV. Tried converting episode to another audio codec. Tried repack MKV. Nothing helping.
    And this appear only on TV. On my S8, iPad, Windows App and Web client it's all working great.

    The only solutuon is to turn Direct Play off. Then it's working. But well, my Qnap start to hurt itself :)

  • wh0ootwh0oot Posts: 4Members ✭✭

    @Sifjar said:
    The only solutuon is to turn Direct Play off. Then it's working. But well, my Qnap start to hurt itself :)

    Since there is no fix for this yet you can always change the default or forced audio track to the one you want.
    I use MKVToolNix (works on other formats too) and simply delete the audio tracks I don't need, takes a couple of minutes for big files

  • mrgregb123mrgregb123 Posts: 1Members

    Have the same issue. Its a big-time bug in the software. I've had movies where it straight-up won't play english unless you turn subtitles on. Really weird stuff. Just started happening a month or so ago. The MKVTool is nice as a workaround in the meantime.

  • CT1991CT1991 Posts: 5Members, Plex Pass Plex Pass

    @mrgregb123 said:
    Have the same issue. Its a big-time bug in the software. I've had movies where it straight-up won't play english unless you turn subtitles on. Really weird stuff. Just started happening a month or so ago. The MKVTool is nice as a workaround in the meantime.

    Once you turn on subtitles it won't direct play any more, which means it will transcode and that makes it possible to change the aufio track, so it's not weird. But to transcode isn't an acceptable solution since it has worked before the latest update.

    The main problem is that direct play force always the first audio track to play - no matter which one that is. In my case it's most of the time english, sometimes german. It's not possible to change the audio track while direct play is turned on. Thats it. And that sucks.

    Please Plex Team we need to get this fixed!

  • dadebuedadebue Posts: 1Members, Plex Pass Plex Pass
    edited August 27

    Same problem hereon my UE7090. This is so annoying :neutral: PLEASE fix this soon as it was working in previous versions!!!

  • kingfridaykingfriday Posts: 1Members, Plex Pass Plex Pass

    Same issue on Samsung ks8000 I cannot select audio track, it pretty much renders Plex useless to me on the TV.

  • ThesnipergeckoThesnipergecko Posts: 2Members

    @wh0oot said:

    @Sifjar said:
    The only solutuon is to turn Direct Play off. Then it's working. But well, my Qnap start to hurt itself :)

    Since there is no fix for this yet you can always change the default or forced audio track to the one you want.
    I use MKVToolNix (works on other formats too) and simply delete the audio tracks I don't need, takes a couple of minutes for big files

    Given up waiting for a fix for this now, decided to try the above. Worked a treat for me. Thanks for the suggestion. Even worked with my 4K files.

  • nickimannickiman Posts: 61Members, Plex Pass Plex Pass

    Hi,
    Same issue here also. This is the scenario:

    Plex 3.1.0 (3.8.0)
    Tizen 2.4.0 (UE40KU6400)
    Plex server Version 1.8.4.4249

    I hope the fix can arrive soon...

    QNAP NAS TS-453Pro FW: QTS4.3.3 Plex Media Server Version 1.9.4.4325
    Plug-Ins: tvheadend-ng; wmc2plex; pelisalacarta; tvalacarta
    3rd Party: Plexpy (Qnap package); PlexEmail; PlexRequests (Qnap package)
    Raspberry Pi 2 with LibreELEC (stable) Kodi Addon Version 0.1.2
    Windows 7 (64 bits) Plex Home Theater Ver. 1.5.1 with AEON Nox skin

  • Bernd1234Bernd1234 Posts: 3Members

    Same problem here!

  • archlamearchlame Posts: 1Members, Plex Pass Plex Pass

    Same issue, setup:
    Plex 3.1.0 (3.8.0)
    Tizen 2.4.0 (UE49KS7500)
    Plex server Version 1.9.2.4285
    Yamaha AV reciever

  • take31415take31415 Posts: 2Members

    Same issue, setup:
    Plex 3.1.0 (3.8.0)
    Tizen 2.4.0 (UE55KS7090)

    This thread is marked as answered. Maybe the admins don't look at it anymore?
    It's getting really frustrating now. I'm already thinking about downgrading my Samsung TV and lose my warranty.

«1
Sign In or Register to comment.