If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

DVR transcoding stalls at "100% Recorded"

TogmahonTogmahon Posts: 8Members, Plex Pass Plex Pass
edited September 12 in FreeBSD

Last week, I've started to move from using an EyeTV recording OTA shows on my Mac to using the Plex DVR with an HDHomeRun on FreeNAS (still OTA). I've had a couple of problems, one that eventually had me restart Plex. I wish I had captured images, but will describe what I can.

After a few days of DVR with a lot of items on the schedule, I noticed no new recordings were showing up. When I went to the Recording Schedule screen, there were 1 show on the previous day and 8ish shows on this day listed with a red dot and circle (if I recall correctly). It wasn't the in-progress indicator, so I guessed it was the transcoder. Clicking on one of these described the show with something like "recorded" or "record complete".

After clicking around the GUI and trying to play something on my iPhone (couldn't play anything), Plex started have problems. The Recording Schedule screen would no longer update, only showing a message that there was a problem.

I logged into FreeNAS and saw there were two transcodes in process, one being the first show with the icon I didn't recognize.

In the end, I restarted Plex, which took an extra long time to come up, but flushed the shows that were in this state and started working normally again.

My FreeNAS CPU is aging, so I suspect Plex was trying to transcode too much at one time for it. Under Plex -> Settings -> Server -> Transcoder, I changed "Transcoder quality" from Automatic to "Prefer Higher Speed Encoding" and "Maximum simultaneous video transcode" from 4 to 1.

Is there anything else I should tweak? Is there anything else I could've done to recovered and not lose recordings?

Edit: renamed Title to better reflect the issue

«13

Answers

  • TogmahonTogmahon Posts: 8Members, Plex Pass Plex Pass

    The symbol was the 100% recording mark as shown in the image.

    I may have come across something else trying to figure this out. As the first image shows, "Forces of Nature" is 100% recorded, but is not done. "top" and "ps" shows the DVR recording is being transcoded.

    I have Optimization Settings to convert recorded shows. On the Conversion screen, the "Sewing with Nancy" show's conversion is in progress. I clicked the Conversion's [Pause] button. Checking "top", the "Forces of Nature" transcode process dropped to 0% CPU, while the conversion process kept going.

    Its a reach, but perhaps the original problem was that optimization conversions take priority over DVR transcodings, so those processes were essentially starved.

    Still digging...

  • SirGioSirGio Posts: 72Members, Plex Pass Plex Pass

    I've been having this issue for a while.

    Mac OS 10 ||| 3 GHz Intel Core i7 ||| 16 GB 1600 MHz DDR3 ||| Intel Iris 1536 MB
    1TB APPLE SSD Internal ||| Media on external USB3 drives ||| HDHomeRun EXTEND
    Clients - AppleTV4, iOS, Roku3

  • sd1973sd1973 Posts: 5Members, Plex Pass Plex Pass

    enabled Transcoding in my DVR, now I'm getting this as well.

  • NickF1227NickF1227 Posts: 14Members, Plex Pass Plex Pass

    +1, me as well
    Except I get a bunch of other weird things too, like I'll get this problem and if I don't notice it the transcoder stops working in general. Outlined here:
    https://forums.plex.tv/discussion/283981/plex-30-45-days-after-setup-keeps-having-issues-help

  • johnfeimster@mac.comjohnfeimster@mac.com Posts: 13Members, Plex Pass Plex Pass

    I am having the same issue without using the transcoding as it is recording function. Has anyone found a solution to this?

  • johnfeimster@mac.comjohnfeimster@mac.com Posts: 13Members, Plex Pass Plex Pass

    So after I updated to 1.81 and it has seemed to fix the issue of being stuck at 100%

  • TogmahonTogmahon Posts: 8Members, Plex Pass Plex Pass

    I've had it reoccur with 1.8.1.4139 and 1.8.2.4209. I lost 4-5 days of recordings on the last one. Another example is shown in the image; I'm not sure, but think that one was with 1.8.1.

  • JediArchiveJediArchive Posts: 1Members, Plex Pass Plex Pass

    I'm seeing this as well with my 1.8.4.4249 server running on Linux capturing recordings from an HDHomeRun Connect. There are currently 17 shows over the last three days that are stuck at "Recording - 100% complete". They don't yet appear in the DVR library because Plex is apparently doing some final processing on them. I could restart the server, but I'm afraid I'd lose those recordings.

    Is there a way to force the recordings to finish so I don't lose them?

  • TogmahonTogmahon Posts: 8Members, Plex Pass Plex Pass

    Restarting does lose the stuck recordings. I've also tried manually killing the stuck transcoder process, but that didn't work, either. The recent release, 1.9.0.4252, has a fix for a transcoder deadlock. I've not read the details, but hopefully it addresses this problem.

  • yan_syan_s Posts: 8Members, Plex Pass Plex Pass

    Every upgrade I do fixes the issue for the first few days but then it starts happening again. I'm currently on 1.9.0 and had a dozen shows in a row at 100%

  • jlibesjlibes Posts: 4Members, Plex Pass Plex Pass

    Same for me... once a recording gets stuck at "recording 100% complete" all subsequent recordings have the same issue until I restart (and I lose the recordings). The problem did not go away for me after I upgraded to Media Server 1.9.0.4252. My tuner is an HDHomeRun Extend by the way.

    This is a newer issue for me though. It might be coincidence, but I did not have this issue until after the Live TV feature was added to the AFTV in early September. Before that, I had many months of [mostly] issue-free DVRing. I feel like the problem has often (or always) occurred sporadically after I watch a program via Live TV that is also a scheduled recording in the DVR. The ability to watch a DVRed show while it is still recording is a key enhancement for me (I'm not sure if that's even supported), but I can't help but wonder if it's related to the issue.

  • jlibesjlibes Posts: 4Members, Plex Pass Plex Pass

    Sorry, didn't realize this was a FreeBSD topic. My issue is on the Windows server.

  • yan_syan_s Posts: 8Members, Plex Pass Plex Pass

    I'm on OS X.. btw I changed my settings to not transcode at all and keep the original settings, and I'm still experiencing the issue.

  • troglio1969@gmail.comtroglio1969@gmail.com Posts: 1Members, Plex Pass Plex Pass

    Any Fix on this problem or any support? I have been having exactly what is described really, getting frustrated. Thanks for any help that i get.

  • matterpromatterpro Posts: 26Members, Plex Pass Plex Pass

    +1 for me on both NAS and Nvidia Shield. Wife is not happy with Fall TV starting.

    Running 1.9.0.4252 with HDhomerun connect primarily on a WD PR4100 NAS, but it also happens when using Shield as the server.

  • skywalkthisskywalkthis Posts: 1Members, Plex Pass Plex Pass

    Same issue. Fresh install of Ubuntu & Plex version 1.9.1.4272.

    Recordings stall at 100%.

  • jamesbiglerjamesbigler Posts: 8Members, Plex Pass Plex Pass

    For me, I don't have transcoding explicitly, but since the change to mkv format files from the native TS files, there is always a "transcoding" step whether I want one or not.

    From my experience the transcoding step is buggy and hangs. I would like to move back to no transcoding by default, or at least have a mechanism of "rescuing" hung recordings.

    I just lost 3 days of recording to this, and I was on plex server 1.7 something or other. I'm going to try a newer version, but until they stop transcoding by default, I don't think this will be fixed.

  • vfishvfish Posts: 1Members, Plex Pass Plex Pass

    Same issue here running 1.8.3 on OSX. Also anybody else notice that on the IOS app it show weird % values

  • rminajewrminajew Posts: 3Members, Plex Pass Plex Pass
    edited September 28

    Same issue here even after upgrading to 1.9.1. Works one day then next day all recordings get hung up at 100%.
    Rebooted my NAS and all shows disappeared but about an hour later 2/6 are now in the Recorded Show Folder.

  • mwkaratesho@gmail.commwkaratesho@gmail.com Posts: 1Members, Plex Pass Plex Pass

    I use an hdhomerun extend and I have just recently started to have the same issues.
    Recording 2154% complete see image. I’ve checked the status of hdhomerun, firmware up to date. Plex version up to date. Anyone find a fix?

«13
Sign In or Register to comment.