If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Unable to Load Plex Home Settings - Embedded Build

evanrichevanrich Posts: 46Members, Plex Pass Plex Pass

So I've already read the comments here: https://forums.plex.tv/discussion/216587/unable-to-load-plex-home-settings-embedded-build

and didn't see a resolution in that post, so I'm opening a new one.

platform: intel nuc7i3bnbk
HDD: Corsair Mp500 240GB m.2
RAM: 4GB
PMP: Latest (1.3.4.699-1d4f6da1)

I've got the exact same problem posted in the issue above, and believe it to be caused by the network taking too long to come up, here's an excerpt from the logs:

2017-07-03 23:29:27 [ INFO ] JS: [Connections] Retrying connection tests for Evan's Plex Media Server in 2 seconds
2017-07-03 23:29:27 [ INFO ] JS: [Connections] Testing connection for Evan's Plex Media Server at https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400/
2017-07-03 23:29:27 [ INFO ] JS: [Connections] Testing connection for plex.tv at https://plex.tv/pms/:/ip
2017-07-03 23:29:27 [ INFO ] JS: [Connections] Evan's Plex Media Server is unavailable at https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400/ (Status 0)
2017-07-03 23:29:27 [ INFO ] JS: [Connections] Prevented fallback to insecure connection for Evan's Plex Media Server
2017-07-03 23:29:27 [ INFO ] JS: [Connections] All connections to Evan's Plex Media Server failed
2017-07-03 23:29:27 [ INFO ] JS: [Servers] Found all servers = (none)
2017-07-03 23:29:27 [ INFO ] JS: [Connections] plex.tv is unavailable at https://plex.tv/pms/:/ip (Status 0)
2017-07-03 23:29:27 [ INFO ] JS: [Connections] All connections to plex.tv failed
2017-07-03 23:29:28 [ INFO ] JS: [Connections] Browser online status changed to true
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Testing all 1 connection(s) for plex.tv
2017-07-03 23:29:30 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Retrying connection tests for plex.tv in 3 seconds
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Testing all 1 connection(s) for Evan's Plex Media Server
2017-07-03 23:29:30 [ INFO ] JS: [Servers] Waiting for pending servers = Evan's Plex Media Server
2017-07-03 23:29:30 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Retrying connection tests for Evan's Plex Media Server in 3 seconds
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Testing connection for Evan's Plex Media Server at https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400/
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Testing connection for plex.tv at https://plex.tv/pms/:/ip
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Evan's Plex Media Server connected at https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400/
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Active connection to Evan's Plex Media Server is https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400
2017-07-03 23:29:30 [ INFO ] JS: [Servers] Found all servers = Evan's Plex Media Server
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Adding possible loopback connection for Evan's Plex Media Server
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Added connection http://127.0.0.1:32400 for Evan's Plex Media Server
2017-07-03 23:29:30 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Testing connection for Evan's Plex Media Server at http://127.0.0.1:32400/
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Evan's Plex Media Server is unavailable at http://127.0.0.1:32400/ (Status 0)
2017-07-03 23:29:30 [ INFO ] JS: [Connections] plex.tv connected at https://plex.tv/pms/:/ip
2017-07-03 23:29:30 [ INFO ] JS: [Connections] Active connection to plex.tv is https://plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing all 1 connection(s) for [Loopback]
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Waiting for initial servers = [Loopback]
2017-07-03 23:29:31 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing all 2 connection(s) for Evan's Plex Media Server
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Waiting for initial servers = [Loopback]
2017-07-03 23:29:31 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:31 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing all 1 connection(s) for plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing connection for Evan's Plex Media Server at http://127.0.0.1:32400/
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing connection for Evan's Plex Media Server at https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400/
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing connection for plex.tv at https://plex.tv/pms/:/ip
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Testing connection for [Loopback] at http://127.0.0.1:32400/
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Evan's Plex Media Server is unavailable at http://127.0.0.1:32400/ (Status 0)
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Evan's Plex Media Server connected at https://192-168-1-20.452180b08dfb4ac38a52c587837171ab.plex.direct:32400/
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Waiting for initial servers = [Loopback]
2017-07-03 23:29:31 [ INFO ] JS: [Connections] [Loopback] is unavailable at http://127.0.0.1:32400/ (Status 0)
2017-07-03 23:29:31 [ INFO ] JS: [Connections] All connections to [Loopback] failed
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Found all servers = Evan's Plex Media Server, plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Finding resources through plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Waiting for additional resources from plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [CloudServerEventManager] Opening server event connection to plex.tv at wss://pubsub.plex.tv/sub/websockets/10572780/ok2d8lchczacit6h3pj76tj4?X-Plex-Token=REDACTED
2017-07-03 23:29:31 [ INFO ] JS: [Companion] Registering player with plex.tv, clientID="ok2d8lchczacit6h3pj76tj4"
2017-07-03 23:29:31 [ DEBUG ] SettingsComponent.cpp @ 140 - Updated possible values for: "updateChannel" to (QVariant(QVariantMap, QMap(("title", QVariant(QString, "Stable"))("value", QVariant(int, 0)))), QVariant(QVariantMap, QMap(("title", QVariant(QString, "PlexPass"))("value", QVariant(int, 8)))))
2017-07-03 23:29:31 [ INFO ] JS: [Connections] plex.tv connected at https://plex.tv/pms/:/ip
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Active connection to plex.tv is https://plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [Servers] Evan's Plex Media Server was found through plex.tv
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Added connection https://71-198-106-179.452180b08dfb4ac38a52c587837171ab.plex.direct:20713 for Evan's Plex Media Server
2017-07-03 23:29:31 [ INFO ] JS: [Commands] Executing testServerConnection
2017-07-03 23:29:31 [ INFO ] JS: [Connections] Added connection https://184-105-148-103.452180b08dfb4ac38a52c587837171ab.plex.direct:8443 for Evan's Plex Media Server

I can see it try to connect, fail, succeed, fail, and finally succeed again. I've tried setting a 10 second delay per the following link: https://forums.plex.tv/discussion/comment/1041985/
but that doesn't seem to make a difference. I did modify the instructions since it said to place the file in the "openelec" directory, but only a "libreelec" folder exists, but dont think that's why it's failing.

Anyone know if there's an updated method of making PMP wait for networking before continuing? while hitting the "back" button on my remote allows me to get in, the message is slightly annoying. Log attached. the Plex server is local on my network, no other client has access problems.

  • HTPC: Intel NUC7I3BNBK (Plex Media Player)
  • Firewall/Router: Ubiquiti USG
  • Core Switch: US-48-500W POE
  • AP: Ubiquiti AP-AC-PRO + IW-AP-AC
  • NAS: Supermicro X11-SSL-F / Intel E3-1230v5 / 32GB DDR4 / SC826 12-bay Chassis/12x 4TB WD red RAID-Z2 / Intel 120GB DC-S3500 ZIL / Avago 9211-8i HBA / Intel X520 10GbE / FreeNAS 9.10

Answers

  • evanrichevanrich Posts: 46Members, Plex Pass Plex Pass

    As a possible solution, enabling "allow fallback to insecure connections: Always" seems to have possibly fixed it... will perform more testing.

    • HTPC: Intel NUC7I3BNBK (Plex Media Player)
    • Firewall/Router: Ubiquiti USG
    • Core Switch: US-48-500W POE
    • AP: Ubiquiti AP-AC-PRO + IW-AP-AC
    • NAS: Supermicro X11-SSL-F / Intel E3-1230v5 / 32GB DDR4 / SC826 12-bay Chassis/12x 4TB WD red RAID-Z2 / Intel 120GB DC-S3500 ZIL / Avago 9211-8i HBA / Intel X520 10GbE / FreeNAS 9.10
  • evanrichevanrich Posts: 46Members, Plex Pass Plex Pass

    forgot to update this...still does this...workaround is to just leave the intel NUC on..while not a huge concern, it's annoying.

    • HTPC: Intel NUC7I3BNBK (Plex Media Player)
    • Firewall/Router: Ubiquiti USG
    • Core Switch: US-48-500W POE
    • AP: Ubiquiti AP-AC-PRO + IW-AP-AC
    • NAS: Supermicro X11-SSL-F / Intel E3-1230v5 / 32GB DDR4 / SC826 12-bay Chassis/12x 4TB WD red RAID-Z2 / Intel 120GB DC-S3500 ZIL / Avago 9211-8i HBA / Intel X520 10GbE / FreeNAS 9.10
Sign In or Register to comment.