If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Surround Sound Problems

I started noticing that a large portion of my library has some issues playing back media when NOT using my surround sound system. This always worked in the past, although I recently updated to Android 7 (from 6). My setup is as follows: a Nexus Player connected to a Marantz NR-1403 Receiver, which is then connected to my LG 47LV500 TV. Typically, I don't actually use the surround sound and set the Marantz' standby connection to route directly to the TV. For the past several years this has worked fine. With the receiver off, I would watch Plex and the TV would output transcoded stereo. Now, however, when I try to play content this way, I get a generic Plex failed to play this media error (not sure offhand of the EXACT message) but I didn't see anything in the logs related to it.

After messing around with the config somewhat, I found an option the Android TV settings for Sound, called Surround Sound. It was set to "Auto". I noticed that when I change that setting to "Always", the content will play fine, but every few minutes there will be some audio distortion. It's better than not being able to watch things at all, but ideally I'd like it to function the way it did on 6.0. I'm thinking about downgrading and figuring out a way to block future updates to the OS, but before that wanted to see if others came across the same issue and had a better solution.


  • breakthestaticbreakthestatic Posts: 11Members ✭✭

    As a quick update, I found that files with AC3 audio are the ones that won't play. EAC3 play fine however. I'd rather not disable pass-through because I'd like my receiver (when I use it) to decode the audio.

Sign In or Register to comment.