If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Sync very, very slow and regular fails

I have an up to date Plex Media Server running on a Linux server. I can sync with no problem to my Android devices. Sync is horribly slow to the point of being useless.

Conversion completes okay, then transfer starts. Monitoring network usage, the speed looks suspiciously identical to what the uplink speed would be on my ADSL connection (which is slow being in a rural area). After a while the app then usually fails with ""tranfer failed, network error" at some point long before a single transfer has copied over.

Network access from the server to the PC works just fine with files regularly copied each way.

As another data point, I just tried playing "live" from the server, and got a message my connection was not fast enough for the content. That also implies it is somehow trying to go over my uplink and not doing direct play. Direct Play works just fine on my Smart TV (on the same network) and other forms of file transfer from the PC happen at a decent rate.

What is going on?

Answers

  • martinbainesmartinbaines Posts: 9Members, Plex Pass Plex Pass

    Just to be clear - the problem is occurring with the Windows 10 App from the App Store.

  • missionspartamissionsparta Posts: 233Validating, Plex Pass Plex Pass

    If you read through the threads, the issue most likely has nothing to do with you. Someone would have to go through your logs if you posted them, but odds are high it is a problem with the mess this app has been in for sometime. I have multiple iOS, multiple Android, and multiple Windows devices using UWP all on the same network syncing from the same server. The iOS and Android devices sync without a hitch. Every single UWP device hangs, crashes, etc when trying to sync. Good luck my friend.

  • martinbainesmartinbaines Posts: 9Members, Plex Pass Plex Pass

    I suspect that, but none of the other threads seem to have any interaction at all from anyone in Plex responding. It would be good to get some actual response even it it just say "sorry, we know, we are fixing it".

    Right now on Windows Plex client is not fit for purpose as far as I can tell. Like you, I have zero issue with my Android clients - I can't comment on iOS as I have none.

    Is anyone from Plex here, listening and would like to comment?

  • missionspartamissionsparta Posts: 233Validating, Plex Pass Plex Pass

    @martinbaines said:
    I suspect that, but none of the other threads seem to have any interaction at all from anyone in Plex responding. It would be good to get some actual response even it it just say "sorry, we know, we are fixing it".

    Right now on Windows Plex client is not fit for purpose as far as I can tell. Like you, I have zero issue with my Android clients - I can't comment on iOS as I have none.

    Is anyone from Plex here, listening and would like to comment?

    I have a thread in this section about Plex and their customer service and lack of communication with their customers, in particular the Windows Apps. It took me pissing many times, but someone from Plex finally responded that this app is a priority and things are being worked on. Only off party was that it seemed to be from a random employee and not someone who is actually working on this app, but obviously it could be someone new to this app. Either way, it's sad how neglected suck a popular ecosystem like Windows has been left to become this poorly running. My hope at this point is they realize it does not run the way it should and doesn't represent the quality they want to emulate and maybe they are remaking it from ground up.

  • Guglielmo.CorniniGuglielmo.Cornini Posts: 13Members, Plex Pass Plex Pass

    I have the same exact problem.
    This app seems to use the WAN interface, there is any way to force the LAN connection?
    The performance are similar to the upload of my vdsl fiber: 20Mbps.
    i've tried to edit the server settings on the app, but there is no way.
    i've tried to set in plex advanced network settings the local LAN address https://support.plex.tv/hc/en-us/articles/200430283-Network but nothing, is there any update for this problem?
    Thanks.

  • moody_bluemoody_blue Posts: 2,921Members, Plex Pass, Plex Ninja Plex Ninja

    If you have DNS Rebinding Protection active this would be the expected behaviour.

    QNAP TS-253A 4G QTS 4.3.4.0411 (beta3) + PMS 1.10.1.4561 (beta) + QPython2 2.7.12.0 + PlexConnect 0.5-dev-161017

    TV Sony KDL-32V2500 (720p) + aTV3 Rev. A firmware 7.2.2 + Denon AVR-1604 A/V Receiver 5.1 + Harmony Touch

    Portables 1x iPad4, 2x Android phone, 1x Android tablet, 2x PMP on Win10

    No support via PM unless requested by me

Sign In or Register to comment.