If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Plex Media Server on Nighthawk X10 R9000 wont connect to Synology NAS

regalmeregalme Posts: 8Members, Plex Pass Plex Pass

Whenever I try to connect my Netgear X10 to a folder on my Synology NAS I get the message "Your router can't connect to your network drive because of network errors.


  • JamminRJamminR Posts: 3,480Members, Plex Pass Plex Pass

    Is there a way to test inside your X10 admin panel that it has access to \your_synology_server\share\path?
    If it does, then you should be able to enter that in folder access in Plex.

    Server - HW: I7-4790K(Haswell), 16GB - SW: Win10 Pro + PMS v1.13.0.5003
    Misc. HW: HDHR Extend + 2TB RAID1(Intel Z87) + 4x4TB RAID5(QNAP TS-653Pro)
    Shares - From: 2  - To: 18(5) - Potential lifetime PlexPass data generating product customer!
    ISP: ~20mbps up/1TB monthly "cap" - (Monthly avg. xfer ~450gb)
    Search the Plex WIKI before asking silly questions.
    Plex stuff I favor - Tautulli - UASv3 - PlexEmail - FMoviesPlus
  • regalmeregalme Posts: 8Members, Plex Pass Plex Pass

    It was the firewall on my NAS, disabled the firewall for the IP address of my router and all was fine.

  • jmagazujmagazu Posts: 1Members, Plex Pass Plex Pass

    I am having a similar, when I Add Network Drive Connection from my netgear x10 (R9000) to my synology NAS it never fills in it just takes me back to the "Add Network Drive Connection" again. When I go into plex I can see the name that I gave it, however it does not work. I have checked the firewall on my Synology. Any other Suggestions?

Sign In or Register to comment.