If you have not already, we suggest setting your Plex username to something else rather than email which is displayed on your posts in forum. You can change the username at https://app.plex.tv/desktop#!/account
Welcome to our forums! Please take a few moments to read through our Community Guidelines (also conveniently linked in the header at the top of each page). There, you'll find guidelines on conduct, tips on getting the help you may be searching for, and more!

Can't get Rasplex to see server content

ScaredyCatUKScaredyCatUK Posts: 15Members ✭✭

Rasplex Version 1.7.1.137-b604995c

Server Version 1.7.5.4035

Rasplex shows up in Devices but wont display anything from the server. No libraries show up at all just repeated lines of:

Watch Later
Search

Server in rasplex is configured manually. I can ssh to rasplex, I can telnet from it to port 32400 on the server which returns:

GET /

HTTP/1.1 200 OK
Content-Type: text/xml;charset=utf-8
Content-Length: 2510
Connection: close
X-Plex-Protocol: 1.0
Cache-Control: no-cache
Date: Wed, 12 Jul 2017 20:01:18 GMT

<?xml version="1.0" encoding="UTF-8"?>
<MediaContainer size="24" allowCameraUpload="0" allowChannelAccess="1" allowMediaDeletion="1" allowSharing="1" allowSync="0" backgroundProcessing="1" certificate="1" companionProxy="1" countryCode....

etc

Any ideas as to what's causing the problem?

Answers

  • videotecaCNSUvideotecaCNSU Posts: 290Validating, Plex Pass Plex Pass

    or your rasplex cant find the server and its a network issue, or you arent sharing any content with that user

  • ScaredyCatUKScaredyCatUK Posts: 15Members ✭✭

    Rasplex must be able to see the server if I can telnet to the port and return info. User is the same user as on the server. I've tried with both a pin and manual login on the rasplex end.

  • videotecaCNSUvideotecaCNSU Posts: 290Validating, Plex Pass Plex Pass

    Sorry no idea

    Doesn't seem to be a network issue, doesnt seem to be a ntd / secure login issue
    have you tried other clients to see if the issue is on the server?

  • eckartheckarth Posts: 452Members, Plex Pass Plex Pass

    Check the clock.

  • ScaredyCatUKScaredyCatUK Posts: 15Members ✭✭

    Clock is fine.

    Android client works ok.

  • r00a006r00a006 Posts: 2Members, Plex Pass Plex Pass

    Has anyone come up with a solution. Just installed 1.8.0 on my Pi2. Install went fine and linked to my Plex account fine but do not see libraries, just "search". My Server is at my office the RasPlex is here at my home, is this an issue for RasPlex? My android is working fine from here.

  • JasunJasun Posts: 1Members, Plex Pass Plex Pass

    Happened to me, no matter what I changed, same problem.. phone would connect and work as a remote and so forth.. only thing that fixed it for me was to yank the Ethernet cable out while it was running and plug it back in then everything came back. It's been fine since then

  • r00a006r00a006 Posts: 2Members, Plex Pass Plex Pass

    Sorry. Forgot to post I fixed the issue. My DNS server at the office died. Replaced and now working fine.

Sign In or Register to comment.